www/ruby-pygments.rb - The NetBSD Packages Collection

Pygments wrapper for ruby

# pygments.rb

A Ruby wrapper for the Python [pygments syntax
highlighter](http://pygments.org/).

pygments.rb works by talking over a simple pipe to a long-lived Python child
process. This library replaces
[github/albino](https://github.com/github/albino), as well as a version of
pygments.rb that used an embedded Python interpreter.

Each Ruby process that runs has its own 'personal Python'; for example, 4
Unicorn workers will have one Python process each.  If a Python process dies,
a new one will be spawned on the next pygments.rb request.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

textproc/ruby-multi_json lang/ruby26-base lang/python38 lang/python38

Available binary packages

aarch64:ruby25-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
aarch64:ruby26-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
aarch64:ruby27-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
aarch64:ruby25-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
aarch64:ruby26-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
aarch64:ruby27-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
aarch64:ruby25-pygments.rb-1.2.1nb2.tgz(NetBSD 9.0)
aarch64:ruby26-pygments.rb-1.2.1nb2.tgz(NetBSD 9.0)
aarch64:ruby27-pygments.rb-1.2.1nb2.tgz(NetBSD 9.0)
alpha:ruby25-pygments.rb-1.2.1nb2.tgz(NetBSD 9.0)
alpha:ruby26-pygments.rb-1.2.1nb2.tgz(NetBSD 9.0)
alpha:ruby27-pygments.rb-1.2.1nb2.tgz(NetBSD 9.0)
alpha:ruby25-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
alpha:ruby26-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
alpha:ruby27-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
earmv6hf:ruby25-pygments.rb-1.2.1nb2.tgz(NetBSD 9.0)
earmv6hf:ruby26-pygments.rb-1.2.1nb2.tgz(NetBSD 9.0)
earmv6hf:ruby27-pygments.rb-1.2.1nb2.tgz(NetBSD 9.0)
earmv6hf:ruby25-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
earmv6hf:ruby26-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
earmv6hf:ruby27-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
earmv6hf:ruby25-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
earmv6hf:ruby26-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
earmv6hf:ruby27-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
earmv6hf:ruby25-pygments.rb-1.2.1nb2.tgz(NetBSD 9.0)
earmv6hf:ruby26-pygments.rb-1.2.1nb2.tgz(NetBSD 9.0)
earmv6hf:ruby27-pygments.rb-1.2.1nb2.tgz(NetBSD 9.0)
earmv7hf:ruby25-pygments.rb-1.2.1nb2.tgz(NetBSD 8.0)
earmv7hf:ruby26-pygments.rb-1.2.1nb2.tgz(NetBSD 8.0)
earmv7hf:ruby27-pygments.rb-1.2.1nb2.tgz(NetBSD 8.0)
earmv7hf:ruby24-pygments.rb-1.2.1nb1.tgz(NetBSD 8.0)
earmv7hf:ruby25-pygments.rb-1.2.1nb1.tgz(NetBSD 8.0)
earmv7hf:ruby26-pygments.rb-1.2.1nb1.tgz(NetBSD 8.0)
earmv7hf:ruby27-pygments.rb-1.2.1nb1.tgz(NetBSD 8.0)
earmv7hf:ruby25-pygments.rb-1.2.1nb1.tgz(NetBSD 8.0)
earmv7hf:ruby26-pygments.rb-1.2.1nb1.tgz(NetBSD 8.0)
earmv7hf:ruby27-pygments.rb-1.2.1nb1.tgz(NetBSD 8.0)
earmv7hf:ruby25-pygments.rb-1.2.1nb1.tgz(NetBSD 8.0)
earmv7hf:ruby26-pygments.rb-1.2.1nb1.tgz(NetBSD 8.0)
earmv7hf:ruby27-pygments.rb-1.2.1nb1.tgz(NetBSD 8.0)
earmv7hf:ruby25-pygments.rb-1.2.1nb2.tgz(NetBSD 9.0)
earmv7hf:ruby26-pygments.rb-1.2.1nb2.tgz(NetBSD 9.0)
earmv7hf:ruby27-pygments.rb-1.2.1nb2.tgz(NetBSD 9.0)
earmv7hf:ruby24-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
earmv7hf:ruby25-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
earmv7hf:ruby26-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
earmv7hf:ruby27-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
earmv7hf:ruby25-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
earmv7hf:ruby26-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
earmv7hf:ruby27-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
earmv7hf:ruby25-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
earmv7hf:ruby26-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
earmv7hf:ruby27-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
earmv7hf:ruby25-pygments.rb-1.2.1nb2.tgz(NetBSD 9.0)
earmv7hf:ruby26-pygments.rb-1.2.1nb2.tgz(NetBSD 9.0)
earmv7hf:ruby27-pygments.rb-1.2.1nb2.tgz(NetBSD 9.0)
i386:ruby25-pygments.rb-1.2.1nb1.tgz(NetBSD 8.0)
i386:ruby26-pygments.rb-1.2.1nb1.tgz(NetBSD 8.0)
i386:ruby27-pygments.rb-1.2.1nb1.tgz(NetBSD 8.0)
i386:ruby25-pygments.rb-1.2.1nb1.tgz(NetBSD 8.0)
i386:ruby26-pygments.rb-1.2.1nb1.tgz(NetBSD 8.0)
i386:ruby27-pygments.rb-1.2.1nb1.tgz(NetBSD 8.0)
i386:ruby25-pygments.rb-1.2.1nb2.tgz(NetBSD 8.0)
i386:ruby26-pygments.rb-1.2.1nb2.tgz(NetBSD 8.0)
i386:ruby27-pygments.rb-1.2.1nb2.tgz(NetBSD 8.0)
i386:ruby25-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
i386:ruby26-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
i386:ruby27-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
i386:ruby25-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
i386:ruby26-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
i386:ruby27-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
i386:ruby25-pygments.rb-1.2.1nb2.tgz(NetBSD 9.0)
i386:ruby26-pygments.rb-1.2.1nb2.tgz(NetBSD 9.0)
i386:ruby27-pygments.rb-1.2.1nb2.tgz(NetBSD 9.0)
mips64eb:ruby25-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
mips64eb:ruby26-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
mips64eb:ruby27-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
powerpc:ruby25-pygments.rb-1.2.1nb2.tgz(NetBSD 8.0)
powerpc:ruby26-pygments.rb-1.2.1nb2.tgz(NetBSD 8.0)
powerpc:ruby27-pygments.rb-1.2.1nb2.tgz(NetBSD 8.0)
powerpc:ruby24-pygments.rb-1.2.1nb1.tgz(NetBSD 8.0)
powerpc:ruby25-pygments.rb-1.2.1nb1.tgz(NetBSD 8.0)
powerpc:ruby26-pygments.rb-1.2.1nb1.tgz(NetBSD 8.0)
powerpc:ruby27-pygments.rb-1.2.1nb1.tgz(NetBSD 8.0)
powerpc:ruby24-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
powerpc:ruby25-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
powerpc:ruby26-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
powerpc:ruby27-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
powerpc:ruby24-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
powerpc:ruby25-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
powerpc:ruby26-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
powerpc:ruby27-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
sparc64:ruby25-pygments.rb-1.2.1nb2.tgz(NetBSD 9.0)
sparc64:ruby26-pygments.rb-1.2.1nb2.tgz(NetBSD 9.0)
sparc64:ruby27-pygments.rb-1.2.1nb2.tgz(NetBSD 9.0)
sparc64:ruby25-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
sparc64:ruby26-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
sparc64:ruby27-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
x86_64:ruby25-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
x86_64:ruby26-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
x86_64:ruby27-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
x86_64:ruby25-pygments.rb-1.2.1nb2.tgz(NetBSD 9.0)
x86_64:ruby26-pygments.rb-1.2.1nb2.tgz(NetBSD 9.0)
x86_64:ruby27-pygments.rb-1.2.1nb2.tgz(NetBSD 9.0)
x86_64:ruby25-pygments.rb-2.0.0.tgz(NetBSD 9.0)
x86_64:ruby26-pygments.rb-2.0.0.tgz(NetBSD 9.0)
x86_64:ruby27-pygments.rb-2.0.0.tgz(NetBSD 9.0)
x86_64:ruby25-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
x86_64:ruby26-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
x86_64:ruby27-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
x86_64:ruby25-pygments.rb-1.2.1nb1.tgz(NetBSD 8.0)
x86_64:ruby26-pygments.rb-1.2.1nb1.tgz(NetBSD 8.0)
x86_64:ruby27-pygments.rb-1.2.1nb1.tgz(NetBSD 8.0)
x86_64:ruby25-pygments.rb-1.2.1nb1.tgz(NetBSD 8.0)
x86_64:ruby26-pygments.rb-1.2.1nb1.tgz(NetBSD 8.0)
x86_64:ruby27-pygments.rb-1.2.1nb1.tgz(NetBSD 8.0)
x86_64:ruby25-pygments.rb-1.2.1nb2.tgz(NetBSD 8.0)
x86_64:ruby26-pygments.rb-1.2.1nb2.tgz(NetBSD 8.0)
x86_64:ruby27-pygments.rb-1.2.1nb2.tgz(NetBSD 8.0)
x86_64:ruby25-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
x86_64:ruby26-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
x86_64:ruby27-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
x86_64:ruby25-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
x86_64:ruby26-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
x86_64:ruby27-pygments.rb-1.2.1nb1.tgz(NetBSD 9.0)
x86_64:ruby25-pygments.rb-1.2.1nb2.tgz(NetBSD 9.0)
x86_64:ruby26-pygments.rb-1.2.1nb2.tgz(NetBSD 9.0)
x86_64:ruby27-pygments.rb-1.2.1nb2.tgz(NetBSD 9.0)
x86_64:ruby25-pygments.rb-2.0.0.tgz(NetBSD 9.0)
x86_64:ruby26-pygments.rb-2.0.0.tgz(NetBSD 9.0)
x86_64:ruby27-pygments.rb-2.0.0.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]