www/py-websockets - The NetBSD Packages Collection

Implementation of the WebSocket Protocol (RFC 6455)

websockets is a library for developing WebSocket servers and clients in
Python. It implements RFC 6455 with a focus on correctness and simplicity.
It passes the Autobahn Testsuite.

Built on top of Python's asynchronous I/O support introduced in PEP 3156,
it provides an API based on coroutines, making it easy to write highly
concurrent applications.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

devel/py-setuptools lang/python38 lang/python38

Available binary packages

aarch64:py36-websockets-8.1.tgz(NetBSD 9.0)
aarch64:py37-websockets-8.1.tgz(NetBSD 9.0)
aarch64:py38-websockets-8.1.tgz(NetBSD 9.0)
aarch64:py36-websockets-8.1.tgz(NetBSD 9.0)
aarch64:py37-websockets-8.1.tgz(NetBSD 9.0)
aarch64:py38-websockets-8.1.tgz(NetBSD 9.0)
aarch64:py36-websockets-8.1.tgz(NetBSD 9.0)
aarch64:py37-websockets-8.1.tgz(NetBSD 9.0)
aarch64:py38-websockets-8.1.tgz(NetBSD 9.0)
aarch64:py39-websockets-8.1.tgz(NetBSD 9.0)
alpha:py36-websockets-8.1.tgz(NetBSD 9.0)
alpha:py37-websockets-8.1.tgz(NetBSD 9.0)
alpha:py38-websockets-8.1.tgz(NetBSD 9.0)
alpha:py39-websockets-8.1.tgz(NetBSD 9.0)
alpha:py36-websockets-8.1.tgz(NetBSD 9.0)
alpha:py37-websockets-8.1.tgz(NetBSD 9.0)
alpha:py38-websockets-8.1.tgz(NetBSD 9.0)
alpha:py36-websockets-8.1.tgz(NetBSD 9.0)
alpha:py37-websockets-8.1.tgz(NetBSD 9.0)
alpha:py38-websockets-8.1.tgz(NetBSD 9.0)
earm:py36-websockets-8.1.tgz(NetBSD 9.0)
earm:py37-websockets-8.1.tgz(NetBSD 9.0)
earm:py38-websockets-8.1.tgz(NetBSD 9.0)
earm:py36-websockets-8.1.tgz(NetBSD 9.0)
earm:py37-websockets-8.1.tgz(NetBSD 9.0)
earm:py38-websockets-8.1.tgz(NetBSD 9.0)
earmv6hf:py36-websockets-8.1.tgz(NetBSD 9.0)
earmv6hf:py37-websockets-8.1.tgz(NetBSD 9.0)
earmv6hf:py38-websockets-8.1.tgz(NetBSD 9.0)
earmv6hf:py39-websockets-8.1.tgz(NetBSD 9.0)
earmv6hf:py36-websockets-8.1.tgz(NetBSD 9.0)
earmv6hf:py37-websockets-8.1.tgz(NetBSD 9.0)
earmv6hf:py38-websockets-8.1.tgz(NetBSD 9.0)
earmv6hf:py36-websockets-8.1.tgz(NetBSD 9.0)
earmv6hf:py37-websockets-8.1.tgz(NetBSD 9.0)
earmv6hf:py38-websockets-8.1.tgz(NetBSD 9.0)
earmv6hf:py36-websockets-8.1.tgz(NetBSD 9.0)
earmv6hf:py37-websockets-8.1.tgz(NetBSD 9.0)
earmv6hf:py38-websockets-8.1.tgz(NetBSD 9.0)
earmv6hf:py39-websockets-8.1.tgz(NetBSD 9.0)
earmv7hf:py36-websockets-8.1.tgz(NetBSD 8.0)
earmv7hf:py37-websockets-8.1.tgz(NetBSD 8.0)
earmv7hf:py38-websockets-8.1.tgz(NetBSD 8.0)
earmv7hf:py39-websockets-8.1.tgz(NetBSD 8.0)
earmv7hf:py36-websockets-8.1.tgz(NetBSD 8.0)
earmv7hf:py37-websockets-8.1.tgz(NetBSD 8.0)
earmv7hf:py38-websockets-8.1.tgz(NetBSD 8.0)
earmv7hf:py36-websockets-8.1.tgz(NetBSD 8.0)
earmv7hf:py37-websockets-8.1.tgz(NetBSD 8.0)
earmv7hf:py38-websockets-8.1.tgz(NetBSD 8.0)
earmv7hf:py36-websockets-8.1.tgz(NetBSD 8.0)
earmv7hf:py37-websockets-8.1.tgz(NetBSD 8.0)
earmv7hf:py38-websockets-8.1.tgz(NetBSD 8.0)
earmv7hf:py36-websockets-8.1.tgz(NetBSD 9.0)
earmv7hf:py37-websockets-8.1.tgz(NetBSD 9.0)
earmv7hf:py38-websockets-8.1.tgz(NetBSD 9.0)
earmv7hf:py39-websockets-8.1.tgz(NetBSD 9.0)
earmv7hf:py36-websockets-8.1.tgz(NetBSD 9.0)
earmv7hf:py37-websockets-8.1.tgz(NetBSD 9.0)
earmv7hf:py38-websockets-8.1.tgz(NetBSD 9.0)
earmv7hf:py36-websockets-8.1.tgz(NetBSD 9.0)
earmv7hf:py37-websockets-8.1.tgz(NetBSD 9.0)
earmv7hf:py38-websockets-8.1.tgz(NetBSD 9.0)
earmv7hf:py36-websockets-8.1.tgz(NetBSD 9.0)
earmv7hf:py37-websockets-8.1.tgz(NetBSD 9.0)
earmv7hf:py38-websockets-8.1.tgz(NetBSD 9.0)
earmv7hf:py36-websockets-8.1.tgz(NetBSD 9.0)
earmv7hf:py37-websockets-8.1.tgz(NetBSD 9.0)
earmv7hf:py38-websockets-8.1.tgz(NetBSD 9.0)
earmv7hf:py39-websockets-8.1.tgz(NetBSD 9.0)
i386:py36-websockets-8.1.tgz(NetBSD 8.0)
i386:py37-websockets-8.1.tgz(NetBSD 8.0)
i386:py38-websockets-8.1.tgz(NetBSD 8.0)
i386:py36-websockets-8.1.tgz(NetBSD 8.0)
i386:py37-websockets-8.1.tgz(NetBSD 8.0)
i386:py38-websockets-8.1.tgz(NetBSD 8.0)
i386:py36-websockets-8.1.tgz(NetBSD 8.0)
i386:py37-websockets-8.1.tgz(NetBSD 8.0)
i386:py38-websockets-8.1.tgz(NetBSD 8.0)
i386:py39-websockets-8.1.tgz(NetBSD 8.0)
i386:py36-websockets-8.1.tgz(NetBSD 9.0)
i386:py37-websockets-8.1.tgz(NetBSD 9.0)
i386:py38-websockets-8.1.tgz(NetBSD 9.0)
i386:py36-websockets-8.1.tgz(NetBSD 9.0)
i386:py37-websockets-8.1.tgz(NetBSD 9.0)
i386:py38-websockets-8.1.tgz(NetBSD 9.0)
i386:py36-websockets-8.1.tgz(NetBSD 9.0)
i386:py37-websockets-8.1.tgz(NetBSD 9.0)
i386:py38-websockets-8.1.tgz(NetBSD 9.0)
i386:py39-websockets-8.1.tgz(NetBSD 9.0)
m68k:py37-websockets-8.1.tgz(NetBSD 9.0)
mips64eb:py36-websockets-8.1.tgz(NetBSD 9.0)
mips64eb:py37-websockets-8.1.tgz(NetBSD 9.0)
mips64eb:py38-websockets-8.1.tgz(NetBSD 9.0)
mips64eb:py36-websockets-8.1.tgz(NetBSD 9.0)
mips64eb:py37-websockets-8.1.tgz(NetBSD 9.0)
mips64eb:py38-websockets-8.1.tgz(NetBSD 9.0)
mips64eb:py39-websockets-8.1.tgz(NetBSD 9.0)
powerpc:py36-websockets-8.1.tgz(NetBSD 8.0)
powerpc:py37-websockets-8.1.tgz(NetBSD 8.0)
powerpc:py38-websockets-8.1.tgz(NetBSD 8.0)
powerpc:py39-websockets-8.1.tgz(NetBSD 8.0)
powerpc:py36-websockets-8.1.tgz(NetBSD 8.0)
powerpc:py37-websockets-8.1.tgz(NetBSD 8.0)
powerpc:py38-websockets-8.1.tgz(NetBSD 8.0)
powerpc:py36-websockets-8.1.tgz(NetBSD 9.0)
powerpc:py37-websockets-8.1.tgz(NetBSD 9.0)
powerpc:py38-websockets-8.1.tgz(NetBSD 9.0)
powerpc:py36-websockets-8.1.tgz(NetBSD 9.0)
powerpc:py37-websockets-8.1.tgz(NetBSD 9.0)
powerpc:py38-websockets-8.1.tgz(NetBSD 9.0)
sparc64:py36-websockets-8.1.tgz(NetBSD 9.0)
sparc64:py37-websockets-8.1.tgz(NetBSD 9.0)
sparc64:py38-websockets-8.1.tgz(NetBSD 9.0)
sparc64:py39-websockets-8.1.tgz(NetBSD 9.0)
sparc64:py36-websockets-8.1.tgz(NetBSD 9.0)
sparc64:py37-websockets-8.1.tgz(NetBSD 9.0)
sparc64:py38-websockets-8.1.tgz(NetBSD 9.0)
sparc64:py36-websockets-8.1.tgz(NetBSD 9.0)
sparc64:py37-websockets-8.1.tgz(NetBSD 9.0)
sparc64:py38-websockets-8.1.tgz(NetBSD 9.0)
sparc:py36-websockets-8.1.tgz(NetBSD 9.0)
sparc:py37-websockets-8.1.tgz(NetBSD 9.0)
sparc:py38-websockets-8.1.tgz(NetBSD 9.0)
sparc:py36-websockets-8.1.tgz(NetBSD 9.0)
sparc:py37-websockets-8.1.tgz(NetBSD 9.0)
sparc:py38-websockets-8.1.tgz(NetBSD 9.0)
sparc:py36-websockets-8.1.tgz(NetBSD 9.0)
sparc:py37-websockets-8.1.tgz(NetBSD 9.0)
sparc:py38-websockets-8.1.tgz(NetBSD 9.0)
sparc:py39-websockets-8.1.tgz(NetBSD 9.0)
x86_64:py36-websockets-8.1.tgz(NetBSD 9.0)
x86_64:py37-websockets-8.1.tgz(NetBSD 9.0)
x86_64:py38-websockets-8.1.tgz(NetBSD 9.0)
x86_64:py39-websockets-8.1.tgz(NetBSD 9.0)
x86_64:py36-websockets-8.1.tgz(NetBSD 9.0)
x86_64:py37-websockets-8.1.tgz(NetBSD 9.0)
x86_64:py38-websockets-8.1.tgz(NetBSD 9.0)
x86_64:py39-websockets-8.1.tgz(NetBSD 9.0)
x86_64:py36-websockets-8.1.tgz(NetBSD 9.0)
x86_64:py37-websockets-8.1.tgz(NetBSD 9.0)
x86_64:py38-websockets-8.1.tgz(NetBSD 9.0)
x86_64:py39-websockets-8.1.tgz(NetBSD 9.0)
x86_64:py36-websockets-8.1.tgz(NetBSD 9.0)
x86_64:py37-websockets-8.1.tgz(NetBSD 9.0)
x86_64:py38-websockets-8.1.tgz(NetBSD 9.0)
x86_64:py36-websockets-8.1.tgz(NetBSD 8.0)
x86_64:py37-websockets-8.1.tgz(NetBSD 8.0)
x86_64:py38-websockets-8.1.tgz(NetBSD 8.0)
x86_64:py36-websockets-8.1.tgz(NetBSD 8.0)
x86_64:py37-websockets-8.1.tgz(NetBSD 8.0)
x86_64:py38-websockets-8.1.tgz(NetBSD 8.0)
x86_64:py36-websockets-8.1.tgz(NetBSD 8.0)
x86_64:py37-websockets-8.1.tgz(NetBSD 8.0)
x86_64:py38-websockets-8.1.tgz(NetBSD 8.0)
x86_64:py39-websockets-8.1.tgz(NetBSD 8.0)
x86_64:py36-websockets-8.1.tgz(NetBSD 9.0)
x86_64:py37-websockets-8.1.tgz(NetBSD 9.0)
x86_64:py38-websockets-8.1.tgz(NetBSD 9.0)
x86_64:py36-websockets-8.1.tgz(NetBSD 9.0)
x86_64:py37-websockets-8.1.tgz(NetBSD 9.0)
x86_64:py38-websockets-8.1.tgz(NetBSD 9.0)
x86_64:py36-websockets-8.1.tgz(NetBSD 9.0)
x86_64:py37-websockets-8.1.tgz(NetBSD 9.0)
x86_64:py38-websockets-8.1.tgz(NetBSD 9.0)
x86_64:py39-websockets-8.1.tgz(NetBSD 9.0)
x86_64:py36-websockets-8.1.tgz(NetBSD 9.0)
x86_64:py37-websockets-8.1.tgz(NetBSD 9.0)
x86_64:py38-websockets-8.1.tgz(NetBSD 9.0)
x86_64:py39-websockets-8.1.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]