www/py-beautifulsoup - The NetBSD Packages Collection

HTML/XML Parser for Python, version 3

Beautiful Soup parses arbitrarily invalid XML- or HTML-like substance
into a tree representation. It provides methods and Pythonic idioms
that make it easy to search and modify the tree.

A well-formed XML/HTML document will yield a well-formed data
structure. An ill-formed XML/HTML document will yield a correspondingly
ill-formed data structure. If your document is only locally
well-formed, you can use this library to find and process the
well-formed part of it. The BeautifulSoup class has heuristics for
obtaining a sensible parse tree in the face of common HTML errors.

This package contains v3 of the module.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

devel/py-setuptools44 lang/python27 lang/python27

Available binary packages

aarch64:py27-beautifulsoup-3.2.2.tgz(NetBSD 9.0)
aarch64:py27-beautifulsoup-3.2.2.tgz(NetBSD 9.0)
aarch64:py27-beautifulsoup-3.2.2.tgz(NetBSD 9.0)
alpha:py27-beautifulsoup-3.2.2.tgz(NetBSD 9.0)
alpha:py27-beautifulsoup-3.2.2.tgz(NetBSD 9.0)
earmv6hf:py27-beautifulsoup-3.2.2.tgz(NetBSD 9.0)
earmv6hf:py27-beautifulsoup-3.2.2.tgz(NetBSD 9.0)
earmv6hf:py27-beautifulsoup-3.2.2.tgz(NetBSD 9.0)
earmv6hf:py27-beautifulsoup-3.2.2.tgz(NetBSD 9.0)
earmv7hf:py27-beautifulsoup-3.2.2.tgz(NetBSD 8.0)
earmv7hf:py27-beautifulsoup-3.2.2.tgz(NetBSD 8.0)
earmv7hf:py27-beautifulsoup-3.2.2.tgz(NetBSD 8.0)
earmv7hf:py27-beautifulsoup-3.2.2.tgz(NetBSD 9.0)
earmv7hf:py27-beautifulsoup-3.2.2.tgz(NetBSD 9.0)
earmv7hf:py27-beautifulsoup-3.2.2.tgz(NetBSD 9.0)
earmv7hf:py27-beautifulsoup-3.2.2.tgz(NetBSD 9.0)
earmv7hf:py27-beautifulsoup-3.2.2.tgz(NetBSD 9.0)
i386:py27-beautifulsoup-3.2.2.tgz(NetBSD 8.0)
i386:py27-beautifulsoup-3.2.2.tgz(NetBSD 8.0)
i386:py27-beautifulsoup-3.2.2.tgz(NetBSD 8.0)
i386:py27-beautifulsoup-3.2.2.tgz(NetBSD 9.0)
i386:py27-beautifulsoup-3.2.2.tgz(NetBSD 9.0)
i386:py27-beautifulsoup-3.2.2.tgz(NetBSD 9.0)
mips64eb:py27-beautifulsoup-3.2.2.tgz(NetBSD 9.0)
powerpc:py27-beautifulsoup-3.2.2.tgz(NetBSD 8.0)
powerpc:py27-beautifulsoup-3.2.2.tgz(NetBSD 8.0)
powerpc:py27-beautifulsoup-3.2.2.tgz(NetBSD 9.0)
powerpc:py27-beautifulsoup-3.2.2.tgz(NetBSD 9.0)
sparc64:py27-beautifulsoup-3.2.2.tgz(NetBSD 9.0)
sparc64:py27-beautifulsoup-3.2.2.tgz(NetBSD 9.0)
sparc64:py27-beautifulsoup-3.2.2.tgz(NetBSD 9.0)
sparc:py27-beautifulsoup-3.2.2.tgz(NetBSD 9.0)
x86_64:py27-beautifulsoup-3.2.2.tgz(NetBSD 9.0)
x86_64:py27-beautifulsoup-3.2.2.tgz(NetBSD 9.0)
x86_64:py27-beautifulsoup-3.2.2.tgz(NetBSD 9.0)
x86_64:py27-beautifulsoup-3.2.2.tgz(NetBSD 9.0)
x86_64:py27-beautifulsoup-3.2.2.tgz(NetBSD 8.0)
x86_64:py27-beautifulsoup-3.2.2.tgz(NetBSD 8.0)
x86_64:py27-beautifulsoup-3.2.2.tgz(NetBSD 8.0)
x86_64:py27-beautifulsoup-3.2.2.tgz(NetBSD 9.0)
x86_64:py27-beautifulsoup-3.2.2.tgz(NetBSD 9.0)
x86_64:py27-beautifulsoup-3.2.2.tgz(NetBSD 9.0)
x86_64:py27-beautifulsoup-3.2.2.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]