Daemon Power

The NetBSD Packages Collection: www/php-http3

Brief description of the package:
PHP extension for extended HTTP support

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://pecl.php.net/package/pecl_http.

Please note that this package has a 2-clause-bsd license.

The package is located in the "www/php-http3" directory. The current source version of the package is "php72-http-3.0.1nb16". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for www/php-http3 :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: libidn>=0.4.6 cwrappers>=20150314 php72-raphf>=2.0.0 php>=7.1.99<7.2.99 pcre>=3.4nb1 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 readline>=2.2 pcre>=8.30nb1 libxml2>=2.9.10nb2 readline>=6.0 php>=7.2.31nb1 re2c>=0.13.0.4 curl>=7.12.3 libidn2>=2.0.0 libunistring>=0.9.3 libunistring>=0.9.4 nghttp2>=1.0.0 python37>=3.7 libffi>=1.20 libuuid>=2.18 libffi>=3.3nb1 python37>=3.7.0 nghttp2>=1.40.0nb4 php72-propro>=2.0.0 libidn>=1.20nb1 curl>=7.70.0nb2 .

This package requires the following package(s) to run: libidn>=0.4.6 php72-raphf>=2.0.0 php>=7.1.99<7.2.99 pcre>=3.4nb1 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 readline>=2.2 pcre>=8.30nb1 libxml2>=2.9.10nb2 readline>=6.0 php>=7.2.31nb1 curl>=7.12.3 libidn2>=2.0.0 libunistring>=0.9.3 libunistring>=0.9.4 nghttp2>=1.0.0 python37>=3.7 libffi>=1.20 libuuid>=2.18 libffi>=3.3nb1 python37>=3.7.0 nghttp2>=1.40.0nb4 php72-propro>=2.0.0 libidn>=1.20nb1 curl>=7.70.0nb2 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
aarch64:php72-http-3.0.1nb16.tgz(NetBSD 9.0)
aarch64:php72-http-3.0.1nb11.tgz(NetBSD 9.0)
aarch64:php72-http-3.0.1nb14.tgz(NetBSD 9.0)
alpha:php71-http-3.0.1nb11.tgz(NetBSD 8.0)
alpha:php72-http-3.0.1nb11.tgz(NetBSD 8.0)
alpha:php72-http-3.0.1nb11.tgz(NetBSD 9.0)
earmv6hf:php72-http-3.0.1nb11.tgz(NetBSD 8.0)
earmv6hf:php72-http-3.0.1nb11.tgz(NetBSD 9.0)
earmv7hf:php72-http-3.0.1nb14.tgz(NetBSD 8.0)
earmv7hf:php72-http-3.0.1nb11.tgz(NetBSD 8.0)
earmv7hf:php72-http-3.0.1nb16.tgz(NetBSD 8.0)
earmv7hf:php72-http-3.0.1nb14.tgz(NetBSD 9.0)
earmv7hf:php72-http-3.0.1nb11.tgz(NetBSD 9.0)
i386:php72-http-3.0.1nb14.tgz(NetBSD 9.0)
i386:php72-http-3.0.1nb11.tgz(NetBSD 7.0)
i386:php71-http-3.0.1nb11.tgz(NetBSD 7.0)
i386:php72-http-3.0.1nb11.tgz(NetBSD 7.0)
i386:php71-http-3.0.1nb11.tgz(NetBSD 7.1)
i386:php72-http-3.0.1nb11.tgz(NetBSD 7.1)
i386:php72-http-3.0.1nb11.tgz(NetBSD 7.1)
i386:php72-http-3.0.1nb14.tgz(NetBSD 7.1)
i386:php72-http-3.0.1nb16.tgz(NetBSD 7.1)
i386:php72-http-3.0.1nb16.tgz(NetBSD 8.0)
i386:php71-http-3.0.1nb11.tgz(NetBSD 8.0)
i386:php72-http-3.0.1nb11.tgz(NetBSD 8.0)
i386:php72-http-3.0.1nb11.tgz(NetBSD 8.0)
i386:php72-http-3.0.1nb14.tgz(NetBSD 8.0)
i386:php72-http-3.0.1nb16.tgz(NetBSD 9.0)
i386:php72-http-3.0.1nb11.tgz(NetBSD 9.0)
i386:php72-http-3.0.1nb14.tgz(NetBSD 9.0)
powerpc:php70-http-3.0.1nb2.tgz(NetBSD 7.1)
powerpc:php70-http-3.0.1nb3.tgz(NetBSD 7.1)
powerpc:php70-http-3.0.1nb4.tgz(NetBSD 7.1)
powerpc:php70-http-3.0.1nb5.tgz(NetBSD 7.1)
powerpc:php70-http-3.0.1nb6.tgz(NetBSD 7.1)
powerpc:php70-http-3.0.1nb7.tgz(NetBSD 7.1)
powerpc:php70-http-3.0.1nb8.tgz(NetBSD 7.1)
powerpc:php71-http-3.0.1nb5.tgz(NetBSD 7.1)
powerpc:php71-http-3.0.1nb6.tgz(NetBSD 7.1)
powerpc:php71-http-3.0.1nb7.tgz(NetBSD 7.1)
powerpc:php71-http-3.0.1nb8.tgz(NetBSD 7.1)
powerpc:php72-http-3.0.1nb5.tgz(NetBSD 7.1)
powerpc:php72-http-3.0.1nb6.tgz(NetBSD 7.1)
powerpc:php72-http-3.0.1nb7.tgz(NetBSD 7.1)
powerpc:php72-http-3.0.1nb8.tgz(NetBSD 7.1)
powerpc:php72-http-3.0.1nb11.tgz(NetBSD 8.0)
powerpc:php72-http-3.0.1nb11.tgz(NetBSD 9.0)
sparc64:php70-http-3.0.1nb6.tgz(NetBSD 7.1)
sparc64:php71-http-3.0.1nb6.tgz(NetBSD 7.1)
sparc64:php72-http-3.0.1nb6.tgz(NetBSD 7.1)
sparc64:php71-http-3.0.1nb11.tgz(NetBSD 8.0)
sparc64:php72-http-3.0.1nb11.tgz(NetBSD 8.0)
x86_64:php72-http-3.0.1nb15.tgz(NetBSD 9.0)
x86_64:php72-http-3.0.1nb16.tgz(NetBSD 9.0)
x86_64:php72-http-3.0.1nb11.tgz(NetBSD 7.0)
x86_64:php71-http-3.0.1nb11.tgz(NetBSD 7.0)
x86_64:php72-http-3.0.1nb11.tgz(NetBSD 7.0)
x86_64:php72-http-3.0.1nb16.tgz(NetBSD 7.1)
x86_64:php71-http-3.0.1nb11.tgz(NetBSD 7.1)
x86_64:php72-http-3.0.1nb11.tgz(NetBSD 7.1)
x86_64:php72-http-3.0.1nb11.tgz(NetBSD 7.1)
x86_64:php72-http-3.0.1nb14.tgz(NetBSD 7.1)
x86_64:php72-http-3.0.1nb14.tgz(NetBSD 8.0)
x86_64:php71-http-3.0.1nb11.tgz(NetBSD 8.0)
x86_64:php72-http-3.0.1nb11.tgz(NetBSD 8.0)
x86_64:php72-http-3.0.1nb11.tgz(NetBSD 8.0)
x86_64:php72-http-3.0.1nb16.tgz(NetBSD 8.0)
x86_64:php72-http-3.0.1nb16.tgz(NetBSD 9.0)
x86_64:php72-http-3.0.1nb11.tgz(NetBSD 9.0)
x86_64:php72-http-3.0.1nb14.tgz(NetBSD 9.0)
x86_64:php72-http-3.0.1nb16.tgz(NetBSD 9.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]