www/p5-Router-Simple - The NetBSD Packages Collection

Simple HTTP router for web applications

Router::Simple is a simple router class. Its main purpose is to serve as a
dispatcher for web applications. Router::Simple can match against PSGI $env
directly, which means it's easy to use with PSGI supporting web frameworks.

Build dependencies

devel/p5-Module-Build pkgtools/cwrappers

Runtime dependencies

devel/p5-Class-Accessor-Lite lang/perl5 lang/perl5

Available binary packages

aarch64:p5-Router-Simple-0.17nb5.tgz(NetBSD 9.0)
aarch64:p5-Router-Simple-0.17nb6.tgz(NetBSD 9.0)
aarch64:p5-Router-Simple-0.17nb6.tgz(NetBSD 9.0)
alpha:p5-Router-Simple-0.17nb6.tgz(NetBSD 9.0)
alpha:p5-Router-Simple-0.17nb5.tgz(NetBSD 9.0)
alpha:p5-Router-Simple-0.17nb6.tgz(NetBSD 9.0)
earm:p5-Router-Simple-0.17nb6.tgz(NetBSD 9.0)
earm:p5-Router-Simple-0.17nb5.tgz(NetBSD 9.0)
earmv6hf:p5-Router-Simple-0.17nb6.tgz(NetBSD 9.0)
earmv6hf:p5-Router-Simple-0.17nb5.tgz(NetBSD 9.0)
earmv6hf:p5-Router-Simple-0.17nb6.tgz(NetBSD 9.0)
earmv6hf:p5-Router-Simple-0.17nb6.tgz(NetBSD 9.0)
earmv7hf:p5-Router-Simple-0.17nb6.tgz(NetBSD 8.0)
earmv7hf:p5-Router-Simple-0.17nb5.tgz(NetBSD 8.0)
earmv7hf:p5-Router-Simple-0.17nb5.tgz(NetBSD 8.0)
earmv7hf:p5-Router-Simple-0.17nb6.tgz(NetBSD 8.0)
earmv7hf:p5-Router-Simple-0.17nb6.tgz(NetBSD 9.0)
earmv7hf:p5-Router-Simple-0.17nb5.tgz(NetBSD 9.0)
earmv7hf:p5-Router-Simple-0.17nb5.tgz(NetBSD 9.0)
earmv7hf:p5-Router-Simple-0.17nb6.tgz(NetBSD 9.0)
earmv7hf:p5-Router-Simple-0.17nb6.tgz(NetBSD 9.0)
i386:p5-Router-Simple-0.17nb5.tgz(NetBSD 8.0)
i386:p5-Router-Simple-0.17nb6.tgz(NetBSD 8.0)
i386:p5-Router-Simple-0.17nb6.tgz(NetBSD 8.0)
i386:p5-Router-Simple-0.17nb5.tgz(NetBSD 9.0)
i386:p5-Router-Simple-0.17nb6.tgz(NetBSD 9.0)
i386:p5-Router-Simple-0.17nb6.tgz(NetBSD 9.0)
mips64eb:p5-Router-Simple-0.17nb6.tgz(NetBSD 9.0)
mips64eb:p5-Router-Simple-0.17nb6.tgz(NetBSD 9.0)
powerpc:p5-Router-Simple-0.17nb6.tgz(NetBSD 8.0)
powerpc:p5-Router-Simple-0.17nb6.tgz(NetBSD 8.0)
powerpc:p5-Router-Simple-0.17nb6.tgz(NetBSD 9.0)
powerpc:p5-Router-Simple-0.17nb5.tgz(NetBSD 9.0)
sparc64:p5-Router-Simple-0.17nb6.tgz(NetBSD 9.0)
sparc64:p5-Router-Simple-0.17nb5.tgz(NetBSD 9.0)
sparc64:p5-Router-Simple-0.17nb6.tgz(NetBSD 9.0)
sparc:p5-Router-Simple-0.17nb6.tgz(NetBSD 9.0)
sparc:p5-Router-Simple-0.17nb5.tgz(NetBSD 9.0)
sparc:p5-Router-Simple-0.17nb6.tgz(NetBSD 9.0)
x86_64:p5-Router-Simple-0.17nb6.tgz(NetBSD 9.0)
x86_64:p5-Router-Simple-0.17nb6.tgz(NetBSD 9.0)
x86_64:p5-Router-Simple-0.17nb6.tgz(NetBSD 9.0)
x86_64:p5-Router-Simple-0.17nb6.tgz(NetBSD 9.0)
x86_64:p5-Router-Simple-0.17nb6.tgz(NetBSD 8.0)
x86_64:p5-Router-Simple-0.17nb5.tgz(NetBSD 8.0)
x86_64:p5-Router-Simple-0.17nb6.tgz(NetBSD 8.0)
x86_64:p5-Router-Simple-0.17nb5.tgz(NetBSD 9.0)
x86_64:p5-Router-Simple-0.17nb6.tgz(NetBSD 9.0)
x86_64:p5-Router-Simple-0.17nb6.tgz(NetBSD 9.0)
x86_64:p5-Router-Simple-0.17nb6.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]