www/p5-HTML-StripScripts - The NetBSD Packages Collection

Perl5 module to strip scripting constructs out of HTML

HTML::StripScript
===========
This module strips scripting constructs out of HTML, leaving as much
non-scripting markup in place as possible. This allows web applications
to display HTML originating from an untrusted source without introducing
XSS (cross site scripting) vulnerabilities.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

lang/perl5 lang/perl5

Available binary packages

aarch64:p5-HTML-StripScripts-1.06nb3.tgz(NetBSD 9.0)
aarch64:p5-HTML-StripScripts-1.06nb4.tgz(NetBSD 9.0)
aarch64:p5-HTML-StripScripts-1.06nb4.tgz(NetBSD 9.0)
alpha:p5-HTML-StripScripts-1.06nb4.tgz(NetBSD 9.0)
alpha:p5-HTML-StripScripts-1.06nb3.tgz(NetBSD 9.0)
alpha:p5-HTML-StripScripts-1.06nb4.tgz(NetBSD 9.0)
earm:p5-HTML-StripScripts-1.06nb4.tgz(NetBSD 9.0)
earm:p5-HTML-StripScripts-1.06nb3.tgz(NetBSD 9.0)
earmv6hf:p5-HTML-StripScripts-1.06nb4.tgz(NetBSD 9.0)
earmv6hf:p5-HTML-StripScripts-1.06nb3.tgz(NetBSD 9.0)
earmv6hf:p5-HTML-StripScripts-1.06nb4.tgz(NetBSD 9.0)
earmv6hf:p5-HTML-StripScripts-1.06nb4.tgz(NetBSD 9.0)
earmv7hf:p5-HTML-StripScripts-1.06nb4.tgz(NetBSD 8.0)
earmv7hf:p5-HTML-StripScripts-1.06nb3.tgz(NetBSD 8.0)
earmv7hf:p5-HTML-StripScripts-1.06nb3.tgz(NetBSD 8.0)
earmv7hf:p5-HTML-StripScripts-1.06nb4.tgz(NetBSD 8.0)
earmv7hf:p5-HTML-StripScripts-1.06nb4.tgz(NetBSD 9.0)
earmv7hf:p5-HTML-StripScripts-1.06nb3.tgz(NetBSD 9.0)
earmv7hf:p5-HTML-StripScripts-1.06nb3.tgz(NetBSD 9.0)
earmv7hf:p5-HTML-StripScripts-1.06nb4.tgz(NetBSD 9.0)
earmv7hf:p5-HTML-StripScripts-1.06nb4.tgz(NetBSD 9.0)
i386:p5-HTML-StripScripts-1.06nb3.tgz(NetBSD 8.0)
i386:p5-HTML-StripScripts-1.06nb4.tgz(NetBSD 8.0)
i386:p5-HTML-StripScripts-1.06nb4.tgz(NetBSD 8.0)
i386:p5-HTML-StripScripts-1.06nb3.tgz(NetBSD 9.0)
i386:p5-HTML-StripScripts-1.06nb4.tgz(NetBSD 9.0)
i386:p5-HTML-StripScripts-1.06nb4.tgz(NetBSD 9.0)
m68k:p5-HTML-StripScripts-1.06nb3.tgz(NetBSD 9.0)
mips64eb:p5-HTML-StripScripts-1.06nb4.tgz(NetBSD 9.0)
mips64eb:p5-HTML-StripScripts-1.06nb4.tgz(NetBSD 9.0)
powerpc:p5-HTML-StripScripts-1.06nb4.tgz(NetBSD 8.0)
powerpc:p5-HTML-StripScripts-1.06nb4.tgz(NetBSD 8.0)
powerpc:p5-HTML-StripScripts-1.06nb4.tgz(NetBSD 9.0)
powerpc:p5-HTML-StripScripts-1.06nb3.tgz(NetBSD 9.0)
sparc64:p5-HTML-StripScripts-1.06nb4.tgz(NetBSD 9.0)
sparc64:p5-HTML-StripScripts-1.06nb3.tgz(NetBSD 9.0)
sparc64:p5-HTML-StripScripts-1.06nb4.tgz(NetBSD 9.0)
sparc:p5-HTML-StripScripts-1.06nb4.tgz(NetBSD 9.0)
sparc:p5-HTML-StripScripts-1.06nb3.tgz(NetBSD 9.0)
sparc:p5-HTML-StripScripts-1.06nb4.tgz(NetBSD 9.0)
x86_64:p5-HTML-StripScripts-1.06nb4.tgz(NetBSD 9.0)
x86_64:p5-HTML-StripScripts-1.06nb4.tgz(NetBSD 9.0)
x86_64:p5-HTML-StripScripts-1.06nb4.tgz(NetBSD 9.0)
x86_64:p5-HTML-StripScripts-1.06nb4.tgz(NetBSD 9.0)
x86_64:p5-HTML-StripScripts-1.06nb4.tgz(NetBSD 8.0)
x86_64:p5-HTML-StripScripts-1.06nb3.tgz(NetBSD 8.0)
x86_64:p5-HTML-StripScripts-1.06nb4.tgz(NetBSD 8.0)
x86_64:p5-HTML-StripScripts-1.06nb3.tgz(NetBSD 9.0)
x86_64:p5-HTML-StripScripts-1.06nb4.tgz(NetBSD 9.0)
x86_64:p5-HTML-StripScripts-1.06nb4.tgz(NetBSD 9.0)
x86_64:p5-HTML-StripScripts-1.06nb4.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]