www/p5-CGI-Minimal - The NetBSD Packages Collection

Perl5 module for simple CGI scripts

CGI::Minimal is a lightweight alternative to CGI.  It provides the _minimum_
functions needed for CGI such as form decoding (including file upload forms),
URL encoding and decoding, HTTP usable date generation (RFC1123 compliant
dates) and _basic_ escaping and unescaping of HTMLized text.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

lang/perl5 lang/perl5

Available binary packages

aarch64:p5-CGI-Minimal-1.29nb11.tgz(NetBSD 9.0)
aarch64:p5-CGI-Minimal-1.30.tgz(NetBSD 9.0)
aarch64:p5-CGI-Minimal-1.30.tgz(NetBSD 9.0)
alpha:p5-CGI-Minimal-1.30.tgz(NetBSD 9.0)
alpha:p5-CGI-Minimal-1.30.tgz(NetBSD 9.0)
earmv6hf:p5-CGI-Minimal-1.30.tgz(NetBSD 9.0)
earmv6hf:p5-CGI-Minimal-1.29nb11.tgz(NetBSD 9.0)
earmv6hf:p5-CGI-Minimal-1.30.tgz(NetBSD 9.0)
earmv6hf:p5-CGI-Minimal-1.30.tgz(NetBSD 9.0)
earmv7hf:p5-CGI-Minimal-1.30.tgz(NetBSD 8.0)
earmv7hf:p5-CGI-Minimal-1.29nb11.tgz(NetBSD 8.0)
earmv7hf:p5-CGI-Minimal-1.29nb11.tgz(NetBSD 8.0)
earmv7hf:p5-CGI-Minimal-1.30.tgz(NetBSD 8.0)
earmv7hf:p5-CGI-Minimal-1.30.tgz(NetBSD 9.0)
earmv7hf:p5-CGI-Minimal-1.29nb11.tgz(NetBSD 9.0)
earmv7hf:p5-CGI-Minimal-1.29nb11.tgz(NetBSD 9.0)
earmv7hf:p5-CGI-Minimal-1.30.tgz(NetBSD 9.0)
earmv7hf:p5-CGI-Minimal-1.30.tgz(NetBSD 9.0)
i386:p5-CGI-Minimal-1.29nb11.tgz(NetBSD 8.0)
i386:p5-CGI-Minimal-1.30.tgz(NetBSD 8.0)
i386:p5-CGI-Minimal-1.30.tgz(NetBSD 8.0)
i386:p5-CGI-Minimal-1.29nb11.tgz(NetBSD 9.0)
i386:p5-CGI-Minimal-1.30.tgz(NetBSD 9.0)
i386:p5-CGI-Minimal-1.30.tgz(NetBSD 9.0)
mips64eb:p5-CGI-Minimal-1.30.tgz(NetBSD 9.0)
powerpc:p5-CGI-Minimal-1.30.tgz(NetBSD 8.0)
powerpc:p5-CGI-Minimal-1.30.tgz(NetBSD 8.0)
powerpc:p5-CGI-Minimal-1.30.tgz(NetBSD 9.0)
powerpc:p5-CGI-Minimal-1.29nb11.tgz(NetBSD 9.0)
sparc64:p5-CGI-Minimal-1.30.tgz(NetBSD 9.0)
sparc64:p5-CGI-Minimal-1.29nb11.tgz(NetBSD 9.0)
sparc64:p5-CGI-Minimal-1.30.tgz(NetBSD 9.0)
sparc:p5-CGI-Minimal-1.30.tgz(NetBSD 9.0)
x86_64:p5-CGI-Minimal-1.30.tgz(NetBSD 9.0)
x86_64:p5-CGI-Minimal-1.30.tgz(NetBSD 9.0)
x86_64:p5-CGI-Minimal-1.30.tgz(NetBSD 9.0)
x86_64:p5-CGI-Minimal-1.30.tgz(NetBSD 9.0)
x86_64:p5-CGI-Minimal-1.30.tgz(NetBSD 8.0)
x86_64:p5-CGI-Minimal-1.29nb11.tgz(NetBSD 8.0)
x86_64:p5-CGI-Minimal-1.30.tgz(NetBSD 8.0)
x86_64:p5-CGI-Minimal-1.29nb11.tgz(NetBSD 9.0)
x86_64:p5-CGI-Minimal-1.30.tgz(NetBSD 9.0)
x86_64:p5-CGI-Minimal-1.30.tgz(NetBSD 9.0)
x86_64:p5-CGI-Minimal-1.30.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]