www/p5-CGI-Application - The NetBSD Packages Collection

Perl5 module to create sophisticated, reusable web-based applications

CGI::Application is intended to make it easier to create sophisticated,
reusable web-based applications. This module implements a methodology which,
if followed, will make your web software easier to design, easier to
document, easier to write, and easier to evolve.

The guiding philosophy behind CGI::Application is that a web-based
application can be organized into a specific set of "Run-Modes." Each
Run-Mode is roughly analogous to a single screen (a form, some output, etc).
All the Run-Modes are managed by a single "Application Module" which is a
Perl module. In your web server's document space there is an "Instance
Script" which is called by the web server as a CGI (or an Apache::Registry
script if you're using Apache + mod_perl).

CGI::Application is an Object-Oriented Perl module which implements an
Abstract Class. It is not intended that this package be instantiated
directly. Instead, it is intended that your Application Module will be
implemented as a Sub-Class of CGI::Application.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

devel/p5-Class-ISA www/p5-HTML-Template lang/perl5 lang/perl5

Available binary packages

aarch64:p5-CGI-Application-4.61nb2.tgz(NetBSD 9.0)
aarch64:p5-CGI-Application-4.61nb3.tgz(NetBSD 9.0)
aarch64:p5-CGI-Application-4.61nb3.tgz(NetBSD 9.0)
alpha:p5-CGI-Application-4.61nb3.tgz(NetBSD 9.0)
alpha:p5-CGI-Application-4.61nb2.tgz(NetBSD 9.0)
alpha:p5-CGI-Application-4.61nb3.tgz(NetBSD 9.0)
earm:p5-CGI-Application-4.61nb3.tgz(NetBSD 9.0)
earm:p5-CGI-Application-4.61nb2.tgz(NetBSD 9.0)
earmv6hf:p5-CGI-Application-4.61nb3.tgz(NetBSD 9.0)
earmv6hf:p5-CGI-Application-4.61nb2.tgz(NetBSD 9.0)
earmv6hf:p5-CGI-Application-4.61nb3.tgz(NetBSD 9.0)
earmv6hf:p5-CGI-Application-4.61nb3.tgz(NetBSD 9.0)
earmv7hf:p5-CGI-Application-4.61nb3.tgz(NetBSD 8.0)
earmv7hf:p5-CGI-Application-4.61nb2.tgz(NetBSD 8.0)
earmv7hf:p5-CGI-Application-4.61nb2.tgz(NetBSD 8.0)
earmv7hf:p5-CGI-Application-4.61nb3.tgz(NetBSD 8.0)
earmv7hf:p5-CGI-Application-4.61nb3.tgz(NetBSD 9.0)
earmv7hf:p5-CGI-Application-4.61nb2.tgz(NetBSD 9.0)
earmv7hf:p5-CGI-Application-4.61nb2.tgz(NetBSD 9.0)
earmv7hf:p5-CGI-Application-4.61nb3.tgz(NetBSD 9.0)
earmv7hf:p5-CGI-Application-4.61nb3.tgz(NetBSD 9.0)
i386:p5-CGI-Application-4.61nb2.tgz(NetBSD 8.0)
i386:p5-CGI-Application-4.61nb3.tgz(NetBSD 8.0)
i386:p5-CGI-Application-4.61nb3.tgz(NetBSD 8.0)
i386:p5-CGI-Application-4.61nb2.tgz(NetBSD 9.0)
i386:p5-CGI-Application-4.61nb3.tgz(NetBSD 9.0)
i386:p5-CGI-Application-4.61nb3.tgz(NetBSD 9.0)
mips64eb:p5-CGI-Application-4.61nb3.tgz(NetBSD 9.0)
mips64eb:p5-CGI-Application-4.61nb3.tgz(NetBSD 9.0)
powerpc:p5-CGI-Application-4.61nb3.tgz(NetBSD 8.0)
powerpc:p5-CGI-Application-4.61nb3.tgz(NetBSD 8.0)
powerpc:p5-CGI-Application-4.61nb3.tgz(NetBSD 9.0)
powerpc:p5-CGI-Application-4.61nb2.tgz(NetBSD 9.0)
sparc64:p5-CGI-Application-4.61nb3.tgz(NetBSD 9.0)
sparc64:p5-CGI-Application-4.61nb2.tgz(NetBSD 9.0)
sparc64:p5-CGI-Application-4.61nb3.tgz(NetBSD 9.0)
sparc:p5-CGI-Application-4.61nb3.tgz(NetBSD 9.0)
sparc:p5-CGI-Application-4.61nb2.tgz(NetBSD 9.0)
sparc:p5-CGI-Application-4.61nb3.tgz(NetBSD 9.0)
x86_64:p5-CGI-Application-4.61nb3.tgz(NetBSD 9.0)
x86_64:p5-CGI-Application-4.61nb3.tgz(NetBSD 9.0)
x86_64:p5-CGI-Application-4.61nb3.tgz(NetBSD 9.0)
x86_64:p5-CGI-Application-4.61nb3.tgz(NetBSD 9.0)
x86_64:p5-CGI-Application-4.61nb3.tgz(NetBSD 8.0)
x86_64:p5-CGI-Application-4.61nb2.tgz(NetBSD 8.0)
x86_64:p5-CGI-Application-4.61nb3.tgz(NetBSD 8.0)
x86_64:p5-CGI-Application-4.61nb2.tgz(NetBSD 9.0)
x86_64:p5-CGI-Application-4.61nb3.tgz(NetBSD 9.0)
x86_64:p5-CGI-Application-4.61nb3.tgz(NetBSD 9.0)
x86_64:p5-CGI-Application-4.61nb3.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]