Daemon Power

The NetBSD Packages Collection: www/p5-CGI-Application-Plugin-ValidateRM

Brief description of the package:
Help validate CGI::Application run modes using Data::FormValidator

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://search.cpan.org/dist/CGI-Application-Plugin-ValidateRM/.

Please note that this package has a gnu-gpl-v2 license.

The package is located in the "www/p5-CGI-Application-Plugin-ValidateRM" directory. The current source version of the package is "p5-CGI-Application-Plugin-ValidateRM-2.5nb5". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for www/p5-CGI-Application-Plugin-ValidateRM :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: p5-CGI-Application-[0-9]* p5-Class-ISA-[0-9]* perl>=5.26.0 cwrappers>=20150314 perl<5.28.0 p5-HTML-Template-[0-9]* p5-CGI-[0-9]* p5-HTML-Parser-[0-9]* p5-HTML-Tagset>=3.0 p5-URI-[0-9]* p5-Test-Needs-[0-9]* p5-Test-Deep-[0-9]* p5-Test-Simple>=1.001010 p5-Test-Warn-[0-9]* p5-Sub-Uplevel>=0.12 p5-Test-NoWarnings-[0-9]* p5-HTML-FillInForm-[0-9]* p5-HTML-Parser>=3.26 p5-Data-FormValidator-[0-9]* p5-Date-Calc>=5.0 p5-Bit-Vector>=7.1 p5-Carp-Clan>=5.3 p5-Carp-Clan>=6.04 p5-Email-Valid-[0-9]* p5-MailTools-[0-9]* p5-TimeDate-[0-9]* p5-Net>=1.09 p5-Net-DNS-[0-9]* p5-Digest-HMAC>=1.0 p5-Net-IP>=1.20 p5-IO-Socket-INET6>=2.01 p5-Socket6>=0.12 p5-Socket6-[0-9]* p5-Net-Domain-TLD-[0-9]* p5-IO-CaptureOutput-[0-9]* p5-File-MMagic>=1.17 p5-Image-Size-[0-9]* p5-MIME-Types>=1.005 p5-Perl6-Junction-[0-9]* p5-Regexp-Common-[0-9]* p5-CGI>=3.48 .

This package requires the following package(s) to run: p5-CGI-Application-[0-9]* p5-Class-ISA-[0-9]* perl>=5.26.0 perl<5.28.0 p5-HTML-Template-[0-9]* p5-CGI-[0-9]* p5-HTML-Parser-[0-9]* p5-HTML-Tagset>=3.0 p5-URI-[0-9]* p5-HTML-FillInForm-[0-9]* p5-HTML-Parser>=3.26 p5-Data-FormValidator-[0-9]* p5-Date-Calc>=5.0 p5-Bit-Vector>=7.1 p5-Carp-Clan>=5.3 p5-Carp-Clan>=6.04 p5-Email-Valid-[0-9]* p5-MailTools-[0-9]* p5-TimeDate-[0-9]* p5-Net-DNS-[0-9]* p5-Digest-HMAC>=1.0 p5-Net-IP>=1.20 p5-IO-Socket-INET6>=2.01 p5-Socket6>=0.12 p5-Socket6-[0-9]* p5-Net-Domain-TLD-[0-9]* p5-IO-CaptureOutput-[0-9]* p5-File-MMagic>=1.17 p5-Image-Size-[0-9]* p5-MIME-Types>=1.005 p5-Perl6-Junction-[0-9]* p5-Regexp-Common-[0-9]* .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
alpha:p5-CGI-Application-Plugin-ValidateRM-2.5nb3.tgz(NetBSD 7.0)
arm:p5-CGI-Application-Plugin-ValidateRM-2.5nb1.tgz(NetBSD 6.1_STABLE)
earm:p5-CGI-Application-Plugin-ValidateRM-2.5nb3.tgz(NetBSD 7.0)
earmv6hf:p5-CGI-Application-Plugin-ValidateRM-2.5nb3.tgz(NetBSD 7.0)
earmv7hf:p5-CGI-Application-Plugin-ValidateRM-2.5nb3.tgz(NetBSD 7.0)
earmv7hf:p5-CGI-Application-Plugin-ValidateRM-2.5nb3.tgz(NetBSD 7.0)
earmv7hf:p5-CGI-Application-Plugin-ValidateRM-2.5nb5.tgz(NetBSD 8.0_BETA)
i386:p5-CGI-Application-Plugin-ValidateRM-2.5nb1.tgz(MirBSD 10)
i386:p5-CGI-Application-Plugin-ValidateRM-2.5nb5.tgz(NetBSD 6.0)
i386:p5-CGI-Application-Plugin-ValidateRM-2.5nb4.tgz(NetBSD 6.0)
i386:p5-CGI-Application-Plugin-ValidateRM-2.5nb4.tgz(NetBSD 6.0)
i386:p5-CGI-Application-Plugin-ValidateRM-2.5nb4.tgz(NetBSD 6.0)
i386:p5-CGI-Application-Plugin-ValidateRM-2.5nb5.tgz(NetBSD 6.1)
i386:p5-CGI-Application-Plugin-ValidateRM-2.5nb4.tgz(NetBSD 6.1)
i386:p5-CGI-Application-Plugin-ValidateRM-2.5nb4.tgz(NetBSD 6.1)
i386:p5-CGI-Application-Plugin-ValidateRM-2.5nb4.tgz(NetBSD 6.1)
i386:p5-CGI-Application-Plugin-ValidateRM-2.5nb5.tgz(NetBSD 7.0)
i386:p5-CGI-Application-Plugin-ValidateRM-2.5nb4.tgz(NetBSD 7.0)
i386:p5-CGI-Application-Plugin-ValidateRM-2.5nb4.tgz(NetBSD 7.0)
i386:p5-CGI-Application-Plugin-ValidateRM-2.5nb4.tgz(NetBSD 7.0)
i386:p5-CGI-Application-Plugin-ValidateRM-2.3nb2.tgz(QNX 6.5.0)
powerpc:p5-CGI-Application-Plugin-ValidateRM-2.5nb4.tgz(NetBSD 6.0)
powerpc:p5-CGI-Application-Plugin-ValidateRM-2.5nb5.tgz(NetBSD 6.1)
powerpc:p5-CGI-Application-Plugin-ValidateRM-2.5nb3.tgz(NetBSD 7.0)
powerpc:p5-CGI-Application-Plugin-ValidateRM-2.5nb5.tgz(NetBSD 7.1)
powerpc:p5-CGI-Application-Plugin-ValidateRM-2.5nb5.tgz(NetBSD 8.0)
sparc:p5-CGI-Application-Plugin-ValidateRM-2.5nb3.tgz(NetBSD 5.1)
sparc:p5-CGI-Application-Plugin-ValidateRM-2.5nb2.tgz(NetBSD 5.1)
x86_64:p5-CGI-Application-Plugin-ValidateRM-2.5nb5.tgz(NetBSD 6.0)
x86_64:p5-CGI-Application-Plugin-ValidateRM-2.5nb4.tgz(NetBSD 6.0)
x86_64:p5-CGI-Application-Plugin-ValidateRM-2.5nb4.tgz(NetBSD 6.0)
x86_64:p5-CGI-Application-Plugin-ValidateRM-2.5nb4.tgz(NetBSD 6.0)
x86_64:p5-CGI-Application-Plugin-ValidateRM-2.5nb5.tgz(NetBSD 6.1)
x86_64:p5-CGI-Application-Plugin-ValidateRM-2.5nb4.tgz(NetBSD 6.1)
x86_64:p5-CGI-Application-Plugin-ValidateRM-2.5nb4.tgz(NetBSD 6.1)
x86_64:p5-CGI-Application-Plugin-ValidateRM-2.5nb4.tgz(NetBSD 6.1)
x86_64:p5-CGI-Application-Plugin-ValidateRM-2.5nb5.tgz(NetBSD 7.0)
x86_64:p5-CGI-Application-Plugin-ValidateRM-2.5nb4.tgz(NetBSD 7.0)
x86_64:p5-CGI-Application-Plugin-ValidateRM-2.5nb4.tgz(NetBSD 7.0)
x86_64:p5-CGI-Application-Plugin-ValidateRM-2.5nb4.tgz(NetBSD 7.0)
x86_64:p5-CGI-Application-Plugin-ValidateRM-2.5nb5.tgz(NetBSD 7.0.1_PATCH)
x86_64:p5-CGI-Application-Plugin-ValidateRM-2.5nb5.tgz(NetBSD 8.99.1)
x86_64:p5-CGI-Application-Plugin-ValidateRM-2.5nb5.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]