www/p5-Apache2-AuthCASSimple - The NetBSD Packages Collection

Apache2 module to authenticate through a CAS server

Apache2::AuthCASSimple is an authentication module for Apache2/mod_perl2.
It allows you to authenticate users through a Yale CAS server. Users
do not need to log in if they are already authenticated
by the CAS server, only tickets are exchanged between Web client,
Apache2 server and CAS server. If they are not yet authenticated,
they will be redirected to the CAS server login form.

Build dependencies

textproc/p5-Pod-Coverage www/apache24 pkgtools/cwrappers www/apache24 lang/perl5

Runtime dependencies

www/p5-Apache-Session-Wrapper security/p5-Authen-CAS-Client security/p5-Crypt-SSLeay www/p5-URI www/ap2-perl lang/perl5 lang/perl5 www/ap2-perl

Available binary packages

aarch64:p5-Apache2-AuthCASSimple-0.10nb11.tgz(NetBSD 9.0)
aarch64:p5-Apache2-AuthCASSimple-0.10nb12.tgz(NetBSD 9.0)
aarch64:p5-Apache2-AuthCASSimple-0.10nb12.tgz(NetBSD 9.0)
alpha:p5-Apache2-AuthCASSimple-0.10nb12.tgz(NetBSD 9.0)
alpha:p5-Apache2-AuthCASSimple-0.10nb12.tgz(NetBSD 9.0)
earmv6hf:p5-Apache2-AuthCASSimple-0.10nb12.tgz(NetBSD 9.0)
earmv6hf:p5-Apache2-AuthCASSimple-0.10nb11.tgz(NetBSD 9.0)
earmv6hf:p5-Apache2-AuthCASSimple-0.10nb12.tgz(NetBSD 9.0)
earmv6hf:p5-Apache2-AuthCASSimple-0.10nb12.tgz(NetBSD 9.0)
earmv7hf:p5-Apache2-AuthCASSimple-0.10nb12.tgz(NetBSD 8.0)
earmv7hf:p5-Apache2-AuthCASSimple-0.10nb11.tgz(NetBSD 8.0)
earmv7hf:p5-Apache2-AuthCASSimple-0.10nb11.tgz(NetBSD 8.0)
earmv7hf:p5-Apache2-AuthCASSimple-0.10nb12.tgz(NetBSD 8.0)
earmv7hf:p5-Apache2-AuthCASSimple-0.10nb12.tgz(NetBSD 9.0)
earmv7hf:p5-Apache2-AuthCASSimple-0.10nb11.tgz(NetBSD 9.0)
earmv7hf:p5-Apache2-AuthCASSimple-0.10nb11.tgz(NetBSD 9.0)
earmv7hf:p5-Apache2-AuthCASSimple-0.10nb12.tgz(NetBSD 9.0)
earmv7hf:p5-Apache2-AuthCASSimple-0.10nb12.tgz(NetBSD 9.0)
i386:p5-Apache2-AuthCASSimple-0.10nb11.tgz(NetBSD 8.0)
i386:p5-Apache2-AuthCASSimple-0.10nb12.tgz(NetBSD 8.0)
i386:p5-Apache2-AuthCASSimple-0.10nb12.tgz(NetBSD 8.0)
i386:p5-Apache2-AuthCASSimple-0.10nb11.tgz(NetBSD 9.0)
i386:p5-Apache2-AuthCASSimple-0.10nb12.tgz(NetBSD 9.0)
i386:p5-Apache2-AuthCASSimple-0.10nb12.tgz(NetBSD 9.0)
mips64eb:p5-Apache2-AuthCASSimple-0.10nb12.tgz(NetBSD 9.0)
powerpc:p5-Apache2-AuthCASSimple-0.10nb12.tgz(NetBSD 8.0)
powerpc:p5-Apache2-AuthCASSimple-0.10nb12.tgz(NetBSD 8.0)
powerpc:p5-Apache2-AuthCASSimple-0.10nb12.tgz(NetBSD 9.0)
powerpc:p5-Apache2-AuthCASSimple-0.10nb11.tgz(NetBSD 9.0)
powerpc:p5-Apache2-AuthCASSimple-0.10nb12.tgz(NetBSD 9.0)
sparc64:p5-Apache2-AuthCASSimple-0.10nb12.tgz(NetBSD 9.0)
sparc64:p5-Apache2-AuthCASSimple-0.10nb12.tgz(NetBSD 9.0)
x86_64:p5-Apache2-AuthCASSimple-0.10nb12.tgz(NetBSD 9.0)
x86_64:p5-Apache2-AuthCASSimple-0.10nb12.tgz(NetBSD 9.0)
x86_64:p5-Apache2-AuthCASSimple-0.10nb12.tgz(NetBSD 9.0)
x86_64:p5-Apache2-AuthCASSimple-0.10nb12.tgz(NetBSD 9.0)
x86_64:p5-Apache2-AuthCASSimple-0.10nb12.tgz(NetBSD 8.0)
x86_64:p5-Apache2-AuthCASSimple-0.10nb11.tgz(NetBSD 8.0)
x86_64:p5-Apache2-AuthCASSimple-0.10nb12.tgz(NetBSD 8.0)
x86_64:p5-Apache2-AuthCASSimple-0.10nb11.tgz(NetBSD 9.0)
x86_64:p5-Apache2-AuthCASSimple-0.10nb12.tgz(NetBSD 9.0)
x86_64:p5-Apache2-AuthCASSimple-0.10nb12.tgz(NetBSD 9.0)
x86_64:p5-Apache2-AuthCASSimple-0.10nb12.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]