www/p5-Alien-GvaScript - The NetBSD Packages Collection

Gva extension to the prototype javascript framework

GvaScript is a javascript framework, built on top of the prototype
object-oriented javascript framework (http://prototype.conio.net)
and offers a number of extensions and widgets, such as keymap
handling, application-specific events, autocompletion on input
field, and a tree navigator.
GvaScript is distributed using Perl tools, but the actual content
of the library is pure javascript.

Build dependencies

devel/p5-Module-Build pkgtools/cwrappers

Runtime dependencies

lang/perl5 lang/perl5

Available binary packages

aarch64:p5-Alien-GvaScript-1.45nb2.tgz(NetBSD 9.0)
aarch64:p5-Alien-GvaScript-1.45nb3.tgz(NetBSD 9.0)
aarch64:p5-Alien-GvaScript-1.45nb3.tgz(NetBSD 9.0)
alpha:p5-Alien-GvaScript-1.45nb3.tgz(NetBSD 9.0)
alpha:p5-Alien-GvaScript-1.45nb2.tgz(NetBSD 9.0)
alpha:p5-Alien-GvaScript-1.45nb3.tgz(NetBSD 9.0)
earm:p5-Alien-GvaScript-1.45nb3.tgz(NetBSD 9.0)
earmv6hf:p5-Alien-GvaScript-1.45nb3.tgz(NetBSD 9.0)
earmv6hf:p5-Alien-GvaScript-1.45nb2.tgz(NetBSD 9.0)
earmv6hf:p5-Alien-GvaScript-1.45nb3.tgz(NetBSD 9.0)
earmv6hf:p5-Alien-GvaScript-1.45nb3.tgz(NetBSD 9.0)
earmv7hf:p5-Alien-GvaScript-1.45nb3.tgz(NetBSD 8.0)
earmv7hf:p5-Alien-GvaScript-1.45nb2.tgz(NetBSD 8.0)
earmv7hf:p5-Alien-GvaScript-1.45nb2.tgz(NetBSD 8.0)
earmv7hf:p5-Alien-GvaScript-1.45nb3.tgz(NetBSD 8.0)
earmv7hf:p5-Alien-GvaScript-1.45nb3.tgz(NetBSD 9.0)
earmv7hf:p5-Alien-GvaScript-1.45nb2.tgz(NetBSD 9.0)
earmv7hf:p5-Alien-GvaScript-1.45nb2.tgz(NetBSD 9.0)
earmv7hf:p5-Alien-GvaScript-1.45nb3.tgz(NetBSD 9.0)
earmv7hf:p5-Alien-GvaScript-1.45nb3.tgz(NetBSD 9.0)
i386:p5-Alien-GvaScript-1.45nb2.tgz(NetBSD 8.0)
i386:p5-Alien-GvaScript-1.45nb3.tgz(NetBSD 8.0)
i386:p5-Alien-GvaScript-1.45nb3.tgz(NetBSD 8.0)
i386:p5-Alien-GvaScript-1.45nb2.tgz(NetBSD 9.0)
i386:p5-Alien-GvaScript-1.45nb3.tgz(NetBSD 9.0)
i386:p5-Alien-GvaScript-1.45nb3.tgz(NetBSD 9.0)
mips64eb:p5-Alien-GvaScript-1.45nb3.tgz(NetBSD 9.0)
mips64eb:p5-Alien-GvaScript-1.45nb3.tgz(NetBSD 9.0)
powerpc:p5-Alien-GvaScript-1.45nb3.tgz(NetBSD 8.0)
powerpc:p5-Alien-GvaScript-1.45nb3.tgz(NetBSD 8.0)
powerpc:p5-Alien-GvaScript-1.45nb3.tgz(NetBSD 9.0)
powerpc:p5-Alien-GvaScript-1.45nb2.tgz(NetBSD 9.0)
sparc64:p5-Alien-GvaScript-1.45nb3.tgz(NetBSD 9.0)
sparc64:p5-Alien-GvaScript-1.45nb2.tgz(NetBSD 9.0)
sparc64:p5-Alien-GvaScript-1.45nb3.tgz(NetBSD 9.0)
sparc:p5-Alien-GvaScript-1.45nb3.tgz(NetBSD 9.0)
x86_64:p5-Alien-GvaScript-1.45nb3.tgz(NetBSD 9.0)
x86_64:p5-Alien-GvaScript-1.45nb3.tgz(NetBSD 9.0)
x86_64:p5-Alien-GvaScript-1.45nb3.tgz(NetBSD 9.0)
x86_64:p5-Alien-GvaScript-1.45nb3.tgz(NetBSD 9.0)
x86_64:p5-Alien-GvaScript-1.45nb3.tgz(NetBSD 8.0)
x86_64:p5-Alien-GvaScript-1.45nb2.tgz(NetBSD 8.0)
x86_64:p5-Alien-GvaScript-1.45nb3.tgz(NetBSD 8.0)
x86_64:p5-Alien-GvaScript-1.45nb2.tgz(NetBSD 9.0)
x86_64:p5-Alien-GvaScript-1.45nb3.tgz(NetBSD 9.0)
x86_64:p5-Alien-GvaScript-1.45nb3.tgz(NetBSD 9.0)
x86_64:p5-Alien-GvaScript-1.45nb3.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]