www/ocsigen - The NetBSD Packages Collection

Web programming framework for OCaml

Ocsigen is a web programming framework for OCaml. It can be used as a web
server, serving static pages, but it is also possible to implement entire
web sites as OCaml modules.

Build dependencies

misc/ocaml-opaline misc/ocaml-opaline devel/gmake pkgtools/cwrappers

Runtime dependencies

devel/ocaml-dune devel/ocaml-findlib lang/ocaml archivers/ocaml-zip devel/ocaml-hmap devel/ocaml-lwt_log devel/ocaml-lwt devel/ocaml-lwt_react devel/ocaml-react devel/ocaml-lwt_ssl security/ocaml-ssl devel/pcre-ocaml net/ocaml-conduit net/ocaml-ipaddr security/ocaml-cryptokit textproc/ocaml-xml-light www/ocaml-cohttp devel/ocaml-dune devel/ocaml-findlib archivers/ocaml-zip devel/ocaml-lwt_log devel/ocaml-lwt devel/ocaml-lwt_react devel/ocaml-react devel/ocaml-lwt_ssl security/ocaml-ssl devel/pcre-ocaml net/ocaml-conduit security/ocaml-cryptokit textproc/ocaml-xml-light

Binary packages

OSArchitectureVersion
NetBSD 8.0i386ocsigen-2.16.1nb1.tgz
NetBSD 8.0i386ocsigen-5.0.1.tgz
NetBSD 8.0powerpcocsigen-2.16.1nb1.tgz
NetBSD 8.0powerpcocsigen-2.16.1nb1.tgz
NetBSD 8.0x86_64ocsigen-5.0.1.tgz
NetBSD 8.0x86_64ocsigen-2.16.1nb1.tgz
NetBSD 9.0aarch64ocsigen-5.0.1.tgz
NetBSD 9.0aarch64ocsigen-2.16.1nb1.tgz
NetBSD 9.0i386ocsigen-5.0.1.tgz
NetBSD 9.0i386ocsigen-2.16.1nb1.tgz
NetBSD 9.0powerpcocsigen-2.16.1nb1.tgz
NetBSD 9.0powerpcocsigen-2.16.1nb1.tgz
NetBSD 9.0x86_64ocsigen-5.0.1.tgz
NetBSD 9.0x86_64ocsigen-5.0.1.tgz
NetBSD 9.0x86_64ocsigen-5.0.1.tgz
NetBSD 9.0x86_64ocsigen-2.16.1nb1.tgz
NetBSD 9.0x86_64ocsigen-2.16.1nb1.tgz
NetBSD 9.0x86_64ocsigen-5.0.1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.