Daemon Power

The NetBSD Packages Collection: www/ocsigen

Brief description of the package:
Web programming framework for OCaml

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://www.ocsigen.org/.

Please note that this package has a gnu-lgpl-v2.1 license.

The package is located in the "www/ocsigen" directory. The current source version of the package is "ocsigen-2.9". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for www/ocsigen :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: ocaml-react-[0-9]* ocaml-text-[0-9]* ocaml-findlib>=1.2 ocaml>=4.06.0 ocaml-findlib>=1.8.0nb1 ocaml>=4.06.1 ocamlbuild>=0.9.2 cwrappers>=20150314 ocamlbuild>=0.12.0 ocaml-zip-[0-9]* ocaml>=3.12.0 ocaml-dbm>=1.0 ocaml-lwt_log>=1.1.0 ocaml-lwt_react>=1.1.0 ocaml-lwt_ssl>=1.1.0 ocaml-ssl>=0.4.0 pcre-ocaml>=5.10.3nb1 ocaml-ipaddr>=2.0.0 ocaml-ppx_sexp_conv>=0.9.0 ocaml-jbuilder>=1.0_beta13nb1 ocaml-ppx_sexp_conv>=0.11.2 ocaml-jbuilder>=1.0_beta20 ocaml-opaline>=0.3.0 ocamlnet>=4.1.2 gnutls>=3.3.0 lzo>=2.01 autogen>=5.12nb5 gmp>=5.0 gmp>=4.2.1 libcfg+>=0.6.2nb1 libtasn1>=4.9 libtasn1>=0.2.7 nettle>=3.1 gmp>=5.0.1 nettle>=2.4 p11-kit>=0.23.1 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 libtasn1>=0.3.0 p11-kit>=0.10 p11-kit>=0.23 libunistring>=0.9.3 libcfg+>=0.6.2nb3 nettle>=3.1.1 libunistring>=0.9.4 ocaml-zip>=1.05nb6 gnutls>=3.6.0nb1 pcre-ocaml>=7.3.4nb2 ocaml-zip>=1.07nb2 ocaml-cryptokit>=1.5 ocaml-zarith>=1.2.1 ocaml-zarith>=1.4.1nb6 ocaml-tyxml>=4.0.1 ocaml-ppx_tools>=0.99.3 ocaml-re>=1.6.0 camlp4>=4.06 ocaml-markup>=0.7.2 ocaml-lwt>=4.0.0 ocaml-uutf>=0.9.3nb1 ocaml-topkg>=0.9.0 ocaml-cmdliner>=0.9.8 ocaml-uchar>=0.0.1 ocaml-topkg>=0.9.1 ocaml-cmdliner>=1.0.2nb2 ocaml-uchar>=0.0.1nb1 ocaml-lwt>=4.0.1 ocaml-uutf>=1.0.1 ocaml-ppx_tools>=5.1 ocaml-re>=1.7.3 ocaml-markup>=0.7.6 ocaml-dbm>=1.0nb15 ocaml-lwt_react>=1.1.1 ocaml-lwt_ssl>=1.1.2 ocaml-ssl>=0.5.5nb1 ocaml-ipaddr>=2.8.0nb4 ocamlnet>=4.1.6 ocaml-cryptokit>=1.11nb3 ocaml-tyxml>=4.2.0 .

This package requires the following package(s) to run: ocaml-react-[0-9]* ocaml-text-[0-9]* ocaml-findlib>=1.2 ocaml>=4.06.0 ocaml-findlib>=1.8.0nb1 ocaml>=4.06.1 ocaml-zip-[0-9]* ocaml>=3.12.0 ocaml-dbm>=1.0 ocaml-lwt_log>=1.1.0 ocaml-lwt_react>=1.1.0 ocaml-lwt_ssl>=1.1.0 ocaml-ssl>=0.4.0 pcre-ocaml>=5.10.3nb1 ocaml-ipaddr>=2.0.0 ocaml-ppx_sexp_conv>=0.9.0 ocaml-jbuilder>=1.0_beta13nb1 ocaml-ppx_sexp_conv>=0.11.2 ocaml-jbuilder>=1.0_beta20 ocamlnet>=4.1.2 gnutls>=3.3.0 lzo>=2.01 autogen>=5.12nb5 gmp>=5.0 gmp>=4.2.1 libcfg+>=0.6.2nb1 libtasn1>=4.9 libtasn1>=0.2.7 nettle>=3.1 gmp>=5.0.1 nettle>=2.4 p11-kit>=0.23.1 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 libtasn1>=0.3.0 p11-kit>=0.10 p11-kit>=0.23 libunistring>=0.9.3 libcfg+>=0.6.2nb3 nettle>=3.1.1 libunistring>=0.9.4 ocaml-zip>=1.05nb6 gnutls>=3.6.0nb1 pcre-ocaml>=7.3.4nb2 ocaml-zip>=1.07nb2 ocaml-cryptokit>=1.5 ocaml-zarith>=1.2.1 ocaml-zarith>=1.4.1nb6 ocaml-tyxml>=4.0.1 ocaml-ppx_tools>=0.99.3 ocaml-re>=1.6.0 camlp4>=4.06 ocaml-markup>=0.7.2 ocaml-lwt>=4.0.0 ocaml-uutf>=0.9.3nb1 ocaml-topkg>=0.9.0 ocaml-cmdliner>=0.9.8 ocaml-uchar>=0.0.1 ocaml-topkg>=0.9.1 ocaml-cmdliner>=1.0.2nb2 ocaml-uchar>=0.0.1nb1 ocaml-lwt>=4.0.1 ocaml-uutf>=1.0.1 ocaml-ppx_tools>=5.1 ocaml-re>=1.7.3 ocaml-markup>=0.7.6 ocaml-dbm>=1.0nb15 ocaml-lwt_react>=1.1.1 ocaml-lwt_ssl>=1.1.2 ocaml-ssl>=0.5.5nb1 ocaml-ipaddr>=2.8.0nb4 ocamlnet>=4.1.6 ocaml-cryptokit>=1.11nb3 ocaml-tyxml>=4.2.0 .

This package supports the following build-time options:

camlzip
Enable camlzip support (for zip/gz/jar).
gdbm
Use the GNU gdbm database library.
pgsql
Enable PostgreSQL support.
sqlite
Enable SQLite support.

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
i386:ocsigen-2.7nb1.tgz(NetBSD 6.0)
i386:ocsigen-2.7nb1.tgz(NetBSD 6.0)
i386:ocsigen-2.8nb1.tgz(NetBSD 6.0)
i386:ocsigen-2.8nb1.tgz(NetBSD 6.0)
i386:ocsigen-2.7nb1.tgz(NetBSD 6.1)
i386:ocsigen-2.7nb1.tgz(NetBSD 6.1)
i386:ocsigen-2.8nb1.tgz(NetBSD 6.1)
i386:ocsigen-2.8nb1.tgz(NetBSD 6.1)
i386:ocsigen-2.7nb1.tgz(NetBSD 7.0)
i386:ocsigen-2.7nb1.tgz(NetBSD 7.0)
i386:ocsigen-2.8nb1.tgz(NetBSD 7.0)
i386:ocsigen-2.8nb1.tgz(NetBSD 7.0)
x86_64:ocsigen-2.8nb1.tgz(NetBSD 7.0.1_PATCH)
x86_64:ocsigen-2.8nb1.tgz(NetBSD 8.99.1)
x86_64:ocsigen-2.8nb3.tgz(NetBSD 8.0)
x86_64:ocsigen-2.8nb2.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]