www/nspluginwrapper - The NetBSD Packages Collection

Use Netscape compatible plugins from other platforms

nspluginwrapper is an Open Source compatibility plugin for Netscape
4 (NPAPI) plugins. It separates the execution environment of the
plugin from the browser, allowing a plugin compiled for one ABI to
be used in a browser compiled for another.

For example the linux 32bit Adobe Flash plugin can be used in a
native Firefox under Linux/x86_64, NetBSD, DragonFlyBSD and FreeBSD
platforms.

To install the Linux flash player into a native Firefox browser:
  - Also install multimedia/adobe-flash-player and
    multimedia/libflashsupport
  - Run "nspluginwrapper -i /usr/pkg/lib/netscape/plugins/libflashplayer.so"
  - Run Firefox

You do not need nspluginwrapper if the ABI of the plugin and browser are the
same, such as running a 32 bit Linux firefox and flash plugin under NetBSD.

Build dependencies

pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/glib2-tools devel/gmake devel/pkgconf

Runtime dependencies

emulators/suse131_base emulators/suse131_gtk2 emulators/suse131_x11 devel/glib2 www/curl x11/gtk2 devel/glib2 www/curl x11/gtk2

Available binary packages

i386:nspluginwrapper-1.4.4nb28.tgz(NetBSD 8.0)
i386:nspluginwrapper-1.4.4nb29.tgz(NetBSD 8.0)
i386:nspluginwrapper-1.4.4nb29.tgz(NetBSD 8.0)
i386:nspluginwrapper-1.4.4nb28.tgz(NetBSD 9.0)
i386:nspluginwrapper-1.4.4nb29.tgz(NetBSD 9.0)
i386:nspluginwrapper-1.4.4nb29.tgz(NetBSD 9.0)
x86_64:nspluginwrapper-1.4.4nb29.tgz(NetBSD 9.0)
x86_64:nspluginwrapper-1.4.4nb29.tgz(NetBSD 9.0)
x86_64:nspluginwrapper-1.4.4nb29.tgz(NetBSD 9.0)
x86_64:nspluginwrapper-1.4.4nb29.tgz(NetBSD 9.0)
x86_64:nspluginwrapper-1.4.4nb29.tgz(NetBSD 8.0)
x86_64:nspluginwrapper-1.4.4nb28.tgz(NetBSD 8.0)
x86_64:nspluginwrapper-1.4.4nb29.tgz(NetBSD 8.0)
x86_64:nspluginwrapper-1.4.4nb28.tgz(NetBSD 9.0)
x86_64:nspluginwrapper-1.4.4nb29.tgz(NetBSD 9.0)
x86_64:nspluginwrapper-1.4.4nb29.tgz(NetBSD 9.0)
x86_64:nspluginwrapper-1.4.4nb29.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]