Daemon Power

The NetBSD Packages Collection: www/nginx-devel

Brief description of the package:
Lightweight HTTP server and mail proxy server

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://nginx.org/.

Please note that this package has a 2-clause-bsd license.

The package is located in the "www/nginx-devel" directory. The current source version of the package is "nginx-1.13.6". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for www/nginx-devel :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: pcre>=3.4nb1 cwrappers>=20150314 pcre>=8.30nb1 .

This package requires the following package(s) to run: pcre>=3.4nb1 pcre>=8.30nb1 .

This package supports the following build-time options:

array-var
auth-request
dav
debug
Enable debugging facilities in the package.
echo
encrypted-session
flv
form-input
gtools
gzip
Enable compression using gzip.
headers-more
http2
Add support for HTTP/2.
image-filter
inet6
Enable support for IPv6.
luajit
mail-proxy
memcache
naxsi
nginx-autodetect-cflags
pcre
Enable Perl-compatible regular expressions.
perl
Enable Perl support.
push
realip
rtmp
Enable rtmp:// support using rtmpdump.
set-misc
ssl
Enable SSL support.
status
sub
uwsgi

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
alpha:nginx-1.9.10.tgz(NetBSD 7.0)
alpha:nginx-1.9.4.tgz(NetBSD 7.0)
alpha:nginx-1.9.5nb1.tgz(NetBSD 7.0)
arm:nginx-1.5.12nb3.tgz(NetBSD 6.1_STABLE)
earm:nginx-1.9.5nb1.tgz(NetBSD 7.0)
earm:nginx-1.9.5nb1.tgz(NetBSD 7.0)
earmv6hf:nginx-1.7.10.tgz(NetBSD 7.0)
earmv6hf:nginx-1.9.4.tgz(NetBSD 7.0)
earmv6hf:nginx-1.9.5nb1.tgz(NetBSD 7.0)
earmv7hf:nginx-1.9.5nb1.tgz(NetBSD 7.0)
earmv7hf:nginx-1.9.5nb1.tgz(NetBSD 7.0)
earmv7hf:nginx-1.13.0.tgz(NetBSD 8.0_BETA)
i386:nginx-1.5.12nb3.tgz(MirBSD 10)
i386:nginx-1.13.3.tgz(NetBSD 6.0)
i386:nginx-1.11.1.tgz(NetBSD 6.0)
i386:nginx-1.11.4.tgz(NetBSD 6.0)
i386:nginx-1.11.9.tgz(NetBSD 6.0)
i386:nginx-1.13.0nb1.tgz(NetBSD 6.0)
i386:nginx-1.13.3.tgz(NetBSD 6.1)
i386:nginx-1.11.1.tgz(NetBSD 6.1)
i386:nginx-1.11.4.tgz(NetBSD 6.1)
i386:nginx-1.11.9.tgz(NetBSD 6.1)
i386:nginx-1.13.0nb1.tgz(NetBSD 6.1)
i386:nginx-1.13.3.tgz(NetBSD 7.0)
i386:nginx-1.11.1.tgz(NetBSD 7.0)
i386:nginx-1.11.4.tgz(NetBSD 7.0)
i386:nginx-1.11.9.tgz(NetBSD 7.0)
i386:nginx-1.13.0nb1.tgz(NetBSD 7.0)
powerpc:nginx-1.11.1.tgz(NetBSD 6.0)
powerpc:nginx-1.13.0nb1.tgz(NetBSD 6.1)
powerpc:nginx-1.9.5nb1.tgz(NetBSD 7.0)
powerpc:nginx-1.13.0nb1.tgz(NetBSD 7.1)
powerpc:nginx-1.13.3.tgz(NetBSD 7.1)
powerpc:nginx-1.13.0nb1.tgz(NetBSD 8.0)
sparc64:nginx-1.7.10.tgz(NetBSD 7.0)
x86_64:nginx-1.13.3.tgz(NetBSD 6.0)
x86_64:nginx-1.11.1.tgz(NetBSD 6.0)
x86_64:nginx-1.11.4.tgz(NetBSD 6.0)
x86_64:nginx-1.11.9.tgz(NetBSD 6.0)
x86_64:nginx-1.13.0nb1.tgz(NetBSD 6.0)
x86_64:nginx-1.13.3.tgz(NetBSD 6.1)
x86_64:nginx-1.11.1.tgz(NetBSD 6.1)
x86_64:nginx-1.11.4.tgz(NetBSD 6.1)
x86_64:nginx-1.11.9.tgz(NetBSD 6.1)
x86_64:nginx-1.13.0nb1.tgz(NetBSD 6.1)
x86_64:nginx-1.13.3.tgz(NetBSD 7.0)
x86_64:nginx-1.11.1.tgz(NetBSD 7.0)
x86_64:nginx-1.11.4.tgz(NetBSD 7.0)
x86_64:nginx-1.11.9.tgz(NetBSD 7.0)
x86_64:nginx-1.13.0nb1.tgz(NetBSD 7.0)
x86_64:nginx-1.13.0.tgz(NetBSD 7.0.1_PATCH)
x86_64:nginx-1.13.0nb1.tgz(NetBSD 8.99.1)
x86_64:nginx-1.13.3.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]