www/lighttpd - The NetBSD Packages Collection

Fast, light-footprint HTTP server

Lighttpd is a secure, speedy, compliant, and very flexible web-server
which is designed and optimized for for high-performance environments.
With a small memory footprint compared to other web-servers, effective
management of the CPU-load, and advanced feature set (FastCGI, SCGI,
Auth, Output-Compression, URL-Rewriting and many more) lighttpd is the
perfect solution for every server that is suffering load problems.

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/pkgconf

Runtime dependencies

security/nettle devel/pcre security/nettle devel/pcre

Available binary packages

aarch64:lighttpd-1.4.55nb2.tgz(NetBSD 9.0)
aarch64:lighttpd-1.4.55nb2.tgz(NetBSD 9.0)
aarch64:lighttpd-1.4.58.tgz(NetBSD 9.0)
alpha:lighttpd-1.4.58.tgz(NetBSD 9.0)
alpha:lighttpd-1.4.55nb2.tgz(NetBSD 9.0)
earmv6hf:lighttpd-1.4.58.tgz(NetBSD 9.0)
earmv6hf:lighttpd-1.4.55nb2.tgz(NetBSD 9.0)
earmv6hf:lighttpd-1.4.55nb2.tgz(NetBSD 9.0)
earmv6hf:lighttpd-1.4.58.tgz(NetBSD 9.0)
earmv7hf:lighttpd-1.4.58.tgz(NetBSD 8.0)
earmv7hf:lighttpd-1.4.55.tgz(NetBSD 8.0)
earmv7hf:lighttpd-1.4.55nb2.tgz(NetBSD 8.0)
earmv7hf:lighttpd-1.4.55nb2.tgz(NetBSD 8.0)
earmv7hf:lighttpd-1.4.58.tgz(NetBSD 9.0)
earmv7hf:lighttpd-1.4.55.tgz(NetBSD 9.0)
earmv7hf:lighttpd-1.4.55nb2.tgz(NetBSD 9.0)
earmv7hf:lighttpd-1.4.55nb2.tgz(NetBSD 9.0)
earmv7hf:lighttpd-1.4.58.tgz(NetBSD 9.0)
i386:lighttpd-1.4.55nb2.tgz(NetBSD 8.0)
i386:lighttpd-1.4.55nb2.tgz(NetBSD 8.0)
i386:lighttpd-1.4.58.tgz(NetBSD 8.0)
i386:lighttpd-1.4.55nb2.tgz(NetBSD 9.0)
i386:lighttpd-1.4.55nb2.tgz(NetBSD 9.0)
i386:lighttpd-1.4.58.tgz(NetBSD 9.0)
mips64eb:lighttpd-1.4.55nb2.tgz(NetBSD 9.0)
powerpc:lighttpd-1.4.55nb2.tgz(NetBSD 8.0)
powerpc:lighttpd-1.4.58.tgz(NetBSD 8.0)
powerpc:lighttpd-1.4.55nb2.tgz(NetBSD 8.0)
powerpc:lighttpd-1.4.55nb2.tgz(NetBSD 9.0)
powerpc:lighttpd-1.4.55nb2.tgz(NetBSD 9.0)
powerpc:lighttpd-1.4.58.tgz(NetBSD 9.0)
sparc64:lighttpd-1.4.58.tgz(NetBSD 9.0)
sparc64:lighttpd-1.4.55nb2.tgz(NetBSD 9.0)
sparc64:lighttpd-1.4.55nb2.tgz(NetBSD 9.0)
sparc:lighttpd-1.4.55nb2.tgz(NetBSD 9.0)
x86_64:lighttpd-1.4.55nb4.tgz(NetBSD 9.0)
x86_64:lighttpd-1.4.58.tgz(NetBSD 9.0)
x86_64:lighttpd-1.4.58.tgz(NetBSD 9.0)
x86_64:lighttpd-1.4.55nb2.tgz(NetBSD 9.0)
x86_64:lighttpd-1.4.55nb2.tgz(NetBSD 8.0)
x86_64:lighttpd-1.4.55nb2.tgz(NetBSD 8.0)
x86_64:lighttpd-1.4.58.tgz(NetBSD 8.0)
x86_64:lighttpd-1.4.55nb2.tgz(NetBSD 9.0)
x86_64:lighttpd-1.4.55nb2.tgz(NetBSD 9.0)
x86_64:lighttpd-1.4.58.tgz(NetBSD 9.0)
x86_64:lighttpd-1.4.59.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

brotli
Provides the BROTLI_COMPRESS output filter.
bzip2
Enable compression using bzip2.
fam
Support using File Alteration Monitor (FAM).
gdbm
Use the GNU gdbm database library.
geoip
Enable IP-to-country-lookup.
gssapi
Enable gssapi (Kerberos V) support.
inet6
Enable support for IPv6.
ldap
Enable LDAP support.
libdbi
Enable libdbi support (similar p5-DBI but for C).
lua
Enable Lua support.
memcached
Enable memcached support.
mysql
Enable MySQL support.
ssl
Enable SSL support.
webdav
Enable WebDAV support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]