www/libmicrohttpd - The NetBSD Packages Collection

Small C library to run an HTTP server as part of another app

GNU libmicrohttpd is a small C library that is supposed to make it
easy to run an HTTP server as part of another application. GNU
libmicrohttpd is free software and part of the GNU project. Key
features that distinguish libmicrohttpd from other projects are:

 * C library: fast and small
 * API is simple, expressive and fully reentrant
 * Implementation is HTTP 1.1 compliant
 * HTTP server can listen on multiple ports
 * Four different threading models (select, poll, pthread, thread pool)
 * Supported platforms include GNU/Linux, FreeBSD, OpenBSD, NetBSD, OS X, W32,
   Symbian and z/OS
 * Support for IPv6
 * Support for SHOUTcast
 * Support for incremental processing of POST data (optional)
 * Support for basic and digest authentication (optional)
 * Support for SSL3 and TLS (requires libgcrypt and libgnutls, optional)
 * Binary is only about 32k (without TLS/SSL support and other optional
   features)

Build dependencies

www/curl pkgtools/cwrappers www/curl devel/libtool-base devel/pkgconf

Runtime dependencies

security/gnutls security/gnutls

Available binary packages

aarch64:libmicrohttpd-0.9.70nb2.tgz(NetBSD 9.0)
aarch64:libmicrohttpd-0.9.71.tgz(NetBSD 9.0)
aarch64:libmicrohttpd-0.9.71.tgz(NetBSD 9.0)
alpha:libmicrohttpd-0.9.71.tgz(NetBSD 9.0)
alpha:libmicrohttpd-0.9.70nb2.tgz(NetBSD 9.0)
alpha:libmicrohttpd-0.9.71.tgz(NetBSD 9.0)
earm:libmicrohttpd-0.9.71.tgz(NetBSD 9.0)
earmv6hf:libmicrohttpd-0.9.71.tgz(NetBSD 9.0)
earmv6hf:libmicrohttpd-0.9.70nb2.tgz(NetBSD 9.0)
earmv6hf:libmicrohttpd-0.9.71.tgz(NetBSD 9.0)
earmv6hf:libmicrohttpd-0.9.71.tgz(NetBSD 9.0)
earmv7hf:libmicrohttpd-0.9.71.tgz(NetBSD 8.0)
earmv7hf:libmicrohttpd-0.9.70.tgz(NetBSD 8.0)
earmv7hf:libmicrohttpd-0.9.70nb2.tgz(NetBSD 8.0)
earmv7hf:libmicrohttpd-0.9.71.tgz(NetBSD 8.0)
earmv7hf:libmicrohttpd-0.9.71.tgz(NetBSD 9.0)
earmv7hf:libmicrohttpd-0.9.70.tgz(NetBSD 9.0)
earmv7hf:libmicrohttpd-0.9.70nb2.tgz(NetBSD 9.0)
earmv7hf:libmicrohttpd-0.9.71.tgz(NetBSD 9.0)
earmv7hf:libmicrohttpd-0.9.71.tgz(NetBSD 9.0)
i386:libmicrohttpd-0.9.70nb2.tgz(NetBSD 8.0)
i386:libmicrohttpd-0.9.71.tgz(NetBSD 8.0)
i386:libmicrohttpd-0.9.71.tgz(NetBSD 8.0)
i386:libmicrohttpd-0.9.70nb2.tgz(NetBSD 9.0)
i386:libmicrohttpd-0.9.71.tgz(NetBSD 9.0)
i386:libmicrohttpd-0.9.71.tgz(NetBSD 9.0)
mips64eb:libmicrohttpd-0.9.71.tgz(NetBSD 9.0)
mips64eb:libmicrohttpd-0.9.71.tgz(NetBSD 9.0)
powerpc:libmicrohttpd-0.9.70nb2.tgz(NetBSD 8.0)
powerpc:libmicrohttpd-0.9.71.tgz(NetBSD 8.0)
powerpc:libmicrohttpd-0.9.71.tgz(NetBSD 8.0)
powerpc:libmicrohttpd-0.9.71.tgz(NetBSD 9.0)
powerpc:libmicrohttpd-0.9.70nb2.tgz(NetBSD 9.0)
sparc64:libmicrohttpd-0.9.71.tgz(NetBSD 9.0)
sparc64:libmicrohttpd-0.9.70nb2.tgz(NetBSD 9.0)
sparc64:libmicrohttpd-0.9.71.tgz(NetBSD 9.0)
sparc:libmicrohttpd-0.9.71.tgz(NetBSD 9.0)
x86_64:libmicrohttpd-0.9.71.tgz(NetBSD 9.0)
x86_64:libmicrohttpd-0.9.71.tgz(NetBSD 9.0)
x86_64:libmicrohttpd-0.9.72nb2.tgz(NetBSD 9.0)
x86_64:libmicrohttpd-0.9.71.tgz(NetBSD 9.0)
x86_64:libmicrohttpd-0.9.71.tgz(NetBSD 8.0)
x86_64:libmicrohttpd-0.9.70nb2.tgz(NetBSD 8.0)
x86_64:libmicrohttpd-0.9.71.tgz(NetBSD 8.0)
x86_64:libmicrohttpd-0.9.70nb2.tgz(NetBSD 9.0)
x86_64:libmicrohttpd-0.9.71.tgz(NetBSD 9.0)
x86_64:libmicrohttpd-0.9.71.tgz(NetBSD 9.0)
x86_64:libmicrohttpd-0.9.72nb2.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]