www/fcgi - The NetBSD Packages Collection

FastCGI application development kit

FastCGI is an open extension to CGI that provides high performance for
all Internet applications without the penalties of Web server APIs.

FastCGI is designed to be layered on top of existing Web server APIs.
For instance, the mod_fastcgi Apache module adds FastCGI support to
the Apache server.  FastCGI can also be used, with reduced
functionality and reduced performance, on any Web server that supports
CGI.

This FastCGI Developer's Kit is designed to make developing FastCGI
applications easy.  The kit currently supports FastCGI applications
written in C/C++, Perl, Tcl, and Java.

Build dependencies

pkgtools/cwrappers devel/libtool-base

Runtime dependencies

(none)

Available binary packages

aarch64:fcgi-2.4.0nb3.tgz(NetBSD 9.0)
aarch64:fcgi-2.4.0nb3.tgz(NetBSD 9.0)
aarch64:fcgi-2.4.0nb3.tgz(NetBSD 9.0)
alpha:fcgi-2.4.0nb3.tgz(NetBSD 9.0)
alpha:fcgi-2.4.0nb3.tgz(NetBSD 9.0)
alpha:fcgi-2.4.0nb3.tgz(NetBSD 9.0)
earm:fcgi-2.4.0nb3.tgz(NetBSD 9.0)
earm:fcgi-2.4.0nb2.tgz(NetBSD 9.0)
earmv6hf:fcgi-2.4.0nb3.tgz(NetBSD 9.0)
earmv6hf:fcgi-2.4.0nb3.tgz(NetBSD 9.0)
earmv6hf:fcgi-2.4.0nb3.tgz(NetBSD 9.0)
earmv6hf:fcgi-2.4.0nb3.tgz(NetBSD 9.0)
earmv7hf:fcgi-2.4.0nb3.tgz(NetBSD 8.0)
earmv7hf:fcgi-2.4.0nb2.tgz(NetBSD 8.0)
earmv7hf:fcgi-2.4.0nb3.tgz(NetBSD 8.0)
earmv7hf:fcgi-2.4.0nb3.tgz(NetBSD 8.0)
earmv7hf:fcgi-2.4.0nb3.tgz(NetBSD 9.0)
earmv7hf:fcgi-2.4.0nb2.tgz(NetBSD 9.0)
earmv7hf:fcgi-2.4.0nb3.tgz(NetBSD 9.0)
earmv7hf:fcgi-2.4.0nb3.tgz(NetBSD 9.0)
earmv7hf:fcgi-2.4.0nb3.tgz(NetBSD 9.0)
i386:fcgi-2.4.0nb3.tgz(NetBSD 8.0)
i386:fcgi-2.4.0nb3.tgz(NetBSD 8.0)
i386:fcgi-2.4.0nb3.tgz(NetBSD 8.0)
i386:fcgi-2.4.0nb3.tgz(NetBSD 9.0)
i386:fcgi-2.4.0nb3.tgz(NetBSD 9.0)
i386:fcgi-2.4.0nb3.tgz(NetBSD 9.0)
m68k:fcgi-2.4.0nb2.tgz(NetBSD 9.0)
mips64eb:fcgi-2.4.0nb3.tgz(NetBSD 9.0)
mips64eb:fcgi-2.4.0nb3.tgz(NetBSD 9.0)
mipsel:fcgi-2.4.0nb3.tgz(NetBSD 9.0)
powerpc:fcgi-2.4.0nb3.tgz(NetBSD 8.0)
powerpc:fcgi-2.4.0nb3.tgz(NetBSD 8.0)
powerpc:fcgi-2.4.0nb3.tgz(NetBSD 8.0)
powerpc:fcgi-2.4.0nb3.tgz(NetBSD 9.0)
powerpc:fcgi-2.4.0nb3.tgz(NetBSD 9.0)
sh3el:fcgi-2.4.0nb3.tgz(NetBSD 9.0)
sparc64:fcgi-2.4.0nb3.tgz(NetBSD 9.0)
sparc64:fcgi-2.4.0nb3.tgz(NetBSD 9.0)
sparc64:fcgi-2.4.0nb3.tgz(NetBSD 9.0)
sparc:fcgi-2.4.0nb3.tgz(NetBSD 9.0)
sparc:fcgi-2.4.0nb3.tgz(NetBSD 9.0)
sparc:fcgi-2.4.0nb3.tgz(NetBSD 9.0)
x86_64:fcgi-2.4.0nb3.tgz(NetBSD 9.0)
x86_64:fcgi-2.4.0nb3.tgz(NetBSD 9.0)
x86_64:fcgi-2.4.0nb3.tgz(NetBSD 9.0)
x86_64:fcgi-2.4.0nb3.tgz(NetBSD 9.0)
x86_64:fcgi-2.4.0nb3.tgz(NetBSD 8.0)
x86_64:fcgi-2.4.0nb3.tgz(NetBSD 8.0)
x86_64:fcgi-2.4.0nb3.tgz(NetBSD 8.0)
x86_64:fcgi-2.4.0nb3.tgz(NetBSD 9.0)
x86_64:fcgi-2.4.0nb3.tgz(NetBSD 9.0)
x86_64:fcgi-2.4.0nb3.tgz(NetBSD 9.0)
x86_64:fcgi-2.4.0nb3.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]