www/ap2-perl - The NetBSD Packages Collection

Module that embeds a Perl interpreter into Apache

The Apache/Perl integration project brings together the full power of the
Perl programming language and the Apache HTTP server.  This is achieved by
linking the Perl runtime library into the server and providing an object
oriented Perl interface to the server's C language API.

These pieces are seamlessly glued together by the `mod_perl' server
plugin, making it is possible to write Apache modules entirely in Perl.
In addition, the persistent interpreter embedded in the server avoids the
overhead of starting an external interpreter program and the additional
Perl start-up (compile) time.

Build dependencies

pkgtools/cwrappers lang/perl5

Runtime dependencies

www/apache24 lang/perl5 lang/perl5 www/apache24

Available binary packages

aarch64:ap24-perl-2.0.11.tgz(NetBSD 9.0)
aarch64:ap24-perl-2.0.11nb1.tgz(NetBSD 9.0)
aarch64:ap24-perl-2.0.11nb1.tgz(NetBSD 9.0)
alpha:ap24-perl-2.0.11nb1.tgz(NetBSD 9.0)
alpha:ap24-perl-2.0.11.tgz(NetBSD 9.0)
alpha:ap24-perl-2.0.11nb1.tgz(NetBSD 9.0)
earm:ap24-perl-2.0.11nb1.tgz(NetBSD 9.0)
earmv6hf:ap24-perl-2.0.11nb1.tgz(NetBSD 9.0)
earmv6hf:ap24-perl-2.0.11.tgz(NetBSD 9.0)
earmv6hf:ap24-perl-2.0.11nb1.tgz(NetBSD 9.0)
earmv6hf:ap24-perl-2.0.11nb1.tgz(NetBSD 9.0)
earmv7hf:ap24-perl-2.0.11nb1.tgz(NetBSD 8.0)
earmv7hf:ap24-perl-2.0.11.tgz(NetBSD 8.0)
earmv7hf:ap24-perl-2.0.11.tgz(NetBSD 8.0)
earmv7hf:ap24-perl-2.0.11nb1.tgz(NetBSD 8.0)
earmv7hf:ap24-perl-2.0.11nb1.tgz(NetBSD 9.0)
earmv7hf:ap24-perl-2.0.11.tgz(NetBSD 9.0)
earmv7hf:ap24-perl-2.0.11.tgz(NetBSD 9.0)
earmv7hf:ap24-perl-2.0.11nb1.tgz(NetBSD 9.0)
earmv7hf:ap24-perl-2.0.11nb1.tgz(NetBSD 9.0)
i386:ap24-perl-2.0.11.tgz(NetBSD 8.0)
i386:ap24-perl-2.0.11nb1.tgz(NetBSD 8.0)
i386:ap24-perl-2.0.11nb1.tgz(NetBSD 8.0)
i386:ap24-perl-2.0.11.tgz(NetBSD 9.0)
i386:ap24-perl-2.0.11nb1.tgz(NetBSD 9.0)
i386:ap24-perl-2.0.11nb1.tgz(NetBSD 9.0)
m68k:ap24-perl-2.0.11nb1.tgz(NetBSD 9.0)
mips64eb:ap24-perl-2.0.11nb1.tgz(NetBSD 9.0)
mips64eb:ap24-perl-2.0.11nb1.tgz(NetBSD 9.0)
powerpc:ap24-perl-2.0.11.tgz(NetBSD 8.0)
powerpc:ap24-perl-2.0.11.tgz(NetBSD 8.0)
powerpc:ap24-perl-2.0.11nb1.tgz(NetBSD 8.0)
powerpc:ap24-perl-2.0.11.tgz(NetBSD 8.0)
powerpc:ap24-perl-2.0.11nb1.tgz(NetBSD 8.0)
powerpc:ap24-perl-2.0.11.tgz(NetBSD 9.0)
powerpc:ap24-perl-2.0.11nb1.tgz(NetBSD 9.0)
powerpc:ap24-perl-2.0.11.tgz(NetBSD 9.0)
sh3el:ap24-perl-2.0.11nb1.tgz(NetBSD 9.0)
sh3el:ap24-perl-2.0.11nb1.tgz(NetBSD 9.0)
sparc64:ap24-perl-2.0.11nb1.tgz(NetBSD 9.0)
sparc64:ap24-perl-2.0.11.tgz(NetBSD 9.0)
sparc64:ap24-perl-2.0.11nb1.tgz(NetBSD 9.0)
sparc:ap24-perl-2.0.11nb1.tgz(NetBSD 9.0)
sparc:ap24-perl-2.0.11.tgz(NetBSD 9.0)
sparc:ap24-perl-2.0.11nb1.tgz(NetBSD 9.0)
x86_64:ap24-perl-2.0.11nb1.tgz(NetBSD 9.0)
x86_64:ap24-perl-2.0.11nb1.tgz(NetBSD 9.0)
x86_64:ap24-perl-2.0.11nb1.tgz(NetBSD 9.0)
x86_64:ap24-perl-2.0.11nb1.tgz(NetBSD 9.0)
x86_64:ap24-perl-2.0.11nb1.tgz(NetBSD 8.0)
x86_64:ap24-perl-2.0.11.tgz(NetBSD 8.0)
x86_64:ap24-perl-2.0.11nb1.tgz(NetBSD 8.0)
x86_64:ap24-perl-2.0.11.tgz(NetBSD 9.0)
x86_64:ap24-perl-2.0.11nb1.tgz(NetBSD 9.0)
x86_64:ap24-perl-2.0.11nb1.tgz(NetBSD 9.0)
x86_64:ap24-perl-2.0.11nb1.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]