Daemon Power

The NetBSD Packages Collection: www/ap-auth-mellon

Brief description of the package:
Module to allow Apache authentication using a SAML 2.0 IdP

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://github.com/UNINETT/mod_auth_mellon.

Please note that this package has a gnu-gpl-v2 license.

The package is located in the "www/ap-auth-mellon" directory. The current source version of the package is "ap24-auth-mellon-0.13.1nb1". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for www/ap-auth-mellon :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: glib2>=2.12 perl>=5.0 cwrappers>=20150314 libelf>=0.8.5 pcre>=8.31 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.0.11 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 readline>=2.2 readline>=6.0 python27>=2.7.1nb2 apache>=2.4.7<2.5 apr>=1.5.0 apr-util>=1.5.3 apr-util>=1.2.8 nghttp2>=1.0.0 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 apr-util>=1.5.4nb4 nghttp2>=1.25.0nb1 lasso>=2.2.1 py27-six-[0-9]* py27-setuptools>=0.8 py27-expat-[0-9]* xmlsec1>=1.2.6nb6 libltdl>=2.4.2 libgcrypt>=1.4.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libgcrypt>=1.2.0 libxml2>=2.7.4 libxslt>=1.1.8 libxml2>=2.6.27 libgcrypt>=1.6.0 docbook-xml-[0-9]* docbook-xsl-[0-9]* docbook-xml>=4.2 libltdl>=2.2.6 libxslt>=1.1.28nb2 cyrus-sasl>=2.1.12 glib2>=2.4.0 xmlsec1>=1.2.19nb1 cyrus-sasl>=2.1.26 glib2>=2.35 glib2>=2.34.0 curl>=7.12.3 libidn2>=2.0.0 libunistring>=0.9.3 libunistring>=0.9.4 apache>=2.4.18nb1 lasso>=2.4.1nb2 curl>=7.55.1nb1 .

This package requires the following package(s) to run: glib2>=2.12 perl>=5.0 libelf>=0.8.5 pcre>=8.31 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.0.11 apache>=2.4.7<2.5 apr>=1.5.0 apr-util>=1.5.3 apr-util>=1.2.8 nghttp2>=1.0.0 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 python27>=2.7.1nb2 libxml2>=2.8.0nb2 readline>=2.2 apr-util>=1.5.4nb4 nghttp2>=1.25.0nb1 readline>=6.0 lasso>=2.2.1 py27-six-[0-9]* py27-setuptools>=0.8 py27-expat-[0-9]* xmlsec1>=1.2.6nb6 libltdl>=2.4.2 libgcrypt>=1.4.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libgcrypt>=1.2.0 libxml2>=2.7.4 libxslt>=1.1.8 libxml2>=2.6.27 libgcrypt>=1.6.0 libltdl>=2.2.6 libxslt>=1.1.28nb2 cyrus-sasl>=2.1.12 glib2>=2.4.0 xmlsec1>=1.2.19nb1 cyrus-sasl>=2.1.26 glib2>=2.35 glib2>=2.34.0 curl>=7.12.3 libidn2>=2.0.0 libunistring>=0.9.3 libunistring>=0.9.4 apache>=2.4.18nb1 lasso>=2.4.1nb2 curl>=7.55.1nb1 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
alpha:ap22-auth-mellon-0.13.1.tgz(NetBSD 8.0)
alpha:ap24-auth-mellon-0.13.1.tgz(NetBSD 8.0)
earmv7hf:ap22-auth-mellon-0.13.1.tgz(NetBSD 8.0_BETA)
earmv7hf:ap24-auth-mellon-0.13.1.tgz(NetBSD 8.0_BETA)
i386:ap22-auth-mellon-0.13.1nb1.tgz(NetBSD 6.0)
i386:ap24-auth-mellon-0.13.1nb1.tgz(NetBSD 6.0)
i386:ap22-auth-mellon-0.13.1.tgz(NetBSD 6.0)
i386:ap24-auth-mellon-0.13.1.tgz(NetBSD 6.0)
i386:ap24-auth-mellon-0.13.1nb1.tgz(NetBSD 6.1)
i386:ap22-auth-mellon-0.13.1.tgz(NetBSD 6.1)
i386:ap24-auth-mellon-0.13.1.tgz(NetBSD 6.1)
i386:ap24-auth-mellon-0.13.1nb1.tgz(NetBSD 7.0)
i386:ap22-auth-mellon-0.13.1.tgz(NetBSD 7.0)
i386:ap24-auth-mellon-0.13.1.tgz(NetBSD 7.0)
powerpc:ap22-auth-mellon-0.13.1.tgz(NetBSD 6.1)
powerpc:ap24-auth-mellon-0.13.1.tgz(NetBSD 6.1)
powerpc:ap22-auth-mellon-0.13.1.tgz(NetBSD 7.1)
powerpc:ap24-auth-mellon-0.13.1.tgz(NetBSD 7.1)
powerpc:ap22-auth-mellon-0.13.1.tgz(NetBSD 7.1)
powerpc:ap22-auth-mellon-0.13.1nb1.tgz(NetBSD 7.1)
powerpc:ap24-auth-mellon-0.13.1.tgz(NetBSD 7.1)
powerpc:ap24-auth-mellon-0.13.1nb1.tgz(NetBSD 7.1)
powerpc:ap22-auth-mellon-0.13.1.tgz(NetBSD 8.0)
powerpc:ap24-auth-mellon-0.13.1.tgz(NetBSD 8.0)
powerpc:ap22-auth-mellon-0.13.1.tgz(NetBSD 8.0)
powerpc:ap24-auth-mellon-0.13.1.tgz(NetBSD 8.0)
x86_64:ap22-auth-mellon-0.13.1nb1.tgz(NetBSD 6.0)
x86_64:ap24-auth-mellon-0.13.1nb1.tgz(NetBSD 6.0)
x86_64:ap22-auth-mellon-0.13.1.tgz(NetBSD 6.0)
x86_64:ap24-auth-mellon-0.13.1.tgz(NetBSD 6.0)
x86_64:ap22-auth-mellon-0.13.1nb1.tgz(NetBSD 6.1)
x86_64:ap24-auth-mellon-0.13.1nb1.tgz(NetBSD 6.1)
x86_64:ap22-auth-mellon-0.13.1.tgz(NetBSD 6.1)
x86_64:ap24-auth-mellon-0.13.1.tgz(NetBSD 6.1)
x86_64:ap22-auth-mellon-0.13.1nb1.tgz(NetBSD 7.0)
x86_64:ap24-auth-mellon-0.13.1nb1.tgz(NetBSD 7.0)
x86_64:ap22-auth-mellon-0.13.1.tgz(NetBSD 7.0)
x86_64:ap24-auth-mellon-0.13.1.tgz(NetBSD 7.0)
x86_64:ap22-auth-mellon-0.13.1.tgz(NetBSD 7.0.1_PATCH)
x86_64:ap24-auth-mellon-0.13.1.tgz(NetBSD 7.0.1_PATCH)
x86_64:ap22-auth-mellon-0.13.1.tgz(NetBSD 8.99.1)
x86_64:ap24-auth-mellon-0.13.1.tgz(NetBSD 8.99.1)
x86_64:ap22-auth-mellon-0.13.1nb1.tgz(NetBSD 8.99.1)
x86_64:ap24-auth-mellon-0.13.1nb1.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]