wm/leftwm - The NetBSD Packages Collection

Tiling window manager for adventurers

Left is a tiling window manager written in rust for stability and performance.
The core of left is designed to do one thing and one thing well. Be a window
manager.
Because you probably want more than just a black screen LeftWM is built around
the concept of theming. With themes you can choose between different
bar/compositor/background/colors, whatever makes you happy.

LeftWM has been built from the very beginning to support multiple screens and
has been built around ultrawide monitors. You will see this with the default
key bindings.

Build dependencies

pkgtools/x11-links lang/rust pkgtools/mktools pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64leftwm-0.3.0.tgz
NetBSD 10.0earmv7hfleftwm-0.3.0.tgz
NetBSD 10.0i386leftwm-0.3.0.tgz
NetBSD 10.0powerpcleftwm-0.3.0.tgz
NetBSD 10.0powerpcleftwm-0.3.0.tgz
NetBSD 10.0x86_64leftwm-0.4.0nb1.tgz
NetBSD 10.0x86_64leftwm-0.3.0.tgz
NetBSD 8.0powerpcleftwm-0.4.0nb1.tgz
NetBSD 8.0powerpcleftwm-0.4.0nb1.tgz
NetBSD 8.0x86_64leftwm-0.3.0.tgz
NetBSD 8.0x86_64leftwm-0.3.0.tgz
NetBSD 9.0aarch64leftwm-0.3.0.tgz
NetBSD 9.0aarch64leftwm-0.3.0.tgz
NetBSD 9.0earmv7hfleftwm-0.3.0.tgz
NetBSD 9.0earmv7hfleftwm-0.3.0.tgz
NetBSD 9.0i386leftwm-0.3.0.tgz
NetBSD 9.0i386leftwm-0.3.0.tgz
NetBSD 9.0i386leftwm-0.3.0.tgz
NetBSD 9.0powerpcleftwm-0.3.0.tgz
NetBSD 9.0powerpcleftwm-0.3.0.tgz
NetBSD 9.0powerpcleftwm-0.3.0.tgz
NetBSD 9.0sparc64leftwm-0.3.0.tgz
NetBSD 9.0sparc64leftwm-0.3.0.tgz
NetBSD 9.0sparc64leftwm-0.4.0nb1.tgz
NetBSD 9.0x86_64leftwm-0.3.0.tgz
NetBSD 9.0x86_64leftwm-0.3.0.tgz
NetBSD 9.0x86_64leftwm-0.3.0.tgz
NetBSD 9.0x86_64leftwm-0.3.0.tgz
NetBSD 9.0x86_64leftwm-0.3.0.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.