Daemon Power

The NetBSD Packages Collection: textproc/py-tablib

Brief description of the package:
Format agnostic tabular data library (XLS, JSON, YAML, CSV)

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://tablib.readthedocs.io/.

Please note that this package has a mit license.

The package is located in the "textproc/py-tablib" directory. The current source version of the package is "py37-tablib-2.0.0". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for textproc/py-tablib :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: py37-odfpy-[0-9]* py37-defusedxml-[0-9]* py37-setuptools>=0.8 py37-expat-[0-9]* python37>=3.7 libffi>=1.20 cwrappers>=20150314 libuuid>=2.18 openssl>=1.1.1 libffi>=3.3nb1 openssl>=1.1.1dnb2 readline>=2.2 readline>=6.0 python37>=3.7.0 python37>=3.7.7 py37-openpyxl>=2.6.0 py37-jdcal-[0-9]* py37-lxml-[0-9]* libxml2>=2.9.2 xmlcatmgr>=2.0beta1 libxml2>=2.6.2 libxslt>=1.1.27 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libxml2>=2.6.27 libgcrypt>=1.6.0 libxml2>=2.9.10nb2 docbook-xml-[0-9]* docbook-xsl-[0-9]* docbook-xml>=4.2 perl>=5.0 libxslt>=1.1.8 libxslt>=1.1.34nb2 py37-tabulate-[0-9]* py37-xlrd-[0-9]* py37-xlwt-[0-9]* py37-yaml-[0-9]* libyaml>=0.1.1 libyaml>=0.1.4 py37-setuptools_scm-[0-9]* py37-toml-[0-9]* .

This package requires the following package(s) to run: py37-odfpy-[0-9]* py37-defusedxml-[0-9]* py37-setuptools>=0.8 py37-expat-[0-9]* python37>=3.7 libffi>=1.20 libuuid>=2.18 openssl>=1.1.1 libffi>=3.3nb1 openssl>=1.1.1dnb2 python37>=3.7.0 python37>=3.7.7 py37-openpyxl>=2.6.0 py37-jdcal-[0-9]* py37-lxml-[0-9]* libxml2>=2.9.2 xmlcatmgr>=2.0beta1 libxml2>=2.6.2 libxslt>=1.1.27 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libxml2>=2.6.27 libgcrypt>=1.6.0 libxml2>=2.9.10nb2 libxslt>=1.1.8 libxslt>=1.1.34nb2 py37-tabulate-[0-9]* py37-xlrd-[0-9]* py37-xlwt-[0-9]* py37-yaml-[0-9]* libyaml>=0.1.1 libyaml>=0.1.4 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
aarch64:py27-tablib-0.12.1nb2.tgz(NetBSD 9.0)
aarch64:py36-tablib-0.12.1nb2.tgz(NetBSD 9.0)
aarch64:py37-tablib-0.12.1nb2.tgz(NetBSD 9.0)
alpha:py27-tablib-0.12.1nb2.tgz(NetBSD 8.0)
alpha:py36-tablib-0.12.1nb2.tgz(NetBSD 8.0)
alpha:py37-tablib-0.12.1nb2.tgz(NetBSD 8.0)
alpha:py27-tablib-0.12.1nb2.tgz(NetBSD 9.0)
alpha:py36-tablib-0.12.1nb2.tgz(NetBSD 9.0)
alpha:py37-tablib-0.12.1nb2.tgz(NetBSD 9.0)
earm:py27-tablib-0.12.1nb2.tgz(NetBSD 8.0)
earm:py34-tablib-0.12.1nb2.tgz(NetBSD 8.0)
earm:py36-tablib-0.12.1nb2.tgz(NetBSD 8.0)
earm:py37-tablib-0.12.1nb2.tgz(NetBSD 8.0)
earm:py27-tablib-0.12.1nb2.tgz(NetBSD 8.0)
earm:py34-tablib-0.12.1nb2.tgz(NetBSD 8.0)
earm:py36-tablib-0.12.1nb2.tgz(NetBSD 8.0)
earm:py37-tablib-0.12.1nb2.tgz(NetBSD 8.0)
earmv4:py27-tablib-0.12.1nb2.tgz(NetBSD 8.0)
earmv4:py36-tablib-0.12.1nb2.tgz(NetBSD 8.0)
earmv4:py37-tablib-0.12.1nb2.tgz(NetBSD 8.0)
earmv6hf:py27-tablib-0.12.1nb2.tgz(NetBSD 8.0)
earmv6hf:py36-tablib-0.12.1nb2.tgz(NetBSD 8.0)
earmv6hf:py37-tablib-0.12.1nb2.tgz(NetBSD 8.0)
earmv6hf:py38-tablib-0.12.1nb2.tgz(NetBSD 8.0)
earmv6hf:py27-tablib-0.12.1nb2.tgz(NetBSD 9.0)
earmv6hf:py36-tablib-0.12.1nb2.tgz(NetBSD 9.0)
earmv6hf:py37-tablib-0.12.1nb2.tgz(NetBSD 9.0)
earmv6hf:py38-tablib-0.12.1nb2.tgz(NetBSD 9.0)
earmv7hf:py27-tablib-0.12.1nb2.tgz(NetBSD 8.0)
earmv7hf:py36-tablib-0.12.1nb2.tgz(NetBSD 8.0)
earmv7hf:py37-tablib-0.12.1nb2.tgz(NetBSD 8.0)
earmv7hf:py38-tablib-0.12.1nb2.tgz(NetBSD 8.0)
earmv7hf:py27-tablib-0.12.1nb2.tgz(NetBSD 8.0)
earmv7hf:py36-tablib-0.12.1nb2.tgz(NetBSD 8.0)
earmv7hf:py37-tablib-0.12.1nb2.tgz(NetBSD 8.0)
earmv7hf:py38-tablib-0.12.1nb2.tgz(NetBSD 8.0)
earmv7hf:py27-tablib-0.12.1nb2.tgz(NetBSD 9.0)
earmv7hf:py36-tablib-0.12.1nb2.tgz(NetBSD 9.0)
earmv7hf:py37-tablib-0.12.1nb2.tgz(NetBSD 9.0)
earmv7hf:py38-tablib-0.12.1nb2.tgz(NetBSD 9.0)
earmv7hf:py27-tablib-0.12.1nb2.tgz(NetBSD 9.0)
earmv7hf:py36-tablib-0.12.1nb2.tgz(NetBSD 9.0)
earmv7hf:py37-tablib-0.12.1nb2.tgz(NetBSD 9.0)
earmv7hf:py38-tablib-0.12.1nb2.tgz(NetBSD 9.0)
i386:py27-tablib-0.12.1nb2.tgz(NetBSD 9.0)
i386:py36-tablib-0.12.1nb2.tgz(NetBSD 9.0)
i386:py37-tablib-0.12.1nb2.tgz(NetBSD 9.0)
i386:py38-tablib-0.12.1nb2.tgz(NetBSD 9.0)
i386:py27-tablib-0.12.1nb2.tgz(NetBSD 7.0)
i386:py36-tablib-0.12.1nb2.tgz(NetBSD 7.0)
i386:py37-tablib-0.12.1nb2.tgz(NetBSD 7.0)
i386:py38-tablib-0.12.1nb2.tgz(NetBSD 7.0)
i386:py27-tablib-0.12.1nb2.tgz(NetBSD 7.0)
i386:py36-tablib-0.12.1nb2.tgz(NetBSD 7.0)
i386:py37-tablib-0.12.1nb2.tgz(NetBSD 7.0)
i386:py27-tablib-0.12.1nb2.tgz(NetBSD 7.1)
i386:py36-tablib-0.12.1nb2.tgz(NetBSD 7.1)
i386:py37-tablib-0.12.1nb2.tgz(NetBSD 7.1)
i386:py27-tablib-0.12.1nb2.tgz(NetBSD 7.1)
i386:py36-tablib-0.12.1nb2.tgz(NetBSD 7.1)
i386:py37-tablib-0.12.1nb2.tgz(NetBSD 7.1)
i386:py38-tablib-0.12.1nb2.tgz(NetBSD 7.1)
i386:py27-tablib-0.12.1nb2.tgz(NetBSD 7.1)
i386:py36-tablib-0.12.1nb2.tgz(NetBSD 7.1)
i386:py37-tablib-0.12.1nb2.tgz(NetBSD 7.1)
i386:py38-tablib-0.12.1nb2.tgz(NetBSD 7.1)
i386:py27-tablib-0.12.1nb2.tgz(NetBSD 8.0)
i386:py36-tablib-0.12.1nb2.tgz(NetBSD 8.0)
i386:py37-tablib-0.12.1nb2.tgz(NetBSD 8.0)
i386:py27-tablib-0.12.1nb2.tgz(NetBSD 8.0)
i386:py36-tablib-0.12.1nb2.tgz(NetBSD 8.0)
i386:py37-tablib-0.12.1nb2.tgz(NetBSD 8.0)
i386:py38-tablib-0.12.1nb2.tgz(NetBSD 8.0)
i386:py27-tablib-0.12.1nb2.tgz(NetBSD 8.0)
i386:py36-tablib-0.12.1nb2.tgz(NetBSD 8.0)
i386:py37-tablib-0.12.1nb2.tgz(NetBSD 8.0)
i386:py38-tablib-0.12.1nb2.tgz(NetBSD 8.0)
i386:py27-tablib-0.12.1nb2.tgz(NetBSD 9.0)
i386:py36-tablib-0.12.1nb2.tgz(NetBSD 9.0)
i386:py37-tablib-0.12.1nb2.tgz(NetBSD 9.0)
i386:py38-tablib-0.12.1nb2.tgz(NetBSD 9.0)
i386:py27-tablib-0.12.1nb2.tgz(NetBSD 9.0)
i386:py36-tablib-0.12.1nb2.tgz(NetBSD 9.0)
i386:py37-tablib-0.12.1nb2.tgz(NetBSD 9.0)
i386:py38-tablib-0.12.1nb2.tgz(NetBSD 9.0)
mips64eb:py27-tablib-0.12.1nb2.tgz(NetBSD 8.0)
mips64eb:py36-tablib-0.12.1nb2.tgz(NetBSD 8.0)
mips64eb:py37-tablib-0.12.1nb2.tgz(NetBSD 8.0)
mips64eb:py27-tablib-0.12.1nb2.tgz(NetBSD 9.0)
mips64eb:py36-tablib-0.12.1nb2.tgz(NetBSD 9.0)
mips64eb:py37-tablib-0.12.1nb2.tgz(NetBSD 9.0)
powerpc:py27-tablib-0.12.1nb2.tgz(NetBSD 7.1)
powerpc:py34-tablib-0.12.1nb2.tgz(NetBSD 7.1)
powerpc:py35-tablib-0.12.1nb2.tgz(NetBSD 7.1)
powerpc:py36-tablib-0.12.1nb2.tgz(NetBSD 7.1)
powerpc:py37-tablib-0.12.1nb2.tgz(NetBSD 7.1)
powerpc:py27-tablib-0.12.1nb2.tgz(NetBSD 8.0)
powerpc:py36-tablib-0.12.1nb2.tgz(NetBSD 8.0)
powerpc:py37-tablib-0.12.1nb2.tgz(NetBSD 8.0)
powerpc:py27-tablib-0.12.1nb2.tgz(NetBSD 9.0)
powerpc:py36-tablib-0.12.1nb2.tgz(NetBSD 9.0)
powerpc:py37-tablib-0.12.1nb2.tgz(NetBSD 9.0)
sparc64:py27-tablib-0.12.1nb2.tgz(NetBSD 8.0)
sparc64:py36-tablib-0.12.1nb2.tgz(NetBSD 8.0)
sparc64:py37-tablib-0.12.1nb2.tgz(NetBSD 8.0)
sparc64:py27-tablib-0.12.1nb2.tgz(NetBSD 9.0)
sparc64:py36-tablib-0.12.1nb2.tgz(NetBSD 9.0)
sparc64:py37-tablib-0.12.1nb2.tgz(NetBSD 9.0)
sparc:py27-tablib-0.12.1nb2.tgz(NetBSD 8.0)
sparc:py36-tablib-0.12.1nb2.tgz(NetBSD 8.0)
sparc:py37-tablib-0.12.1nb2.tgz(NetBSD 8.0)
x86_64:py27-tablib-0.12.1nb2.tgz(NetBSD 9.0)
x86_64:py36-tablib-0.12.1nb2.tgz(NetBSD 9.0)
x86_64:py37-tablib-0.12.1nb2.tgz(NetBSD 9.0)
x86_64:py38-tablib-0.12.1nb2.tgz(NetBSD 9.0)
x86_64:py27-tablib-0.12.1nb2.tgz(NetBSD 9.0)
x86_64:py36-tablib-0.12.1nb2.tgz(NetBSD 9.0)
x86_64:py37-tablib-0.12.1nb2.tgz(NetBSD 9.0)
x86_64:py38-tablib-0.12.1nb2.tgz(NetBSD 9.0)
x86_64:py27-tablib-0.12.1nb2.tgz(NetBSD 7.0)
x86_64:py36-tablib-0.12.1nb2.tgz(NetBSD 7.0)
x86_64:py37-tablib-0.12.1nb2.tgz(NetBSD 7.0)
x86_64:py38-tablib-0.12.1nb2.tgz(NetBSD 7.0)
x86_64:py27-tablib-0.12.1nb2.tgz(NetBSD 7.0)
x86_64:py36-tablib-0.12.1nb2.tgz(NetBSD 7.0)
x86_64:py37-tablib-0.12.1nb2.tgz(NetBSD 7.0)
x86_64:py27-tablib-0.12.1nb2.tgz(NetBSD 7.1)
x86_64:py36-tablib-0.12.1nb2.tgz(NetBSD 7.1)
x86_64:py37-tablib-0.12.1nb2.tgz(NetBSD 7.1)
x86_64:py38-tablib-0.12.1nb2.tgz(NetBSD 7.1)
x86_64:py27-tablib-0.12.1nb2.tgz(NetBSD 7.1)
x86_64:py36-tablib-0.12.1nb2.tgz(NetBSD 7.1)
x86_64:py37-tablib-0.12.1nb2.tgz(NetBSD 7.1)
x86_64:py27-tablib-0.12.1nb2.tgz(NetBSD 7.1)
x86_64:py36-tablib-0.12.1nb2.tgz(NetBSD 7.1)
x86_64:py37-tablib-0.12.1nb2.tgz(NetBSD 7.1)
x86_64:py38-tablib-0.12.1nb2.tgz(NetBSD 7.1)
x86_64:py27-tablib-0.12.1nb2.tgz(NetBSD 8.0)
x86_64:py36-tablib-0.12.1nb2.tgz(NetBSD 8.0)
x86_64:py37-tablib-0.12.1nb2.tgz(NetBSD 8.0)
x86_64:py38-tablib-0.12.1nb2.tgz(NetBSD 8.0)
x86_64:py27-tablib-0.12.1nb2.tgz(NetBSD 8.0)
x86_64:py36-tablib-0.12.1nb2.tgz(NetBSD 8.0)
x86_64:py37-tablib-0.12.1nb2.tgz(NetBSD 8.0)
x86_64:py27-tablib-0.12.1nb2.tgz(NetBSD 8.0)
x86_64:py36-tablib-0.12.1nb2.tgz(NetBSD 8.0)
x86_64:py37-tablib-0.12.1nb2.tgz(NetBSD 8.0)
x86_64:py38-tablib-0.12.1nb2.tgz(NetBSD 8.0)
x86_64:py27-tablib-0.12.1nb2.tgz(NetBSD 9.0)
x86_64:py36-tablib-0.12.1nb2.tgz(NetBSD 9.0)
x86_64:py37-tablib-0.12.1nb2.tgz(NetBSD 9.0)
x86_64:py38-tablib-0.12.1nb2.tgz(NetBSD 9.0)
x86_64:py27-tablib-0.12.1nb2.tgz(NetBSD 9.0)
x86_64:py36-tablib-0.12.1nb2.tgz(NetBSD 9.0)
x86_64:py37-tablib-0.12.1nb2.tgz(NetBSD 9.0)
x86_64:py38-tablib-0.12.1nb2.tgz(NetBSD 9.0)
x86_64:py36-tablib-2.0.0.tgz(NetBSD 9.0)
x86_64:py37-tablib-2.0.0.tgz(NetBSD 9.0)
x86_64:py38-tablib-2.0.0.tgz(NetBSD 9.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]