Daemon Power

The NetBSD Packages Collection: textproc/php-excel

Brief description of the package:
Pure PHP library for reading and writing spreadsheet files

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://github.com/PHPOffice/PHPExcel.

Please note that this package has a gnu-lgpl-v2 license.

The package is located in the "textproc/php-excel" directory. The current source version of the package is "php73-excel-1.8.1". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for textproc/php-excel :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: php73-gd-[0-9]* gd>=2.0.15nb1 perl>=5.0 cwrappers>=20150314 tiff>=3.6.1 jbigkit>=2.0 jpeg>=8nb1 jpeg>=9 fontconfig>=2.11.91 libuuid>=2.18 freetype2>=2.8.1 freetype2>=2.1.3 fontconfig>=2.1nb2 libimagequant>=2.8.2 libwebp>=0.2.0 giflib>=5.2.1 png>=1.2.4 tiff>=4.0.3nb5 png>=1.6.0nb1 fontconfig>=2.13.0 libwebp>=0.6.0 php>=7.3.0<7.3.99 pcre2>=10.21 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 openssl>=1.1.1 readline>=2.2 pcre2>=10.30 libxml2>=2.8.0nb2 openssl>=1.1.1dnb2 readline>=6.0 gd>=2.2.5nb2 php73-zip-[0-9]* libzip>=0.7.1 libzip>=1.6.1nb1 .

This package requires the following package(s) to run: php73-gd-[0-9]* gd>=2.0.15nb1 perl>=5.0 tiff>=3.6.1 jbigkit>=2.0 jpeg>=8nb1 jpeg>=9 fontconfig>=2.11.91 libuuid>=2.18 freetype2>=2.8.1 freetype2>=2.1.3 fontconfig>=2.1nb2 libimagequant>=2.8.2 libwebp>=0.2.0 giflib>=5.2.1 png>=1.2.4 tiff>=4.0.3nb5 png>=1.6.0nb1 fontconfig>=2.13.0 libwebp>=0.6.0 php>=7.3.0<7.3.99 pcre2>=10.21 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 openssl>=1.1.1 readline>=2.2 pcre2>=10.30 libxml2>=2.8.0nb2 openssl>=1.1.1dnb2 readline>=6.0 gd>=2.2.5nb2 php73-zip-[0-9]* libzip>=0.7.1 libzip>=1.6.1nb1 .

This package supports the following build-time options:

gd
Use GD to render graphical output.
zip

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
aarch64:php56-excel-1.8.1.tgz(NetBSD 9.0)
aarch64:php72-excel-1.8.1.tgz(NetBSD 9.0)
aarch64:php73-excel-1.8.1.tgz(NetBSD 9.0)
aarch64:php74-excel-1.8.1.tgz(NetBSD 9.0)
alpha:php56-excel-1.8.1.tgz(NetBSD 8.0)
alpha:php71-excel-1.8.1.tgz(NetBSD 8.0)
alpha:php72-excel-1.8.1.tgz(NetBSD 8.0)
alpha:php73-excel-1.8.1.tgz(NetBSD 8.0)
alpha:php56-excel-1.8.1.tgz(NetBSD 9.0)
alpha:php72-excel-1.8.1.tgz(NetBSD 9.0)
alpha:php73-excel-1.8.1.tgz(NetBSD 9.0)
alpha:php74-excel-1.8.1.tgz(NetBSD 9.0)
earm:php55-excel-1.8.0.tgz(NetBSD 7.0)
earm:php56-excel-1.8.0.tgz(NetBSD 7.0)
earm:php70-excel-1.8.0.tgz(NetBSD 7.0)
earm:php56-excel-1.8.1.tgz(NetBSD 8.0)
earm:php71-excel-1.8.1.tgz(NetBSD 8.0)
earm:php72-excel-1.8.1.tgz(NetBSD 8.0)
earm:php73-excel-1.8.1.tgz(NetBSD 8.0)
earm:php56-excel-1.8.1.tgz(NetBSD 8.0)
earmv6hf:php56-excel-1.8.1.tgz(NetBSD 8.0)
earmv6hf:php72-excel-1.8.1.tgz(NetBSD 8.0)
earmv6hf:php73-excel-1.8.1.tgz(NetBSD 8.0)
earmv6hf:php74-excel-1.8.1.tgz(NetBSD 8.0)
earmv6hf:php56-excel-1.8.1.tgz(NetBSD 8.0)
earmv6hf:php71-excel-1.8.1.tgz(NetBSD 8.0)
earmv6hf:php72-excel-1.8.1.tgz(NetBSD 8.0)
earmv6hf:php73-excel-1.8.1.tgz(NetBSD 8.0)
earmv6hf:php56-excel-1.8.1.tgz(NetBSD 9.0)
earmv6hf:php72-excel-1.8.1.tgz(NetBSD 9.0)
earmv6hf:php73-excel-1.8.1.tgz(NetBSD 9.0)
earmv6hf:php74-excel-1.8.1.tgz(NetBSD 9.0)
earmv7hf:php56-excel-1.8.1.tgz(NetBSD 8.0)
earmv7hf:php72-excel-1.8.1.tgz(NetBSD 8.0)
earmv7hf:php73-excel-1.8.1.tgz(NetBSD 8.0)
earmv7hf:php74-excel-1.8.1.tgz(NetBSD 8.0)
earmv7hf:php56-excel-1.8.1.tgz(NetBSD 8.0)
earmv7hf:php71-excel-1.8.1.tgz(NetBSD 8.0)
earmv7hf:php72-excel-1.8.1.tgz(NetBSD 8.0)
earmv7hf:php73-excel-1.8.1.tgz(NetBSD 8.0)
earmv7hf:php56-excel-1.8.1.tgz(NetBSD 9.0)
earmv7hf:php72-excel-1.8.1.tgz(NetBSD 9.0)
earmv7hf:php73-excel-1.8.1.tgz(NetBSD 9.0)
earmv7hf:php74-excel-1.8.1.tgz(NetBSD 9.0)
i386:php56-excel-1.8.1.tgz(NetBSD 7.0)
i386:php72-excel-1.8.1.tgz(NetBSD 7.0)
i386:php73-excel-1.8.1.tgz(NetBSD 7.0)
i386:php74-excel-1.8.1.tgz(NetBSD 7.0)
i386:php56-excel-1.8.1.tgz(NetBSD 7.0)
i386:php71-excel-1.8.1.tgz(NetBSD 7.0)
i386:php72-excel-1.8.1.tgz(NetBSD 7.0)
i386:php73-excel-1.8.1.tgz(NetBSD 7.0)
i386:php56-excel-1.8.1.tgz(NetBSD 7.0)
i386:php71-excel-1.8.1.tgz(NetBSD 7.0)
i386:php72-excel-1.8.1.tgz(NetBSD 7.0)
i386:php73-excel-1.8.1.tgz(NetBSD 7.0)
i386:php56-excel-1.8.1.tgz(NetBSD 7.0)
i386:php71-excel-1.8.1.tgz(NetBSD 7.0)
i386:php72-excel-1.8.1.tgz(NetBSD 7.0)
i386:php73-excel-1.8.1.tgz(NetBSD 7.0)
i386:php56-excel-1.8.1.tgz(NetBSD 7.1)
i386:php71-excel-1.8.1.tgz(NetBSD 7.1)
i386:php72-excel-1.8.1.tgz(NetBSD 7.1)
i386:php73-excel-1.8.1.tgz(NetBSD 7.1)
i386:php56-excel-1.8.1.tgz(NetBSD 7.1)
i386:php71-excel-1.8.1.tgz(NetBSD 7.1)
i386:php72-excel-1.8.1.tgz(NetBSD 7.1)
i386:php73-excel-1.8.1.tgz(NetBSD 7.1)
i386:php56-excel-1.8.1.tgz(NetBSD 7.1)
i386:php71-excel-1.8.1.tgz(NetBSD 7.1)
i386:php72-excel-1.8.1.tgz(NetBSD 7.1)
i386:php73-excel-1.8.1.tgz(NetBSD 7.1)
i386:php56-excel-1.8.1.tgz(NetBSD 7.1)
i386:php72-excel-1.8.1.tgz(NetBSD 7.1)
i386:php73-excel-1.8.1.tgz(NetBSD 7.1)
i386:php74-excel-1.8.1.tgz(NetBSD 7.1)
i386:php56-excel-1.8.1.tgz(NetBSD 8.0)
i386:php71-excel-1.8.1.tgz(NetBSD 8.0)
i386:php72-excel-1.8.1.tgz(NetBSD 8.0)
i386:php73-excel-1.8.1.tgz(NetBSD 8.0)
i386:php56-excel-1.8.1.tgz(NetBSD 8.0)
i386:php71-excel-1.8.1.tgz(NetBSD 8.0)
i386:php72-excel-1.8.1.tgz(NetBSD 8.0)
i386:php73-excel-1.8.1.tgz(NetBSD 8.0)
i386:php56-excel-1.8.1.tgz(NetBSD 8.0)
i386:php71-excel-1.8.1.tgz(NetBSD 8.0)
i386:php72-excel-1.8.1.tgz(NetBSD 8.0)
i386:php73-excel-1.8.1.tgz(NetBSD 8.0)
i386:php56-excel-1.8.1.tgz(NetBSD 8.0)
i386:php72-excel-1.8.1.tgz(NetBSD 8.0)
i386:php73-excel-1.8.1.tgz(NetBSD 8.0)
i386:php74-excel-1.8.1.tgz(NetBSD 8.0)
i386:php56-excel-1.8.1.tgz(NetBSD 9.0)
i386:php72-excel-1.8.1.tgz(NetBSD 9.0)
i386:php73-excel-1.8.1.tgz(NetBSD 9.0)
i386:php74-excel-1.8.1.tgz(NetBSD 9.0)
powerpc:php56-excel-1.8.0.tgz(NetBSD 7.1)
powerpc:php56-excel-1.8.1.tgz(NetBSD 7.1)
powerpc:php70-excel-1.8.0.tgz(NetBSD 7.1)
powerpc:php70-excel-1.8.1.tgz(NetBSD 7.1)
powerpc:php71-excel-1.8.0.tgz(NetBSD 7.1)
powerpc:php71-excel-1.8.1.tgz(NetBSD 7.1)
powerpc:php72-excel-1.8.1.tgz(NetBSD 7.1)
powerpc:php73-excel-1.8.1.tgz(NetBSD 7.1)
powerpc:php56-excel-1.8.1.tgz(NetBSD 8.0)
powerpc:php72-excel-1.8.1.tgz(NetBSD 8.0)
powerpc:php73-excel-1.8.1.tgz(NetBSD 8.0)
powerpc:php74-excel-1.8.1.tgz(NetBSD 8.0)
powerpc:php56-excel-1.8.1.tgz(NetBSD 9.0)
powerpc:php71-excel-1.8.1.tgz(NetBSD 9.0)
powerpc:php72-excel-1.8.1.tgz(NetBSD 9.0)
powerpc:php73-excel-1.8.1.tgz(NetBSD 9.0)
powerpc:php56-excel-1.8.1.tgz(NetBSD 9.0)
powerpc:php72-excel-1.8.1.tgz(NetBSD 9.0)
powerpc:php73-excel-1.8.1.tgz(NetBSD 9.0)
powerpc:php74-excel-1.8.1.tgz(NetBSD 9.0)
sparc64:php56-excel-1.8.1.tgz(NetBSD 8.0)
sparc64:php71-excel-1.8.1.tgz(NetBSD 8.0)
sparc64:php72-excel-1.8.1.tgz(NetBSD 8.0)
sparc64:php73-excel-1.8.1.tgz(NetBSD 8.0)
x86_64:php56-excel-1.8.1.tgz(NetBSD 9.0)
x86_64:php72-excel-1.8.1.tgz(NetBSD 9.0)
x86_64:php73-excel-1.8.1.tgz(NetBSD 9.0)
x86_64:php74-excel-1.8.1.tgz(NetBSD 9.0)
x86_64:php56-excel-1.8.1.tgz(NetBSD 9.0)
x86_64:php72-excel-1.8.1.tgz(NetBSD 9.0)
x86_64:php73-excel-1.8.1.tgz(NetBSD 9.0)
x86_64:php74-excel-1.8.1.tgz(NetBSD 9.0)
x86_64:php56-excel-1.8.1.tgz(NetBSD 9.0)
x86_64:php72-excel-1.8.1.tgz(NetBSD 9.0)
x86_64:php73-excel-1.8.1.tgz(NetBSD 9.0)
x86_64:php74-excel-1.8.1.tgz(NetBSD 9.0)
x86_64:php56-excel-1.8.1.tgz(NetBSD 7.0)
x86_64:php72-excel-1.8.1.tgz(NetBSD 7.0)
x86_64:php73-excel-1.8.1.tgz(NetBSD 7.0)
x86_64:php74-excel-1.8.1.tgz(NetBSD 7.0)
x86_64:php56-excel-1.8.1.tgz(NetBSD 7.0)
x86_64:php71-excel-1.8.1.tgz(NetBSD 7.0)
x86_64:php72-excel-1.8.1.tgz(NetBSD 7.0)
x86_64:php73-excel-1.8.1.tgz(NetBSD 7.0)
x86_64:php56-excel-1.8.1.tgz(NetBSD 7.0)
x86_64:php71-excel-1.8.1.tgz(NetBSD 7.0)
x86_64:php72-excel-1.8.1.tgz(NetBSD 7.0)
x86_64:php73-excel-1.8.1.tgz(NetBSD 7.0)
x86_64:php56-excel-1.8.1.tgz(NetBSD 7.0)
x86_64:php71-excel-1.8.1.tgz(NetBSD 7.0)
x86_64:php72-excel-1.8.1.tgz(NetBSD 7.0)
x86_64:php73-excel-1.8.1.tgz(NetBSD 7.0)
x86_64:php56-excel-1.8.1.tgz(NetBSD 7.1)
x86_64:php72-excel-1.8.1.tgz(NetBSD 7.1)
x86_64:php73-excel-1.8.1.tgz(NetBSD 7.1)
x86_64:php74-excel-1.8.1.tgz(NetBSD 7.1)
x86_64:php56-excel-1.8.1.tgz(NetBSD 7.1)
x86_64:php71-excel-1.8.1.tgz(NetBSD 7.1)
x86_64:php72-excel-1.8.1.tgz(NetBSD 7.1)
x86_64:php73-excel-1.8.1.tgz(NetBSD 7.1)
x86_64:php56-excel-1.8.1.tgz(NetBSD 7.1)
x86_64:php71-excel-1.8.1.tgz(NetBSD 7.1)
x86_64:php72-excel-1.8.1.tgz(NetBSD 7.1)
x86_64:php73-excel-1.8.1.tgz(NetBSD 7.1)
x86_64:php56-excel-1.8.1.tgz(NetBSD 7.1)
x86_64:php71-excel-1.8.1.tgz(NetBSD 7.1)
x86_64:php72-excel-1.8.1.tgz(NetBSD 7.1)
x86_64:php73-excel-1.8.1.tgz(NetBSD 7.1)
x86_64:php56-excel-1.8.1.tgz(NetBSD 8.0)
x86_64:php72-excel-1.8.1.tgz(NetBSD 8.0)
x86_64:php73-excel-1.8.1.tgz(NetBSD 8.0)
x86_64:php74-excel-1.8.1.tgz(NetBSD 8.0)
x86_64:php56-excel-1.8.1.tgz(NetBSD 8.0)
x86_64:php71-excel-1.8.1.tgz(NetBSD 8.0)
x86_64:php72-excel-1.8.1.tgz(NetBSD 8.0)
x86_64:php73-excel-1.8.1.tgz(NetBSD 8.0)
x86_64:php56-excel-1.8.1.tgz(NetBSD 8.0)
x86_64:php71-excel-1.8.1.tgz(NetBSD 8.0)
x86_64:php72-excel-1.8.1.tgz(NetBSD 8.0)
x86_64:php73-excel-1.8.1.tgz(NetBSD 8.0)
x86_64:php56-excel-1.8.1.tgz(NetBSD 8.0)
x86_64:php71-excel-1.8.1.tgz(NetBSD 8.0)
x86_64:php72-excel-1.8.1.tgz(NetBSD 8.0)
x86_64:php73-excel-1.8.1.tgz(NetBSD 8.0)
x86_64:php56-excel-1.8.1.tgz(NetBSD 9.0)
x86_64:php72-excel-1.8.1.tgz(NetBSD 9.0)
x86_64:php73-excel-1.8.1.tgz(NetBSD 9.0)
x86_64:php74-excel-1.8.1.tgz(NetBSD 9.0)
x86_64:php56-excel-1.8.1.tgz(NetBSD 9.0)
x86_64:php72-excel-1.8.1.tgz(NetBSD 9.0)
x86_64:php73-excel-1.8.1.tgz(NetBSD 9.0)
x86_64:php74-excel-1.8.1.tgz(NetBSD 9.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]