textproc/p5-Text-Template - The NetBSD Packages Collection

Perl5 library for generating form letters

  This is a library for generating form letters, building HTML pages,
or filling in templates generally.  A `template' is a piece of text
that has little Perl programs embedded in it here and there.  When
you `fill in' a template, you evaluate the little programs and
replace them with their values.  Here's an example of a template:

        Dear {$title} {$lastname},

        It has come to our attention that you are delinquent in your
        {$monthname[$last_paid_month]} payment.  Please remit
        ${sprintf("%.2f", $amount)} immediately, or your patellae may
        be needlessly endangered.


The result of filling in this template is a string, which might look
something like this:

        Dear Mr. Gates,

        It has come to our attention that you are delinquent in your
        February payment.  Please remit
        $392.12 immediately, or your patellae may
        be needlessly endangered.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Text-Template-1.59.tgz
NetBSD 8.0earmv7hfp5-Text-Template-1.59.tgz
NetBSD 8.0earmv7hfp5-Text-Template-1.59.tgz
NetBSD 8.0i386p5-Text-Template-1.59.tgz
NetBSD 8.0i386p5-Text-Template-1.59.tgz
NetBSD 8.0i386p5-Text-Template-1.59.tgz
NetBSD 8.0powerpcp5-Text-Template-1.59.tgz
NetBSD 8.0powerpcp5-Text-Template-1.59.tgz
NetBSD 8.0powerpcp5-Text-Template-1.59.tgz
NetBSD 8.0x86_64p5-Text-Template-1.59.tgz
NetBSD 8.0x86_64p5-Text-Template-1.59.tgz
NetBSD 9.0aarch64p5-Text-Template-1.59.tgz
NetBSD 9.0aarch64p5-Text-Template-1.59.tgz
NetBSD 9.0aarch64p5-Text-Template-1.59.tgz
NetBSD 9.0alphap5-Text-Template-1.59.tgz
NetBSD 9.0alphap5-Text-Template-1.59.tgz
NetBSD 9.0alphap5-Text-Template-1.59.tgz
NetBSD 9.0earmp5-Text-Template-1.59.tgz
NetBSD 9.0earmp5-Text-Template-1.59.tgz
NetBSD 9.0earmp5-Text-Template-1.59.tgz
NetBSD 9.0earmv6hfp5-Text-Template-1.59.tgz
NetBSD 9.0earmv6hfp5-Text-Template-1.59.tgz
NetBSD 9.0earmv6hfp5-Text-Template-1.59.tgz
NetBSD 9.0earmv6hfp5-Text-Template-1.59.tgz
NetBSD 9.0earmv7hfp5-Text-Template-1.59.tgz
NetBSD 9.0earmv7hfp5-Text-Template-1.59.tgz
NetBSD 9.0earmv7hfp5-Text-Template-1.59.tgz
NetBSD 9.0earmv7hfp5-Text-Template-1.59.tgz
NetBSD 9.0i386p5-Text-Template-1.59.tgz
NetBSD 9.0i386p5-Text-Template-1.59.tgz
NetBSD 9.0m68kp5-Text-Template-1.59.tgz
NetBSD 9.0m68kp5-Text-Template-1.59.tgz
NetBSD 9.0m68kp5-Text-Template-1.59.tgz
NetBSD 9.0mips64ebp5-Text-Template-1.59.tgz
NetBSD 9.0mips64ebp5-Text-Template-1.59.tgz
NetBSD 9.0mips64ebp5-Text-Template-1.59.tgz
NetBSD 9.0mipselp5-Text-Template-1.59.tgz
NetBSD 9.0mipselp5-Text-Template-1.59.tgz
NetBSD 9.0powerpcp5-Text-Template-1.59.tgz
NetBSD 9.0powerpcp5-Text-Template-1.59.tgz
NetBSD 9.0sh3elp5-Text-Template-1.59.tgz
NetBSD 9.0sh3elp5-Text-Template-1.59.tgz
NetBSD 9.0sh3elp5-Text-Template-1.59.tgz
NetBSD 9.0sparc64p5-Text-Template-1.59.tgz
NetBSD 9.0sparc64p5-Text-Template-1.58.tgz
NetBSD 9.0sparc64p5-Text-Template-1.59.tgz
NetBSD 9.0sparc64p5-Text-Template-1.59.tgz
NetBSD 9.0sparcp5-Text-Template-1.59.tgz
NetBSD 9.0sparcp5-Text-Template-1.59.tgz
NetBSD 9.0sparcp5-Text-Template-1.59.tgz
NetBSD 9.0vaxp5-Text-Template-1.59.tgz
NetBSD 9.0vaxp5-Text-Template-1.59.tgz
NetBSD 9.0x86_64p5-Text-Template-1.59.tgz
NetBSD 9.0x86_64p5-Text-Template-1.59.tgz
NetBSD 9.0x86_64p5-Text-Template-1.59.tgz
NetBSD 9.0x86_64p5-Text-Template-1.59.tgz
NetBSD 9.0x86_64p5-Text-Template-1.59.tgz
NetBSD 9.0x86_64p5-Text-Template-1.59.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.