textproc/lua-ftcsv - The NetBSD Packages Collection

Fast csv library written in pure Lua

ftcsv is a fast csv library written in pure Lua.

It features two parsing modes, one for CSVs that can easily be loaded into
memory (up to a few hundred MBs depending on the system), and another for
loading files using an iterator - useful for manipulating large files or
processing during load.

It correctly handles most csv (and csv-like) files found in the wild, from
varying line endings (Windows, Linux, and OS9), UTF-8 BOM support, and odd
delimiters.

There are also various options that can tweak how a file is loaded, only
grabbing a few fields, renaming fields, and parsing header-less files!

Build dependencies

pkgtools/mktools pkgtools/cwrappers

Runtime dependencies

lang/lua54

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64lua51-ftcsv-1.2.1.tgz
NetBSD 10.0aarch64lua52-ftcsv-1.2.1.tgz
NetBSD 10.0aarch64lua53-ftcsv-1.2.1.tgz
NetBSD 10.0aarch64lua54-ftcsv-1.2.1.tgz
NetBSD 10.0earmv6hflua51-ftcsv-1.2.1.tgz
NetBSD 10.0earmv6hflua52-ftcsv-1.2.1.tgz
NetBSD 10.0earmv6hflua53-ftcsv-1.2.1.tgz
NetBSD 10.0earmv6hflua54-ftcsv-1.2.1.tgz
NetBSD 10.0earmv7hflua51-ftcsv-1.2.1.tgz
NetBSD 10.0earmv7hflua52-ftcsv-1.2.1.tgz
NetBSD 10.0earmv7hflua53-ftcsv-1.2.1.tgz
NetBSD 10.0earmv7hflua54-ftcsv-1.2.1.tgz
NetBSD 8.0i386lua51-ftcsv-1.2.1.tgz
NetBSD 8.0i386lua52-ftcsv-1.2.1.tgz
NetBSD 8.0i386lua53-ftcsv-1.2.1.tgz
NetBSD 8.0i386lua54-ftcsv-1.2.1.tgz
NetBSD 8.0i386lua51-ftcsv-1.2.1.tgz
NetBSD 8.0i386lua52-ftcsv-1.2.1.tgz
NetBSD 8.0i386lua53-ftcsv-1.2.1.tgz
NetBSD 8.0i386lua54-ftcsv-1.2.1.tgz
NetBSD 8.0powerpclua51-ftcsv-1.2.1.tgz
NetBSD 8.0powerpclua52-ftcsv-1.2.1.tgz
NetBSD 8.0powerpclua53-ftcsv-1.2.1.tgz
NetBSD 8.0powerpclua54-ftcsv-1.2.1.tgz
NetBSD 8.0powerpclua51-ftcsv-1.2.1.tgz
NetBSD 8.0powerpclua52-ftcsv-1.2.1.tgz
NetBSD 8.0powerpclua53-ftcsv-1.2.1.tgz
NetBSD 8.0powerpclua54-ftcsv-1.2.1.tgz
NetBSD 8.0x86_64lua51-ftcsv-1.2.1.tgz
NetBSD 8.0x86_64lua52-ftcsv-1.2.1.tgz
NetBSD 8.0x86_64lua53-ftcsv-1.2.1.tgz
NetBSD 8.0x86_64lua54-ftcsv-1.2.1.tgz
NetBSD 8.0x86_64lua51-ftcsv-1.2.1.tgz
NetBSD 8.0x86_64lua52-ftcsv-1.2.1.tgz
NetBSD 8.0x86_64lua53-ftcsv-1.2.1.tgz
NetBSD 8.0x86_64lua54-ftcsv-1.2.1.tgz
NetBSD 9.0aarch64lua51-ftcsv-1.2.1.tgz
NetBSD 9.0aarch64lua52-ftcsv-1.2.1.tgz
NetBSD 9.0aarch64lua53-ftcsv-1.2.1.tgz
NetBSD 9.0aarch64lua54-ftcsv-1.2.1.tgz
NetBSD 9.0aarch64lua51-ftcsv-1.2.1.tgz
NetBSD 9.0aarch64lua52-ftcsv-1.2.1.tgz
NetBSD 9.0aarch64lua53-ftcsv-1.2.1.tgz
NetBSD 9.0aarch64lua54-ftcsv-1.2.1.tgz
NetBSD 9.0alphalua51-ftcsv-1.2.1.tgz
NetBSD 9.0alphalua52-ftcsv-1.2.1.tgz
NetBSD 9.0alphalua53-ftcsv-1.2.1.tgz
NetBSD 9.0alphalua54-ftcsv-1.2.1.tgz
NetBSD 9.0alphalua51-ftcsv-1.2.1.tgz
NetBSD 9.0alphalua52-ftcsv-1.2.1.tgz
NetBSD 9.0alphalua53-ftcsv-1.2.1.tgz
NetBSD 9.0alphalua54-ftcsv-1.2.1.tgz
NetBSD 9.0earmlua51-ftcsv-1.2.1.tgz
NetBSD 9.0earmlua52-ftcsv-1.2.1.tgz
NetBSD 9.0earmlua53-ftcsv-1.2.1.tgz
NetBSD 9.0earmlua54-ftcsv-1.2.1.tgz
NetBSD 9.0earmv6hflua51-ftcsv-1.2.1.tgz
NetBSD 9.0earmv6hflua52-ftcsv-1.2.1.tgz
NetBSD 9.0earmv6hflua53-ftcsv-1.2.1.tgz
NetBSD 9.0earmv6hflua54-ftcsv-1.2.1.tgz
NetBSD 9.0earmv6hflua51-ftcsv-1.2.1.tgz
NetBSD 9.0earmv6hflua52-ftcsv-1.2.1.tgz
NetBSD 9.0earmv6hflua53-ftcsv-1.2.1.tgz
NetBSD 9.0earmv6hflua54-ftcsv-1.2.1.tgz
NetBSD 9.0earmv7hflua51-ftcsv-1.2.1.tgz
NetBSD 9.0earmv7hflua52-ftcsv-1.2.1.tgz
NetBSD 9.0earmv7hflua53-ftcsv-1.2.1.tgz
NetBSD 9.0earmv7hflua54-ftcsv-1.2.1.tgz
NetBSD 9.0earmv7hflua51-ftcsv-1.2.1.tgz
NetBSD 9.0earmv7hflua52-ftcsv-1.2.1.tgz
NetBSD 9.0earmv7hflua53-ftcsv-1.2.1.tgz
NetBSD 9.0earmv7hflua54-ftcsv-1.2.1.tgz
NetBSD 9.0i386lua51-ftcsv-1.2.1.tgz
NetBSD 9.0i386lua52-ftcsv-1.2.1.tgz
NetBSD 9.0i386lua53-ftcsv-1.2.1.tgz
NetBSD 9.0i386lua54-ftcsv-1.2.1.tgz
NetBSD 9.0i386lua51-ftcsv-1.2.1.tgz
NetBSD 9.0i386lua52-ftcsv-1.2.1.tgz
NetBSD 9.0i386lua53-ftcsv-1.2.1.tgz
NetBSD 9.0i386lua54-ftcsv-1.2.1.tgz
NetBSD 9.0mips64eblua51-ftcsv-1.2.1.tgz
NetBSD 9.0mips64eblua52-ftcsv-1.2.1.tgz
NetBSD 9.0mips64eblua53-ftcsv-1.2.1.tgz
NetBSD 9.0mips64eblua54-ftcsv-1.2.1.tgz
NetBSD 9.0mips64eblua51-ftcsv-1.2.1.tgz
NetBSD 9.0mips64eblua52-ftcsv-1.2.1.tgz
NetBSD 9.0mips64eblua53-ftcsv-1.2.1.tgz
NetBSD 9.0mips64eblua54-ftcsv-1.2.1.tgz
NetBSD 9.0powerpclua51-ftcsv-1.2.1.tgz
NetBSD 9.0powerpclua52-ftcsv-1.2.1.tgz
NetBSD 9.0powerpclua53-ftcsv-1.2.1.tgz
NetBSD 9.0powerpclua54-ftcsv-1.2.1.tgz
NetBSD 9.0powerpclua51-ftcsv-1.2.1.tgz
NetBSD 9.0powerpclua52-ftcsv-1.2.1.tgz
NetBSD 9.0powerpclua53-ftcsv-1.2.1.tgz
NetBSD 9.0powerpclua54-ftcsv-1.2.1.tgz
NetBSD 9.0sparc64lua51-ftcsv-1.2.1.tgz
NetBSD 9.0sparc64lua52-ftcsv-1.2.1.tgz
NetBSD 9.0sparc64lua53-ftcsv-1.2.1.tgz
NetBSD 9.0sparc64lua54-ftcsv-1.2.1.tgz
NetBSD 9.0sparc64lua51-ftcsv-1.2.1.tgz
NetBSD 9.0sparc64lua52-ftcsv-1.2.1.tgz
NetBSD 9.0sparc64lua53-ftcsv-1.2.1.tgz
NetBSD 9.0sparc64lua54-ftcsv-1.2.1.tgz
NetBSD 9.0sparclua51-ftcsv-1.2.1.tgz
NetBSD 9.0sparclua52-ftcsv-1.2.1.tgz
NetBSD 9.0sparclua53-ftcsv-1.2.1.tgz
NetBSD 9.0sparclua54-ftcsv-1.2.1.tgz
NetBSD 9.0sparclua51-ftcsv-1.2.1.tgz
NetBSD 9.0sparclua52-ftcsv-1.2.1.tgz
NetBSD 9.0sparclua53-ftcsv-1.2.1.tgz
NetBSD 9.0sparclua54-ftcsv-1.2.1.tgz
NetBSD 9.0x86_64lua51-ftcsv-1.2.1.tgz
NetBSD 9.0x86_64lua52-ftcsv-1.2.1.tgz
NetBSD 9.0x86_64lua53-ftcsv-1.2.1.tgz
NetBSD 9.0x86_64lua54-ftcsv-1.2.1.tgz
NetBSD 9.0x86_64lua51-ftcsv-1.2.1.tgz
NetBSD 9.0x86_64lua52-ftcsv-1.2.1.tgz
NetBSD 9.0x86_64lua53-ftcsv-1.2.1.tgz
NetBSD 9.0x86_64lua54-ftcsv-1.2.1.tgz
NetBSD 9.3x86_64lua51-ftcsv-1.2.1.tgz
NetBSD 9.3x86_64lua52-ftcsv-1.2.1.tgz
NetBSD 9.3x86_64lua53-ftcsv-1.2.1.tgz
NetBSD 9.3x86_64lua54-ftcsv-1.2.1.tgz
NetBSD 9.3x86_64lua51-ftcsv-1.2.1.tgz
NetBSD 9.3x86_64lua52-ftcsv-1.2.1.tgz
NetBSD 9.3x86_64lua53-ftcsv-1.2.1.tgz
NetBSD 9.3x86_64lua54-ftcsv-1.2.1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.