sysutils/erdtree - The NetBSD Packages Collection

Multi-threaded file-tree visualizer and disk usage analyzer

A modern, vibrant, and multi-threaded file-tree visualizer and disk usage
analyzer that respects hidden files and .gitignore rules by default, i.e.
the secret love child of tree and du.

erdtree is a modern alternative to tree and du in that it:
  - offers a minimal and user-friendly CLI
  - respects hidden files and .gitignore rules by default
  - displays file sizes in human-readable format by default
  - leverages parallism to traverse the file-system
  - displays files using ANSI colors by default
  - supports icons! (checkout the Icons section before using)

If the chosen defaults don't meet your requirements and you don't want to bloat
your shell configs with aliases, you can use a configuration file instead.

Build dependencies

lang/rust pkgtools/mktools pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64erdtree-3.1.2.tgz
NetBSD 10.0aarch64erdtree-3.0.1.tgz
NetBSD 10.0aarch64erdtree-3.1.2.tgz
NetBSD 10.0earmv7hferdtree-3.1.2.tgz
NetBSD 10.0earmv7hferdtree-3.0.1.tgz
NetBSD 10.0earmv7hferdtree-3.1.2.tgz
NetBSD 10.0i386erdtree-3.1.2.tgz
NetBSD 10.0i386erdtree-3.1.2.tgz
NetBSD 10.0powerpcerdtree-3.1.2.tgz
NetBSD 10.0x86_64erdtree-3.1.2.tgz
NetBSD 10.0_BETAx86_64erdtree-3.1.2.tgz
NetBSD 9.0aarch64erdtree-3.1.2.tgz
NetBSD 9.0aarch64erdtree-3.0.1.tgz
NetBSD 9.0aarch64erdtree-3.1.2.tgz
NetBSD 9.0earmv7hferdtree-3.1.2.tgz
NetBSD 9.0earmv7hferdtree-3.0.1.tgz
NetBSD 9.0earmv7hferdtree-3.1.2.tgz
NetBSD 9.0i386erdtree-3.1.2.tgz
NetBSD 9.0powerpcerdtree-3.1.2.tgz
NetBSD 9.0powerpcerdtree-1.5.2.tgz
NetBSD 9.0powerpcerdtree-3.0.1.tgz
NetBSD 9.0powerpcerdtree-3.1.2.tgz
NetBSD 9.0sparc64erdtree-1.5.2.tgz
NetBSD 9.0x86_64erdtree-3.1.2.tgz
NetBSD 9.3x86_64erdtree-3.1.2.tgz
NetBSD 9.3x86_64erdtree-3.1.2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.