Daemon Power

The NetBSD Packages Collection: sysutils/baloo

Brief description of the package:
KDE framework for searching and managing user metadata

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://www.kde.org/.

Please note that this package has a gnu-gpl-v3 license.

The package is located in the "sysutils/baloo" directory. The current source version of the package is "baloo-4.14.3nb10". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for sysutils/baloo :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: libbaloo4-[0-9]* gnupg2-[0-9]* pinentry-[0-9]* libassuan>=2.1.0 libgpg-error>=0.6 cwrappers>=20150314 libgpg-error>=1.17 libgpg-error>=1.10nb1 libassuan>=2.4.2 libgpg-error>=1.16 libksba>=0.9.7 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=1.2 libgcrypt>=1.6.0 libksba>=1.3.0nb1 libusb1>=1.0.9 libgcrypt>=1.7 libgpg-error>=1.24 libassuan>=2.4.3 libksba>=1.3.4 npth>=1.2 npth>=1.1 qt4-libs>=4.4.0 glu>=3.4.2 MesaLib>=3.4.2 libXdamage>=1.0.3 Xfixes>=2.0.0 x11-links>=1.06 osabi-NetBSD-7.0.1 fixesproto>=3.0.0<5 xextproto>=7.0 inputproto>=1.4 xproto>=7.0.9 Xfixes>=2.0.1nb2 damageproto>=1.1.0 libdrm>=2.4.60 libdrm>=2.4.15 libva>=1.0.6 libvdpau>=0.3 dri2proto>=2.0 libelf>=0.8.5 libLLVM>=4.0 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 readline>=2.2 readline>=6.0 python27>=2.7.1nb2 libLLVM>=4.0.0 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 xcb-proto>=1.12 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 xcb-proto>=1.4 py27-mako-[0-9]* py27-setuptools>=0.8 py27-expat-[0-9]* dri2proto>=2.1 glproto>=1.4.11 glproto>=1.4.6 xf86driproto>=2.0.3 xf86vidmodeproto>=2.3 MesaLib>=7.11.2 glu>=6.0 xcursor>=1.0 Xrender>=0.8 renderproto>=0.9.3nb1 renderproto>=0.9 Xrender>=0.2 Xrender>=0.8.2 Xrender>=0.9.0nb1 xcursor>=1.1.1 Xft2>=2.1 fontconfig>=2.2 freetype2>=2.4.5 freetype2>=2.1.3 freetype2>=2.4.11 gperf-[0-9]* fontconfig>=2.10.93 fontconfig>=2.1nb2 Xrender>=0.9.0nb2 fontconfig>=2.10.93nb2 Xft2>=2.1nb2 Xrandr>=0.99 randrproto>=1.2.0 randrproto>=1.0 Xrandr>=1.0.1 jpeg>=8nb1 png>=1.2.4 glu>=7.11.2 xcursor>=1.1.2nb1 Xft2>=2.1.7nb6 Xrandr>=1.0.2nb3 jpeg>=9 png>=1.6.0nb1 qt4-libs>=4.6.1nb2 qt4-qdbus>=4.3.2 dbus>=0.91 xmlto-[0-9]* getopt-[0-9]* docbook-xsl>=1.67.0nb1 docbook-xml>=4.2 perl>=5.0 bash-[0-9]* libxslt>=1.1.8 libxml2>=2.6.27 docbook-xml-[0-9]* docbook-xsl-[0-9]* libxslt>=1.1.28nb2 qt4-libs>=4.8.7 qt4-libs>=4.8.7nb1 qjson>=0.7.1 qt4-tools>=4.1.0 libtool-base-[0-9]* qt4-tools>=4.8.7nb1 akonadi>=0.82.0 shared-mime-info>=0.15 glib2>=2.4.0 pcre>=8.31 pcre>=3.4nb1 pcre>=8.30nb1 glib2>=2.34.0 boost-libs-1.65.* icu>=3.4 icu>=60.0 boost-headers-1.65.* boost-jam-1.65.* shared-mime-info>=1.0nb1 boost-libs>=1.65.0 qt4-qdbus>=4.8.7nb1 automoc4>=0.9.87 libxslt-[0-9]* kdepimlibs4>=4.0.0 akonadi>=1.8.51 cyrus-sasl>=2.1.12 gpgme>=0.9.0 libassuan>=2.0.2 libical>=0.42 zonetab-[0-9]* kdelibs4>=4.0.0 docbook-xsl>=1.75 qt4-tools>=4.4.0 strigi>=0.5.11 cppunit>=1.10.2 exiv2>=0.18 libclucene>=2.3.3.4 libclucene>=2.2.0 fam>=2.6.10 cppunit>=1.10.2nb5 exiv2>=0.24 libclucene>=2.3.3.4nb9 fam>=2.7.0nb7 strigi>=0.6.2 grantlee>=0.3.0 libdbusmenu-qt>=0.8.2 hicolor-icon-theme>=0.4 jasper>=1.600.0 giflib>=5.1.0 openexr>=1.6.1 ilmbase>=1.0.2nb1 ilmbase>=1.0.1 ilmbase>=2.2.0nb1 attica>=0.1.2 phonon>=4.5.0 polkit-qt>=0.9.2 policykit>=0.9 dbus-glib>=0.61 glib2>=2.32 dbus>=1.8 dbus-glib>=0.100nb1 policykit>=0.9nb12 qca2>=2.0.0 aspell>=0.50.3 ncurses>=5.3nb1 ncurses>=6.0 enchant>=1.1.3 hunspell-en_US-[0-9]* hunspell>=1.2.2 hunspell>=1.3.2 libXScrnSaver>=1.1.2 scrnsaverproto>=1.2.0 scrnsaverproto>=1.1.0 libXpm>=3.5.4.2 libXtst>=1.0.1 recordproto>=1.13.99.1 recordproto>=1.13.1 xextproto>=7.0.99.3 desktop-file-utils>=0.8 strigi>=0.7.8nb19 grantlee>=0.5.1nb2 libdbusmenu-qt>=0.9.3.15.10.20150604nb1 hicolor-icon-theme>=0.9nb1 jasper>=1.900.1nb7 openexr>=2.2.0nb3 attica>=0.4.2nb3 phonon>=4.8.3nb3 polkit-qt>=0.9.4nb19 qca2>=2.0.3nb20 aspell>=0.60.6nb3 enchant>=1.6.0nb5 desktop-file-utils>=0.10nb1 akonadi>=1.13.0nb6 cyrus-sasl>=2.1.26 gpgme>=1.8.0nb1 kdelibs4>=4.14.27nb2 kfilemetadata>=4.14.3 taglib>=1.0 kdegraphics-mobipocket>=4.14.3 ffmpeg2>=2.0 libass>=0.9.12 fribidi>=0.19.0 fribidi>=0.19.1 harfbuzz>=0.9.4 enca>=1.9 harfbuzz>=1.4.2nb1 libtheora>=1.0alpha3 libvorbis>=1.0.1 libogg>=1.1 libogg>=1.1.2nb1 libvorbis>=1.1.0nb1 lame>=3.93.1nb2 xvidcore>=1.0.0 x264-devel>=20111207 nasm>=2.13.0 x264-devel>=20140303 libvpx>=1.6.0 yasm-[0-9]* libass>=0.13.4nb2 libtheora>=1.0alpha3nb1 lame>=3.98.2nb1 lame>=3.96.1nb4 xvidcore>=1.1.0nb1 libvpx>=1.6.1 yasm>=0.7.2 poppler-qt4>=0.6.1 openjpeg>=2.1.0 lcms2>=2.2 tiff>=3.6.1 jbigkit>=2.0 tiff>=4.0.3nb5 poppler>=0.61.1 poppler>=0.5.1 qt4-libs>=4.7.0 poppler>=0.61.1nb1 ebook-tools>=0.1.1 libzip>=0.7.1 libzip>=1.3.0 cmake>=2.8.5nb1 libarchive>=3.0.0 libarchive>=3.1 libuv>=1.6 curl>=7.12.3 libidn2>=2.0.0 libunistring>=0.9.3 libunistring>=0.9.4 libarchive>=3.3.1 curl>=7.55.1nb1 rhash>=1.3.1 taglib>=1.9.1 kdegraphics-mobipocket>=16.08.0nb2 ffmpeg2>=2.8.10nb1 poppler-qt4>=0.61.1nb1 ebook-tools>=0.2.2nb2 xapian>=1.0.7 libuuid>=2.18 kdepimlibs4>=4.14.10nb7 xapian>=1.4.1 .

This package requires the following package(s) to run: libbaloo4-[0-9]* gnupg2-[0-9]* pinentry-[0-9]* libassuan>=2.1.0 libgpg-error>=0.6 libgpg-error>=1.17 libgpg-error>=1.10nb1 libassuan>=2.4.2 libgpg-error>=1.16 libksba>=0.9.7 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=1.2 libgcrypt>=1.6.0 libksba>=1.3.0nb1 libusb1>=1.0.9 libgcrypt>=1.7 libgpg-error>=1.24 libassuan>=2.4.3 libksba>=1.3.4 npth>=1.2 npth>=1.1 qt4-libs>=4.4.0 glu>=3.4.2 MesaLib>=3.4.2 libXdamage>=1.0.3 Xfixes>=2.0.0 Xfixes>=2.0.1nb2 libdrm>=2.4.60 libdrm>=2.4.15 libva>=1.0.6 libvdpau>=0.3 libelf>=0.8.5 libLLVM>=4.0 libLLVM>=4.0.0 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 MesaLib>=7.11.2 glu>=6.0 xcursor>=1.0 Xrender>=0.8 Xrender>=0.2 Xrender>=0.8.2 Xrender>=0.9.0nb1 xcursor>=1.1.1 Xft2>=2.1 fontconfig>=2.2 freetype2>=2.4.5 freetype2>=2.1.3 freetype2>=2.4.11 fontconfig>=2.10.93 fontconfig>=2.1nb2 Xrender>=0.9.0nb2 fontconfig>=2.10.93nb2 Xft2>=2.1nb2 Xrandr>=0.99 Xrandr>=1.0.1 jpeg>=8nb1 png>=1.2.4 glu>=7.11.2 xcursor>=1.1.2nb1 Xft2>=2.1.7nb6 Xrandr>=1.0.2nb3 jpeg>=9 png>=1.6.0nb1 qt4-libs>=4.6.1nb2 qt4-qdbus>=4.3.2 dbus>=0.91 qt4-libs>=4.8.7 qt4-libs>=4.8.7nb1 qjson>=0.7.1 akonadi>=0.82.0 shared-mime-info>=0.15 glib2>=2.4.0 perl>=5.0 pcre>=8.31 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.0.11 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 glib2>=2.34.0 libxml2>=2.8.0nb2 boost-libs-1.65.* icu>=3.4 icu>=60.0 shared-mime-info>=1.0nb1 boost-libs>=1.65.0 qt4-qdbus>=4.8.7nb1 kdepimlibs4>=4.0.0 akonadi>=1.8.51 cyrus-sasl>=2.1.12 gpgme>=0.9.0 libassuan>=2.0.2 libical>=0.42 zonetab-[0-9]* kdelibs4>=4.0.0 docbook-xml>=4.2 docbook-xsl>=1.75 qt4-tools>=4.4.0 libtool-base-[0-9]* qt4-tools>=4.1.0 strigi>=0.5.11 cppunit>=1.10.2 exiv2>=0.18 libclucene>=2.3.3.4 libclucene>=2.2.0 fam>=2.6.10 cppunit>=1.10.2nb5 exiv2>=0.24 libclucene>=2.3.3.4nb9 fam>=2.7.0nb7 strigi>=0.6.2 grantlee>=0.3.0 libdbusmenu-qt>=0.8.2 hicolor-icon-theme>=0.4 jasper>=1.600.0 giflib>=5.1.0 openexr>=1.6.1 ilmbase>=1.0.2nb1 ilmbase>=1.0.1 ilmbase>=2.2.0nb1 attica>=0.1.2 phonon>=4.5.0 qt4-tools>=4.8.7nb1 polkit-qt>=0.9.2 policykit>=0.9 dbus-glib>=0.61 glib2>=2.32 dbus>=1.8 dbus-glib>=0.100nb1 policykit>=0.9nb12 qca2>=2.0.0 aspell>=0.50.3 ncurses>=5.3nb1 ncurses>=6.0 enchant>=1.1.3 hunspell-en_US-[0-9]* hunspell>=1.2.2 hunspell>=1.3.2 libxslt>=1.1.8 libxml2>=2.6.27 libXScrnSaver>=1.1.2 libXpm>=3.5.4.2 libXtst>=1.0.1 desktop-file-utils>=0.8 strigi>=0.7.8nb19 grantlee>=0.5.1nb2 libdbusmenu-qt>=0.9.3.15.10.20150604nb1 hicolor-icon-theme>=0.9nb1 jasper>=1.900.1nb7 openexr>=2.2.0nb3 attica>=0.4.2nb3 phonon>=4.8.3nb3 polkit-qt>=0.9.4nb19 qca2>=2.0.3nb20 aspell>=0.60.6nb3 enchant>=1.6.0nb5 libxslt>=1.1.28nb2 desktop-file-utils>=0.10nb1 akonadi>=1.13.0nb6 cyrus-sasl>=2.1.26 gpgme>=1.8.0nb1 kdelibs4>=4.14.27nb2 kfilemetadata>=4.14.3 taglib>=1.0 kdegraphics-mobipocket>=4.14.3 ffmpeg2>=2.0 libass>=0.9.12 fribidi>=0.19.0 fribidi>=0.19.1 harfbuzz>=0.9.4 enca>=1.9 harfbuzz>=1.4.2nb1 libtheora>=1.0alpha3 libvorbis>=1.0.1 libogg>=1.1 libogg>=1.1.2nb1 libvorbis>=1.1.0nb1 lame>=3.93.1nb2 xvidcore>=1.0.0 x264-devel>=20111207 x264-devel>=20140303 libvpx>=1.6.0 libass>=0.13.4nb2 libtheora>=1.0alpha3nb1 lame>=3.98.2nb1 lame>=3.96.1nb4 xvidcore>=1.1.0nb1 libvpx>=1.6.1 poppler-qt4>=0.6.1 openjpeg>=2.1.0 lcms2>=2.2 tiff>=3.6.1 jbigkit>=2.0 tiff>=4.0.3nb5 poppler>=0.61.1 poppler>=0.5.1 qt4-libs>=4.7.0 poppler>=0.61.1nb1 ebook-tools>=0.1.1 libzip>=0.7.1 libzip>=1.3.0 taglib>=1.9.1 kdegraphics-mobipocket>=16.08.0nb2 ffmpeg2>=2.8.10nb1 poppler-qt4>=0.61.1nb1 ebook-tools>=0.2.2nb2 xapian>=1.0.7 libuuid>=2.18 kdepimlibs4>=4.14.10nb7 xapian>=1.4.1 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
earmv6hf:baloo-4.14.3nb2.tgz(NetBSD 7.0)
earmv7hf:baloo-4.14.3nb2.tgz(NetBSD 7.0)
earmv7hf:baloo-4.14.3nb2.tgz(NetBSD 7.99.21)
earmv7hfeb:baloo-4.14.3nb2.tgz(NetBSD 7.0)
i386:baloo-4.14.3nb4.tgz(NetBSD 7.0)
i386:baloo-4.14.3nb6.tgz(NetBSD 7.0)
i386:baloo-4.14.3nb7.tgz(NetBSD 7.0)
i386:baloo-4.14.3nb9.tgz(NetBSD 7.0)
powerpc:baloo-4.14.3nb9.tgz(NetBSD 8.0)
powerpc:baloo-4.14.3nb10.tgz(NetBSD 8.0)
sparc64:baloo-4.14.3nb2.tgz(NetBSD 7.0)
x86_64:baloo-4.14.3nb10.tgz(NetBSD 7.0)
x86_64:baloo-4.14.3nb4.tgz(NetBSD 7.0)
x86_64:baloo-4.14.3nb6.tgz(NetBSD 7.0)
x86_64:baloo-4.14.3nb7.tgz(NetBSD 7.0)
x86_64:baloo-4.14.3nb9.tgz(NetBSD 7.0)
x86_64:baloo-4.14.3nb9.tgz(NetBSD 7.0.1_PATCH)
x86_64:baloo-4.14.3nb9.tgz(NetBSD 8.99.1)
x86_64:baloo-4.14.3nb10.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]