security/ruby-gssapi - The NetBSD Packages Collection

FFI wrapper around the system GSSAPI library

Ruby GSSAPI Library

This is a wrapper around the system GSSAPI library (MIT only at this time).
It exposes the low-level GSSAPI methods like gss_init_sec_context and
gss_wrap and also provides an easier to use wrapper on top of this for
common usage scenarios.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

lang/ruby27-base

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfruby25-gssapi-1.3.0.tgz
NetBSD 8.0earmv7hfruby26-gssapi-1.3.0.tgz
NetBSD 8.0earmv7hfruby27-gssapi-1.3.0.tgz
NetBSD 8.0earmv7hfruby25-gssapi-1.3.0.tgz
NetBSD 8.0earmv7hfruby26-gssapi-1.3.0.tgz
NetBSD 8.0earmv7hfruby27-gssapi-1.3.0.tgz
NetBSD 8.0earmv7hfruby25-gssapi-1.3.1.tgz
NetBSD 8.0earmv7hfruby26-gssapi-1.3.1.tgz
NetBSD 8.0earmv7hfruby27-gssapi-1.3.1.tgz
NetBSD 8.0earmv7hfruby26-gssapi-1.3.1.tgz
NetBSD 8.0earmv7hfruby27-gssapi-1.3.1.tgz
NetBSD 8.0i386ruby25-gssapi-1.3.0.tgz
NetBSD 8.0i386ruby26-gssapi-1.3.0.tgz
NetBSD 8.0i386ruby27-gssapi-1.3.0.tgz
NetBSD 8.0i386ruby25-gssapi-1.3.0.tgz
NetBSD 8.0i386ruby26-gssapi-1.3.0.tgz
NetBSD 8.0i386ruby27-gssapi-1.3.0.tgz
NetBSD 8.0i386ruby25-gssapi-1.3.1.tgz
NetBSD 8.0i386ruby26-gssapi-1.3.1.tgz
NetBSD 8.0i386ruby27-gssapi-1.3.1.tgz
NetBSD 8.0i386ruby26-gssapi-1.3.1.tgz
NetBSD 8.0i386ruby27-gssapi-1.3.1.tgz
NetBSD 8.0powerpcruby24-gssapi-1.3.0.tgz
NetBSD 8.0powerpcruby25-gssapi-1.3.0.tgz
NetBSD 8.0powerpcruby26-gssapi-1.3.0.tgz
NetBSD 8.0powerpcruby27-gssapi-1.3.0.tgz
NetBSD 8.0powerpcruby24-gssapi-1.3.0.tgz
NetBSD 8.0powerpcruby25-gssapi-1.3.0.tgz
NetBSD 8.0powerpcruby26-gssapi-1.3.0.tgz
NetBSD 8.0powerpcruby27-gssapi-1.3.0.tgz
NetBSD 8.0powerpcruby25-gssapi-1.3.1.tgz
NetBSD 8.0powerpcruby26-gssapi-1.3.1.tgz
NetBSD 8.0powerpcruby27-gssapi-1.3.1.tgz
NetBSD 8.0powerpcruby25-gssapi-1.3.1.tgz
NetBSD 8.0powerpcruby26-gssapi-1.3.1.tgz
NetBSD 8.0powerpcruby27-gssapi-1.3.1.tgz
NetBSD 8.0powerpcruby25-gssapi-1.3.1.tgz
NetBSD 8.0powerpcruby26-gssapi-1.3.1.tgz
NetBSD 8.0powerpcruby27-gssapi-1.3.1.tgz
NetBSD 8.0x86_64ruby25-gssapi-1.3.1.tgz
NetBSD 8.0x86_64ruby26-gssapi-1.3.1.tgz
NetBSD 8.0x86_64ruby27-gssapi-1.3.1.tgz
NetBSD 8.0x86_64ruby25-gssapi-1.3.0.tgz
NetBSD 8.0x86_64ruby26-gssapi-1.3.0.tgz
NetBSD 8.0x86_64ruby27-gssapi-1.3.0.tgz
NetBSD 8.0x86_64ruby25-gssapi-1.3.0.tgz
NetBSD 8.0x86_64ruby26-gssapi-1.3.0.tgz
NetBSD 8.0x86_64ruby27-gssapi-1.3.0.tgz
NetBSD 8.0x86_64ruby26-gssapi-1.3.1.tgz
NetBSD 8.0x86_64ruby27-gssapi-1.3.1.tgz
NetBSD 9.0aarch64ruby26-gssapi-1.3.1.tgz
NetBSD 9.0aarch64ruby27-gssapi-1.3.1.tgz
NetBSD 9.0aarch64ruby30-gssapi-1.3.1.tgz
NetBSD 9.0aarch64ruby25-gssapi-1.3.0.tgz
NetBSD 9.0aarch64ruby26-gssapi-1.3.0.tgz
NetBSD 9.0aarch64ruby27-gssapi-1.3.0.tgz
NetBSD 9.0aarch64ruby25-gssapi-1.3.0.tgz
NetBSD 9.0aarch64ruby26-gssapi-1.3.0.tgz
NetBSD 9.0aarch64ruby27-gssapi-1.3.0.tgz
NetBSD 9.0aarch64ruby25-gssapi-1.3.1.tgz
NetBSD 9.0aarch64ruby26-gssapi-1.3.1.tgz
NetBSD 9.0aarch64ruby27-gssapi-1.3.1.tgz
NetBSD 9.0aarch64ruby30-gssapi-1.3.1.tgz
NetBSD 9.0aarch64ruby26-gssapi-1.3.1.tgz
NetBSD 9.0aarch64ruby27-gssapi-1.3.1.tgz
NetBSD 9.0aarch64ruby30-gssapi-1.3.1.tgz
NetBSD 9.0alpharuby25-gssapi-1.3.1.tgz
NetBSD 9.0alpharuby26-gssapi-1.3.1.tgz
NetBSD 9.0alpharuby27-gssapi-1.3.1.tgz
NetBSD 9.0alpharuby25-gssapi-1.3.1.tgz
NetBSD 9.0alpharuby26-gssapi-1.3.1.tgz
NetBSD 9.0alpharuby27-gssapi-1.3.1.tgz
NetBSD 9.0alpharuby25-gssapi-1.3.1.tgz
NetBSD 9.0alpharuby26-gssapi-1.3.1.tgz
NetBSD 9.0alpharuby27-gssapi-1.3.1.tgz
NetBSD 9.0earmv6hfruby26-gssapi-1.3.1.tgz
NetBSD 9.0earmv6hfruby27-gssapi-1.3.1.tgz
NetBSD 9.0earmv6hfruby30-gssapi-1.3.1.tgz
NetBSD 9.0earmv6hfruby25-gssapi-1.3.0.tgz
NetBSD 9.0earmv6hfruby26-gssapi-1.3.0.tgz
NetBSD 9.0earmv6hfruby27-gssapi-1.3.0.tgz
NetBSD 9.0earmv6hfruby25-gssapi-1.3.0.tgz
NetBSD 9.0earmv6hfruby26-gssapi-1.3.0.tgz
NetBSD 9.0earmv6hfruby27-gssapi-1.3.0.tgz
NetBSD 9.0earmv6hfruby25-gssapi-1.3.0.tgz
NetBSD 9.0earmv6hfruby26-gssapi-1.3.0.tgz
NetBSD 9.0earmv6hfruby27-gssapi-1.3.0.tgz
NetBSD 9.0earmv6hfruby25-gssapi-1.3.1.tgz
NetBSD 9.0earmv6hfruby26-gssapi-1.3.1.tgz
NetBSD 9.0earmv6hfruby27-gssapi-1.3.1.tgz
NetBSD 9.0earmv6hfruby30-gssapi-1.3.1.tgz
NetBSD 9.0earmv6hfruby26-gssapi-1.3.1.tgz
NetBSD 9.0earmv6hfruby27-gssapi-1.3.1.tgz
NetBSD 9.0earmv6hfruby30-gssapi-1.3.1.tgz
NetBSD 9.0earmv7hfruby26-gssapi-1.3.1.tgz
NetBSD 9.0earmv7hfruby27-gssapi-1.3.1.tgz
NetBSD 9.0earmv7hfruby30-gssapi-1.3.1.tgz
NetBSD 9.0earmv7hfruby25-gssapi-1.3.0.tgz
NetBSD 9.0earmv7hfruby26-gssapi-1.3.0.tgz
NetBSD 9.0earmv7hfruby27-gssapi-1.3.0.tgz
NetBSD 9.0earmv7hfruby25-gssapi-1.3.0.tgz
NetBSD 9.0earmv7hfruby26-gssapi-1.3.0.tgz
NetBSD 9.0earmv7hfruby27-gssapi-1.3.0.tgz
NetBSD 9.0earmv7hfruby25-gssapi-1.3.0.tgz
NetBSD 9.0earmv7hfruby26-gssapi-1.3.0.tgz
NetBSD 9.0earmv7hfruby27-gssapi-1.3.0.tgz
NetBSD 9.0earmv7hfruby25-gssapi-1.3.1.tgz
NetBSD 9.0earmv7hfruby26-gssapi-1.3.1.tgz
NetBSD 9.0earmv7hfruby27-gssapi-1.3.1.tgz
NetBSD 9.0earmv7hfruby30-gssapi-1.3.1.tgz
NetBSD 9.0earmv7hfruby25-gssapi-1.3.1.tgz
NetBSD 9.0earmv7hfruby26-gssapi-1.3.1.tgz
NetBSD 9.0earmv7hfruby27-gssapi-1.3.1.tgz
NetBSD 9.0earmv7hfruby30-gssapi-1.3.1.tgz
NetBSD 9.0earmv7hfruby26-gssapi-1.3.1.tgz
NetBSD 9.0earmv7hfruby27-gssapi-1.3.1.tgz
NetBSD 9.0earmv7hfruby30-gssapi-1.3.1.tgz
NetBSD 9.0earmv7hfruby26-gssapi-1.3.1.tgz
NetBSD 9.0earmv7hfruby27-gssapi-1.3.1.tgz
NetBSD 9.0earmv7hfruby30-gssapi-1.3.1.tgz
NetBSD 9.0i386ruby25-gssapi-1.3.0.tgz
NetBSD 9.0i386ruby26-gssapi-1.3.0.tgz
NetBSD 9.0i386ruby27-gssapi-1.3.0.tgz
NetBSD 9.0i386ruby25-gssapi-1.3.0.tgz
NetBSD 9.0i386ruby26-gssapi-1.3.0.tgz
NetBSD 9.0i386ruby27-gssapi-1.3.0.tgz
NetBSD 9.0i386ruby25-gssapi-1.3.1.tgz
NetBSD 9.0i386ruby26-gssapi-1.3.1.tgz
NetBSD 9.0i386ruby27-gssapi-1.3.1.tgz
NetBSD 9.0i386ruby30-gssapi-1.3.1.tgz
NetBSD 9.0i386ruby26-gssapi-1.3.1.tgz
NetBSD 9.0i386ruby27-gssapi-1.3.1.tgz
NetBSD 9.0i386ruby30-gssapi-1.3.1.tgz
NetBSD 9.0m68kruby26-gssapi-1.3.1.tgz
NetBSD 9.0m68kruby30-gssapi-1.3.1.tgz
NetBSD 9.0m68kruby26-gssapi-1.3.1.tgz
NetBSD 9.0m68kruby30-gssapi-1.3.1.tgz
NetBSD 9.0mips64ebruby25-gssapi-1.3.1.tgz
NetBSD 9.0mips64ebruby26-gssapi-1.3.1.tgz
NetBSD 9.0mips64ebruby27-gssapi-1.3.1.tgz
NetBSD 9.0mips64ebruby30-gssapi-1.3.1.tgz
NetBSD 9.0mips64ebruby25-gssapi-1.3.0.tgz
NetBSD 9.0mips64ebruby26-gssapi-1.3.0.tgz
NetBSD 9.0mips64ebruby27-gssapi-1.3.0.tgz
NetBSD 9.0mips64ebruby25-gssapi-1.3.0.tgz
NetBSD 9.0mips64ebruby26-gssapi-1.3.0.tgz
NetBSD 9.0mips64ebruby27-gssapi-1.3.0.tgz
NetBSD 9.0mips64ebruby25-gssapi-1.3.1.tgz
NetBSD 9.0mips64ebruby26-gssapi-1.3.1.tgz
NetBSD 9.0mips64ebruby27-gssapi-1.3.1.tgz
NetBSD 9.0mips64ebruby30-gssapi-1.3.1.tgz
NetBSD 9.0mips64ebruby25-gssapi-1.3.1.tgz
NetBSD 9.0mips64ebruby26-gssapi-1.3.1.tgz
NetBSD 9.0mips64ebruby27-gssapi-1.3.1.tgz
NetBSD 9.0mips64ebruby30-gssapi-1.3.1.tgz
NetBSD 9.0mipselruby27-gssapi-1.3.1.tgz
NetBSD 9.0mipselruby30-gssapi-1.3.1.tgz
NetBSD 9.0mipselruby25-gssapi-1.3.0.tgz
NetBSD 9.0mipselruby27-gssapi-1.3.0.tgz
NetBSD 9.0mipselruby27-gssapi-1.3.1.tgz
NetBSD 9.0mipselruby30-gssapi-1.3.1.tgz
NetBSD 9.0powerpcruby25-gssapi-1.3.1.tgz
NetBSD 9.0powerpcruby26-gssapi-1.3.1.tgz
NetBSD 9.0powerpcruby27-gssapi-1.3.1.tgz
NetBSD 9.0powerpcruby30-gssapi-1.3.1.tgz
NetBSD 9.0powerpcruby24-gssapi-1.3.0.tgz
NetBSD 9.0powerpcruby25-gssapi-1.3.0.tgz
NetBSD 9.0powerpcruby26-gssapi-1.3.0.tgz
NetBSD 9.0powerpcruby27-gssapi-1.3.0.tgz
NetBSD 9.0powerpcruby24-gssapi-1.3.0.tgz
NetBSD 9.0powerpcruby25-gssapi-1.3.0.tgz
NetBSD 9.0powerpcruby26-gssapi-1.3.0.tgz
NetBSD 9.0powerpcruby27-gssapi-1.3.0.tgz
NetBSD 9.0powerpcruby25-gssapi-1.3.1.tgz
NetBSD 9.0powerpcruby26-gssapi-1.3.1.tgz
NetBSD 9.0powerpcruby27-gssapi-1.3.1.tgz
NetBSD 9.0powerpcruby30-gssapi-1.3.1.tgz
NetBSD 9.0powerpcruby25-gssapi-1.3.1.tgz
NetBSD 9.0powerpcruby26-gssapi-1.3.1.tgz
NetBSD 9.0powerpcruby27-gssapi-1.3.1.tgz
NetBSD 9.0powerpcruby30-gssapi-1.3.1.tgz
NetBSD 9.0sh3elruby25-gssapi-1.3.0.tgz
NetBSD 9.0sparc64ruby25-gssapi-1.3.1.tgz
NetBSD 9.0sparc64ruby26-gssapi-1.3.1.tgz
NetBSD 9.0sparc64ruby27-gssapi-1.3.1.tgz
NetBSD 9.0sparc64ruby30-gssapi-1.3.1.tgz
NetBSD 9.0sparc64ruby25-gssapi-1.3.1.tgz
NetBSD 9.0sparc64ruby26-gssapi-1.3.1.tgz
NetBSD 9.0sparc64ruby27-gssapi-1.3.1.tgz
NetBSD 9.0sparc64ruby30-gssapi-1.3.1.tgz
NetBSD 9.0sparc64ruby25-gssapi-1.3.1.tgz
NetBSD 9.0sparc64ruby26-gssapi-1.3.1.tgz
NetBSD 9.0sparc64ruby27-gssapi-1.3.1.tgz
NetBSD 9.0sparc64ruby30-gssapi-1.3.1.tgz
NetBSD 9.0sparcruby25-gssapi-1.3.1.tgz
NetBSD 9.0sparcruby27-gssapi-1.3.1.tgz
NetBSD 9.0sparcruby30-gssapi-1.3.1.tgz
NetBSD 9.0sparcruby25-gssapi-1.3.0.tgz
NetBSD 9.0sparcruby27-gssapi-1.3.0.tgz
NetBSD 9.0sparcruby25-gssapi-1.3.0.tgz
NetBSD 9.0sparcruby27-gssapi-1.3.0.tgz
NetBSD 9.0sparcruby25-gssapi-1.3.1.tgz
NetBSD 9.0sparcruby27-gssapi-1.3.1.tgz
NetBSD 9.0sparcruby30-gssapi-1.3.1.tgz
NetBSD 9.0sparcruby25-gssapi-1.3.1.tgz
NetBSD 9.0sparcruby27-gssapi-1.3.1.tgz
NetBSD 9.0sparcruby30-gssapi-1.3.1.tgz
NetBSD 9.0vaxruby25-gssapi-1.3.0.tgz
NetBSD 9.0vaxruby27-gssapi-1.3.0.tgz
NetBSD 9.0x86_64ruby26-gssapi-1.3.1.tgz
NetBSD 9.0x86_64ruby27-gssapi-1.3.1.tgz
NetBSD 9.0x86_64ruby30-gssapi-1.3.1.tgz
NetBSD 9.0x86_64ruby26-gssapi-1.3.1.tgz
NetBSD 9.0x86_64ruby27-gssapi-1.3.1.tgz
NetBSD 9.0x86_64ruby30-gssapi-1.3.1.tgz
NetBSD 9.0x86_64ruby25-gssapi-1.3.0.tgz
NetBSD 9.0x86_64ruby26-gssapi-1.3.0.tgz
NetBSD 9.0x86_64ruby27-gssapi-1.3.0.tgz
NetBSD 9.0x86_64ruby25-gssapi-1.3.0.tgz
NetBSD 9.0x86_64ruby26-gssapi-1.3.0.tgz
NetBSD 9.0x86_64ruby27-gssapi-1.3.0.tgz
NetBSD 9.0x86_64ruby25-gssapi-1.3.1.tgz
NetBSD 9.0x86_64ruby26-gssapi-1.3.1.tgz
NetBSD 9.0x86_64ruby27-gssapi-1.3.1.tgz
NetBSD 9.0x86_64ruby30-gssapi-1.3.1.tgz
NetBSD 9.0x86_64ruby26-gssapi-1.3.1.tgz
NetBSD 9.0x86_64ruby27-gssapi-1.3.1.tgz
NetBSD 9.0x86_64ruby30-gssapi-1.3.1.tgz
NetBSD 9.0x86_64ruby26-gssapi-1.3.1.tgz
NetBSD 9.0x86_64ruby27-gssapi-1.3.1.tgz
NetBSD 9.0x86_64ruby30-gssapi-1.3.1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.