security/hs-tls - The NetBSD Packages Collection

TLS/SSL protocol native implementation (Server and Client)

Native Haskell TLS and SSL protocol implementation for server and
client.

This provides a high-level implementation of a sensitive security
protocol, eliminating a common set of security issues through the use
of the advanced type system, high level constructions and common
Haskell features.

Currently implement the SSL3.0, TLS1.0, TLS1.1, TLS1.2 and TLS 1.3
protocol, and support RSA and Ephemeral (Elliptic curve and regular)
Diffie Hellman key exchanges, and many extensions.

Build dependencies

pkgtools/cwrappers devel/pkgconf

Runtime dependencies

devel/hs-asn1-encoding devel/hs-asn1-types time/hs-hourglass devel/hs-memory devel/hs-async devel/hs-cereal security/hs-cryptonite devel/hs-data-default-class security/hs-x509 security/hs-x509-store security/hs-x509-validation net/hs-network lang/ghc88 devel/hs-cereal devel/hs-data-default-class net/hs-network lang/ghc88

Binary packages

OSArchitectureVersion
NetBSD 8.0x86_64hs-tls-1.5.3.tgz
NetBSD 8.0x86_64hs-tls-1.5.3.tgz
NetBSD 8.0x86_64hs-tls-1.5.3.tgz
NetBSD 9.0x86_64hs-tls-1.5.3.tgz
NetBSD 9.0x86_64hs-tls-1.5.3.tgz
NetBSD 9.0x86_64hs-tls-1.5.3.tgz
NetBSD 9.0x86_64hs-tls-1.5.3.tgz
NetBSD 9.0x86_64hs-tls-1.5.3.tgz
NetBSD 9.0x86_64hs-tls-1.5.3.tgz
NetBSD 9.0x86_64hs-tls-1.5.3.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.