Daemon Power

The NetBSD Packages Collection: security/gpgmepp

Brief description of the package:
C++ bindings/wrapper for gpgme

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://projects.kde.org/gpgmepp.

Please note that this package has a gnu-lgpl-v2.1 license.

The package is located in the "security/gpgmepp" directory. The current source version of the package is "gpgmepp-15.12.2nb10". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for security/gpgmepp :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: gnupg2>=2.2.0 pinentry-[0-9]* libassuan>=2.1.0 libgpg-error>=0.6 cwrappers>=20150314 libgpg-error>=1.17 libgpg-error>=1.10nb1 libassuan>=2.4.2 libgpg-error>=1.16 libksba>=0.9.7 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=1.2 libgcrypt>=1.6.0 libksba>=1.3.0nb1 libusb1>=1.0.9 libgcrypt>=1.7 libgpg-error>=1.28 libassuan>=2.5.1 libksba>=1.3.4 npth>=1.2 npth>=1.1 gpgme>=0.9.0 libassuan>=2.0.2 qt5-qtbase>=5.9.1 glib2>=2.4.0 perl>=5.0 libelf>=0.8.5 pcre>=8.31 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.0.11 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 readline>=2.2 readline>=6.0 python27>=2.7.1nb2 pcre2>=10.21 harfbuzz>=0.9.4 icu>=3.4 freetype2>=2.4.5 freetype2>=2.1.3 icu>=62.1 glib2>=2.34.0 freetype2>=2.4.11 png>=1.2.4 dbus>=0.91 xmlto-[0-9]* getopt-[0-9]* docbook-xsl>=1.67.0nb1 docbook-xml>=4.2 xmlcatmgr>=2.0beta1 libxml2>=2.6.2 libxslt>=1.1.8 libxml2>=2.6.27 libxml2>=2.8.0nb2 docbook-xml-[0-9]* docbook-xsl-[0-9]* libxslt>=1.1.28nb2 x11-links>=1.12 osabi-NetBSD-8.0_RC2 libproxy>=0.2.3 fontconfig>=2.10.93 libuuid>=2.18 freetype2>=2.8.1 gperf-[0-9]* fontconfig>=2.1nb2 glu>=3.4.2 MesaLib>=3.4.2 libxcb>=1.6 libXdmcp>=0.99 xorgproto>=2016.1 libXau>=1.0 xcb-proto>=1.13 xcb-proto>=1.4 py27-mako-[0-9]* py27-setuptools>=0.8 py27-expat-[0-9]* MesaLib>=7.11.2 glu>=6.0 xcb-util>=0.3.9 gperf>=3.0.1 xcb-util-image>=0.3.9 xcb-util-keysyms>=0.3.9 xcb-util-renderutil>=0.3.8nb1 xcb-util-wm>=0.3.9 xcursor>=1.0 Xfixes>=2.0.0 fixesproto>=3.0.0<5 Xrender>=0.8 Xrender>=0.2 Xrender>=0.8.2 Xfixes>=2.0.1nb2 Xrender>=0.9.0nb1 xcursor>=1.1.1 Xft2>=2.1 fontconfig>=2.2 Xrender>=0.9.0nb2 fontconfig>=2.13.0 Xft2>=2.1nb2 Xrandr>=0.99 Xrandr>=1.0.1 libxkbcommon>=0.4.0 libxcb>=1.10 xorg-util-macros>=1.17 xkeyboard-config>=1.9 xkbcomp-[0-9]* jpeg>=8nb1 pcre2>=10.30 harfbuzz>=1.4.2nb1 png>=1.6.0nb1 libproxy>=0.4.11 glu>=7.11.2 xcursor>=1.1.2nb1 Xft2>=2.1.7nb7 Xrandr>=1.0.2nb3 libxkbcommon>=0.4.0nb1 jpeg>=9 gpgme>=1.8.0nb1 qt5-qtbase>=5.11.1nb1 extra-cmake-modules>=5.19.0 boost-headers-1.67.* boost-jam-1.67.* .

This package requires the following package(s) to run: gnupg2>=2.2.0 pinentry-[0-9]* libassuan>=2.1.0 libgpg-error>=0.6 libgpg-error>=1.17 libgpg-error>=1.10nb1 libassuan>=2.4.2 libgpg-error>=1.16 libksba>=0.9.7 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=1.2 libgcrypt>=1.6.0 libksba>=1.3.0nb1 libusb1>=1.0.9 libgcrypt>=1.7 libgpg-error>=1.28 libassuan>=2.5.1 libksba>=1.3.4 npth>=1.2 npth>=1.1 gpgme>=0.9.0 libassuan>=2.0.2 qt5-qtbase>=5.9.1 glib2>=2.4.0 perl>=5.0 libelf>=0.8.5 pcre>=8.31 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.0.11 pcre2>=10.21 harfbuzz>=0.9.4 icu>=3.4 freetype2>=2.4.5 freetype2>=2.1.3 icu>=62.1 glib2>=2.34.0 freetype2>=2.4.11 png>=1.2.4 dbus>=0.91 libproxy>=0.2.3 fontconfig>=2.10.93 libuuid>=2.18 freetype2>=2.8.1 fontconfig>=2.1nb2 glu>=3.4.2 MesaLib>=3.4.2 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 MesaLib>=7.11.2 glu>=6.0 xcb-util>=0.3.9 xcb-util-image>=0.3.9 xcb-util-keysyms>=0.3.9 xcb-util-renderutil>=0.3.8nb1 xcb-util-wm>=0.3.9 xcursor>=1.0 Xfixes>=2.0.0 Xrender>=0.8 Xrender>=0.2 Xrender>=0.8.2 Xfixes>=2.0.1nb2 Xrender>=0.9.0nb1 xcursor>=1.1.1 Xft2>=2.1 fontconfig>=2.2 Xrender>=0.9.0nb2 fontconfig>=2.13.0 Xft2>=2.1nb2 Xrandr>=0.99 Xrandr>=1.0.1 libxkbcommon>=0.4.0 libxcb>=1.10 jpeg>=8nb1 pcre2>=10.30 harfbuzz>=1.4.2nb1 png>=1.6.0nb1 libproxy>=0.4.11 glu>=7.11.2 xcursor>=1.1.2nb1 Xft2>=2.1.7nb7 Xrandr>=1.0.2nb3 libxkbcommon>=0.4.0nb1 jpeg>=9 gpgme>=1.8.0nb1 qt5-qtbase>=5.11.1nb1 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
alpha:gpgmepp-15.12.2nb7.tgz(NetBSD 8.0)
earmv6hf:gpgmepp-15.12.2nb6.tgz(NetBSD 8.0)
earmv7hf:gpgmepp-15.12.2nb8.tgz(NetBSD 8.0)
earmv7hfeb:gpgmepp-15.12.2nb7.tgz(NetBSD 8.0)
i386:gpgmepp-15.12.2nb3.tgz(NetBSD 6.0)
i386:gpgmepp-15.12.2nb9.tgz(NetBSD 7.0)
i386:gpgmepp-15.12.2.tgz(NetBSD 7.0)
i386:gpgmepp-15.12.2nb1.tgz(NetBSD 7.0)
i386:gpgmepp-15.12.2nb3.tgz(NetBSD 7.0)
i386:gpgmepp-15.12.2nb5.tgz(NetBSD 7.0)
i386:gpgmepp-15.12.2nb7.tgz(NetBSD 7.0)
i386:gpgmepp-15.12.2nb8.tgz(NetBSD 7.0)
i386:gpgmepp-15.12.2nb9.tgz(NetBSD 7.1)
i386:gpgmepp-15.12.2nb7.tgz(NetBSD 7.1)
i386:gpgmepp-15.12.2nb8.tgz(NetBSD 7.1)
i386:gpgmepp-15.12.2nb7.tgz(NetBSD 8.0)
i386:gpgmepp-15.12.2nb8.tgz(NetBSD 8.0)
powerpc:gpgmepp-15.12.2nb9.tgz(NetBSD 7.1)
powerpc:gpgmepp-15.12.2nb9.tgz(NetBSD 8.0)
powerpc:gpgmepp-15.12.2nb8.tgz(NetBSD 8.0)
sparc64:gpgmepp-15.12.2nb7.tgz(NetBSD 8.0)
x86_64:gpgmepp-15.12.2nb9.tgz(NetBSD 7.0)
x86_64:gpgmepp-15.12.2nb6.tgz(NetBSD 7.0)
x86_64:gpgmepp-15.12.2nb7.tgz(NetBSD 7.0)
x86_64:gpgmepp-15.12.2nb8.tgz(NetBSD 7.0)
x86_64:gpgmepp-15.12.2nb5.tgz(NetBSD 7.0.1_PATCH)
x86_64:gpgmepp-15.12.2nb9.tgz(NetBSD 7.1)
x86_64:gpgmepp-15.12.2nb7.tgz(NetBSD 7.1)
x86_64:gpgmepp-15.12.2nb8.tgz(NetBSD 7.1)
x86_64:gpgmepp-15.12.2nb9.tgz(NetBSD 8.0)
x86_64:gpgmepp-15.12.2nb5.tgz(NetBSD 8.99.1)
x86_64:gpgmepp-15.12.2nb6.tgz(NetBSD 8.0)
x86_64:gpgmepp-15.12.2nb7.tgz(NetBSD 8.0)
x86_64:gpgmepp-15.12.2nb8.tgz(NetBSD 8.0)
x86_64:gpgmepp-15.12.2nb5.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]