Daemon Power

The NetBSD Packages Collection: parallel/slurm-wlm

Brief description of the package:
Simple Linux Utility for Resource Management

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://www.schedmd.com/.

Please note that this package has a gnu-gpl-v2 license.

The package is located in the "parallel/slurm-wlm" directory. The current source version of the package is "slurm-wlm-19.05.5nb5". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for parallel/slurm-wlm :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: curl>=7.12.3 libidn2>=2.0.0 libunistring>=0.9.3 cwrappers>=20150314 libunistring>=0.9.4 nghttp2>=1.0.0 python37>=3.7 libffi>=1.20 libuuid>=2.18 libffi>=3.3nb1 readline>=2.2 readline>=6.0 python37>=3.7.0 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.9.10nb2 nghttp2>=1.40.0nb4 munge>=0.5.10 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libgcrypt>=1.6.0 hwloc>=1.4 x11-links>=1.31 osabi-NetBSD-9.0_STABLE hdf5>=1.8.7 libaec>=1.0.4 lz4>=1.7.3<100 json-c>=0.14 libssh2>=0.18 lua53>=5.3.0<5.4 mysql-client>=5.7.12<5.8 perl>=5.0 boost-libs-1.73.* icu>=3.4 icu>=67.1 boost-jam-1.73.* editline>=3.0.20130712nb1 libevent>=0.6 lz4>=1.7.3 boost-libs>=1.73.0 libevent>=2.1.11nb1 boost-headers-1.73.* curl>=7.70.0nb2 hwloc>=1.11.13nb1 hdf5>=1.8.11 libssh2>=1.9.0nb1 mysql-client>=5.7.28nb2 man2html-[0-9]* .

This package requires the following package(s) to run: curl>=7.12.3 libidn2>=2.0.0 libunistring>=0.9.3 libunistring>=0.9.4 nghttp2>=1.0.0 python37>=3.7 libffi>=1.20 libuuid>=2.18 libffi>=3.3nb1 python37>=3.7.0 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.9.10nb2 nghttp2>=1.40.0nb4 munge>=0.5.10 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libgcrypt>=1.6.0 hwloc>=1.4 hdf5>=1.8.7 libaec>=1.0.4 readline>=2.2 lz4>=1.7.3<100 json-c>=0.14 libssh2>=0.18 lua53>=5.3.0<5.4 mysql-client>=5.7.12<5.8 perl>=5.0 boost-libs-1.73.* icu>=3.4 icu>=67.1 editline>=3.0.20130712nb1 libevent>=0.6 lz4>=1.7.3 boost-libs>=1.73.0 libevent>=2.1.11nb1 curl>=7.70.0nb2 hwloc>=1.11.13nb1 hdf5>=1.8.11 readline>=6.0 libssh2>=1.9.0nb1 mysql-client>=5.7.28nb2 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
aarch64:slurm-wlm-19.05.5nb5.tgz(NetBSD 9.0)
aarch64:slurm-wlm-17.11.5nb9.tgz(NetBSD 9.0)
aarch64:slurm-wlm-19.05.5nb1.tgz(NetBSD 9.0)
alpha:slurm-wlm-17.11.5nb9.tgz(NetBSD 8.0)
earmv6hf:slurm-wlm-17.11.5nb9.tgz(NetBSD 8.0)
earmv6hf:slurm-wlm-17.11.5nb9.tgz(NetBSD 9.0)
earmv7hf:slurm-wlm-17.11.5nb9.tgz(NetBSD 8.0)
earmv7hf:slurm-wlm-17.11.5nb9.tgz(NetBSD 9.0)
i386:slurm-wlm-17.11.5nb9.tgz(NetBSD 7.0)
i386:slurm-wlm-17.11.5nb9.tgz(NetBSD 7.0)
i386:slurm-wlm-17.11.5nb9.tgz(NetBSD 7.1)
i386:slurm-wlm-17.11.5nb9.tgz(NetBSD 7.1)
i386:slurm-wlm-17.11.5nb9.tgz(NetBSD 8.0)
i386:slurm-wlm-17.11.5nb9.tgz(NetBSD 8.0)
i386:slurm-wlm-17.11.5nb9.tgz(NetBSD 9.0)
sparc64:slurm-wlm-17.11.5nb9.tgz(NetBSD 8.0)
sparc64:slurm-wlm-17.11.5nb9.tgz(NetBSD 9.0)
x86_64:slurm-wlm-19.05.5nb2.tgz(NetBSD 9.0)
x86_64:slurm-wlm-19.05.5nb4.tgz(NetBSD 9.0)
x86_64:slurm-wlm-17.11.5nb9.tgz(NetBSD 7.0)
x86_64:slurm-wlm-17.11.5nb9.tgz(NetBSD 7.0)
x86_64:slurm-wlm-17.11.5nb9.tgz(NetBSD 7.1)
x86_64:slurm-wlm-17.11.5nb9.tgz(NetBSD 7.1)
x86_64:slurm-wlm-17.11.5nb9.tgz(NetBSD 8.0)
x86_64:slurm-wlm-17.11.5nb9.tgz(NetBSD 8.0)
x86_64:slurm-wlm-19.05.5nb5.tgz(NetBSD 8.0)
x86_64:slurm-wlm-19.05.5nb5.tgz(NetBSD 9.0)
x86_64:slurm-wlm-17.11.5nb9.tgz(NetBSD 9.0)
x86_64:slurm-wlm-19.05.5nb5.tgz(NetBSD 9.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]