net/netatalk3 - The NetBSD Packages Collection

Netatalk AFP file services

Netatalk 3 is a freely-available implementation of the Apple
Filesharing Protocol Suite (AFP) over TCP/IP.

Using Netatalk's AFP 3.1 compliant file-server leads to significantly
higher transmissions speeds compared with Macs accessing a server via
SMB or NFS, while providing clients with the best user experience (full
support for Macintosh metadata, flawlessly supporting mixed
environments of classic MacOS and MacOS X clients).

See also netatalk22, which has full support for pre-Darwin systems.

Build dependencies

devel/libtool-base pkgtools/mktools devel/gmake devel/pkgconf pkgtools/cwrappers

Runtime dependencies

lang/perl5 devel/libevent devel/libevent lang/python311 lang/python311 security/libgcrypt databases/db5 devel/libevent security/libgcrypt databases/db5

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64netatalk3-3.1.19.tgz
NetBSD 10.0aarch64netatalk3-3.1.15nb4.tgz
NetBSD 10.0aarch64netatalk3-3.1.18.tgz
NetBSD 10.0aarch64ebnetatalk3-3.1.18.tgz
NetBSD 10.0alphanetatalk3-3.1.18.tgz
NetBSD 10.0alphanetatalk3-3.1.18.tgz
NetBSD 10.0earmv6hfnetatalk3-3.1.15nb4.tgz
NetBSD 10.0earmv6hfnetatalk3-3.1.18.tgz
NetBSD 10.0earmv6hfnetatalk3-3.1.19.tgz
NetBSD 10.0earmv7hfnetatalk3-3.1.19.tgz
NetBSD 10.0earmv7hfnetatalk3-3.1.15nb4.tgz
NetBSD 10.0earmv7hfnetatalk3-3.1.18.tgz
NetBSD 10.0i386netatalk3-3.1.19.tgz
NetBSD 10.0i386netatalk3-3.1.15nb4.tgz
NetBSD 10.0i386netatalk3-3.1.18.tgz
NetBSD 10.0powerpcnetatalk3-3.1.15nb1.tgz
NetBSD 10.0powerpcnetatalk3-3.1.15nb4.tgz
NetBSD 10.0sparc64netatalk3-3.1.18.tgz
NetBSD 10.0x86_64netatalk3-3.1.19.tgz
NetBSD 10.0x86_64netatalk3-3.1.15nb4.tgz
NetBSD 10.0x86_64netatalk3-3.1.18.tgz
NetBSD 9.0aarch64netatalk3-3.1.19.tgz
NetBSD 9.0aarch64netatalk3-3.1.15nb4.tgz
NetBSD 9.0aarch64netatalk3-3.1.18.tgz
NetBSD 9.0alphanetatalk3-3.1.18.tgz
NetBSD 9.0earmv6hfnetatalk3-3.1.19.tgz
NetBSD 9.0earmv6hfnetatalk3-3.1.15nb4.tgz
NetBSD 9.0earmv6hfnetatalk3-3.1.18.tgz
NetBSD 9.0earmv7hfnetatalk3-3.1.19.tgz
NetBSD 9.0earmv7hfnetatalk3-3.1.15nb4.tgz
NetBSD 9.0earmv7hfnetatalk3-3.1.18.tgz
NetBSD 9.0i386netatalk3-3.1.19.tgz
NetBSD 9.0i386netatalk3-3.1.15nb4.tgz
NetBSD 9.0i386netatalk3-3.1.18.tgz
NetBSD 9.0powerpcnetatalk3-3.1.15nb4.tgz
NetBSD 9.0powerpcnetatalk3-3.1.15nb1.tgz
NetBSD 9.0powerpcnetatalk3-3.1.18.tgz
NetBSD 9.0sparc64netatalk3-3.1.18.tgz
NetBSD 9.0x86_64netatalk3-3.1.19.tgz
NetBSD 9.0x86_64netatalk3-3.1.15nb4.tgz
NetBSD 9.0x86_64netatalk3-3.1.18.tgz
NetBSD 9.3x86_64netatalk3-3.1.18nb2.tgz
NetBSD 9.3x86_64netatalk3-3.1.18nb2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

debug
Enable debugging facilities in the package.
dnssd
Enable DNS Service Discovery Protocol support.
kerberos
Enable Kerberos support.
ldap
Enable LDAP support.
pam
Enable PAM support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.