Daemon Power

The NetBSD Packages Collection: net/libsoup

Brief description of the package:
HTTP library implementation in C

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://wiki.gnome.org/Projects/libsoup.

Please note that this package has a gnu-lgpl-v2 license.

The package is located in the "net/libsoup" directory. The current source version of the package is "libsoup-2.62.3". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for net/libsoup :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: glib-networking-[0-9]* mozilla-rootcerts>=1.0.20150804nb1 cwrappers>=20150314 glib2>=2.56.0 perl>=5.0 libelf>=0.8.5 pcre>=8.31 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.0.11 python27>=2.7 readline>=2.2 readline>=6.0 python27>=2.7.1nb2 glib2>=2.4.0 libproxy>=0.3.1 libproxy>=0.2.3 gnutls>=3.6.0nb1 lzo>=2.01 gmp>=5.0 gmp>=4.2.1 libcfg+>=0.6.2nb1 libtasn1>=4.9 libtasn1>=0.2.7 nettle>=3.1 gmp>=5.0.1 nettle>=2.4 p11-kit>=0.23.1 libtasn1>=0.3.0 p11-kit>=0.10 p11-kit>=0.23 libunistring>=0.9.3 libcfg+>=0.6.2nb3 nettle>=3.1.1 libunistring>=0.9.4 gnutls>=3.3.0 gsettings-desktop-schemas>=3.4.2 glib2>=2.34.0 gobject-introspection>=1.31 py27-cElementTree-[0-9]* py27-expat-[0-9]* glib2>=2.54.0 libffi>=3.0.0 gobject-introspection>=0.6.14nb1 gobject-introspection>=1.34.0 python37>=3.7 libuuid>=2.18 python37>=3.7.0 libproxy>=0.4.11 py37-meson-[0-9]* ninja-build-[0-9]* re2c>=0.11.3 py37-setuptools>=0.8 glib2>=2.38.0 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 gobject-introspection>=0.9.5 .

This package requires the following package(s) to run: glib-networking-[0-9]* mozilla-rootcerts>=1.0.20150804nb1 glib2>=2.56.0 perl>=5.0 libelf>=0.8.5 pcre>=8.31 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.0.11 glib2>=2.4.0 libproxy>=0.3.1 libproxy>=0.2.3 gnutls>=3.6.0nb1 lzo>=2.01 gmp>=5.0 gmp>=4.2.1 libcfg+>=0.6.2nb1 libtasn1>=4.9 libtasn1>=0.2.7 nettle>=3.1 gmp>=5.0.1 nettle>=2.4 p11-kit>=0.23.1 libtasn1>=0.3.0 p11-kit>=0.10 p11-kit>=0.23 libunistring>=0.9.3 libcfg+>=0.6.2nb3 nettle>=3.1.1 libunistring>=0.9.4 gnutls>=3.3.0 gsettings-desktop-schemas>=3.4.2 glib2>=2.34.0 python37>=3.7 libuuid>=2.18 python37>=3.7.0 libproxy>=0.4.11 glib2>=2.38.0 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 .

This package supports the following build-time options:

gssapi
Enable gssapi (Kerberos V) support.

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
earm:libsoup-2.50.0nb1.tgz(NetBSD 7.0)
earm:libsoup-2.50.0.tgz(NetBSD 7.0)
earm:libsoup-2.50.0.tgz(NetBSD 7.0)
earm:libsoup-2.50.0nb1.tgz(NetBSD 7.0)
earmv6hf:libsoup-2.50.0nb1.tgz(NetBSD 7.0)
earmv6hf:libsoup-2.58.2nb1.tgz(NetBSD 8.0)
earmv6hf:libsoup-2.60.2nb1.tgz(NetBSD 8.0)
earmv7hf:libsoup-2.50.0nb1.tgz(NetBSD 7.0)
earmv7hf:libsoup-2.60.3.tgz(NetBSD 8.0)
earmv7hfeb:libsoup-2.52.2.tgz(NetBSD 7.0)
earmv7hfeb:libsoup-2.60.2nb1.tgz(NetBSD 8.0)
i386:libsoup-2.54.1nb3.tgz(NetBSD 6.0)
i386:libsoup-2.58.2nb1.tgz(NetBSD 6.0)
i386:libsoup-2.62.2.tgz(NetBSD 7.0)
i386:libsoup-2.54.1nb3.tgz(NetBSD 7.0)
i386:libsoup-2.60.2nb1.tgz(NetBSD 7.0)
i386:libsoup-2.60.3.tgz(NetBSD 7.0)
i386:libsoup-2.62.2.tgz(NetBSD 7.1)
i386:libsoup-2.60.2nb1.tgz(NetBSD 7.1)
i386:libsoup-2.60.3.tgz(NetBSD 7.1)
i386:libsoup-2.62.2.tgz(NetBSD 8.0)
i386:libsoup-2.60.2nb1.tgz(NetBSD 8.0)
i386:libsoup-2.60.3.tgz(NetBSD 8.0)
powerpc:libsoup-2.62.2.tgz(NetBSD 7.1)
powerpc:libsoup-2.60.3.tgz(NetBSD 7.1)
powerpc:libsoup-2.62.2.tgz(NetBSD 8.0)
powerpc:libsoup-2.60.3.tgz(NetBSD 8.0)
sparc64:libsoup-2.50.0.tgz(NetBSD 7.0)
sparc64:libsoup-2.50.0nb1.tgz(NetBSD 7.0)
sparc64:libsoup-2.54.1nb1.tgz(NetBSD 7.1_RC1)
sparc64:libsoup-2.62.2.tgz(NetBSD 7.1)
sparc64:libsoup-2.60.2nb1.tgz(NetBSD 8.0)
sparc:libsoup-2.50.0.tgz(NetBSD 7.0)
x86_64:libsoup-2.58.2nb1.tgz(NetBSD 6.0)
x86_64:libsoup-2.58.2nb1.tgz(NetBSD 6.1)
x86_64:libsoup-2.62.2.tgz(NetBSD 7.0)
x86_64:libsoup-2.58.2nb1.tgz(NetBSD 7.0)
x86_64:libsoup-2.60.2nb1.tgz(NetBSD 7.0)
x86_64:libsoup-2.60.3.tgz(NetBSD 7.0)
x86_64:libsoup-2.54.1nb3.tgz(NetBSD 7.0.1_PATCH)
x86_64:libsoup-2.62.2.tgz(NetBSD 7.1)
x86_64:libsoup-2.60.2nb1.tgz(NetBSD 7.1)
x86_64:libsoup-2.60.3.tgz(NetBSD 7.1)
x86_64:libsoup-2.62.2.tgz(NetBSD 8.0)
x86_64:libsoup-2.54.1nb3.tgz(NetBSD 8.99.1)
x86_64:libsoup-2.58.2nb1.tgz(NetBSD 8.0)
x86_64:libsoup-2.60.2nb1.tgz(NetBSD 8.0)
x86_64:libsoup-2.60.3.tgz(NetBSD 8.0)
x86_64:libsoup-2.58.2.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]