net/hercules4sdl-telnet - The NetBSD Packages Collection

The SoftDevLabs version of telnet library for Hercules 4.x

Simple RFC-compliant TELNET implementation

libtelnet is a library for handling the TELNET protocol. It includes routines
for parsing incoming data from a remote peer as well as formatting data to be
sent to the remote peer.

libtelnet uses a callback-oriented API, allowing application-specific handling
of various events. The callback system is also used for buffering outgoing
protocol data, allowing the application to maintain control of the actual
socket connection.

Features supported include the full TELNET protocol, Q-method option
negotiation, and NEW-ENVIRON.

This version is the one used by the SoftDevLabs version of
Hercules 4.x (Hyperion).

Build dependencies

pkgtools/mktools devel/cmake pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64hercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 10.0aarch64hercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 10.0aarch64hercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 10.0aarch64ebhercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 10.0aarch64ebhercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 10.0alphahercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 10.0alphahercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 10.0earmv6hfhercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 10.0earmv6hfhercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 10.0earmv6hfhercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 10.0earmv7hfhercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 10.0earmv7hfhercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 10.0earmv7hfhercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 10.0i386hercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 10.0i386hercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 10.0i386hercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 10.0powerpchercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 10.0powerpchercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 10.0sh3elhercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 10.0sparc64hercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 10.0sparc64hercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 10.0sparchercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 10.0sparchercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 10.0vaxhercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 10.0vaxhercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 10.0x86_64hercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 10.0x86_64hercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 10.0x86_64hercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 9.0aarch64hercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 9.0aarch64hercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 9.0aarch64hercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 9.0alphahercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 9.0earmv6hfhercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 9.0earmv6hfhercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 9.0earmv6hfhercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 9.0earmv7hfhercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 9.0earmv7hfhercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 9.0earmv7hfhercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 9.0i386hercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 9.0i386hercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 9.0i386hercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 9.0m68khercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 9.0powerpchercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 9.0powerpchercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 9.0powerpchercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 9.0sparc64hercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 9.0x86_64hercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 9.0x86_64hercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 9.0x86_64hercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 9.3x86_64hercules4sdl-telnet-1.0.0nb20220201.tgz
NetBSD 9.3x86_64hercules4sdl-telnet-1.0.0nb20220201.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.