net/czmq - The NetBSD Packages Collection

High-level C binding for ZeroMQ

High-level C binding for ZeroMQ. czmq is trying to create shorter and
more readable applications by wrapping the ZeroMQ core API in better
semantics. It also tries to hide the differences between versions of
ZeroMQ as far as possible.

Build dependencies

devel/libtool-base pkgtools/mktools devel/gmake devel/pkgconf pkgtools/cwrappers

Runtime dependencies

archivers/lz4 devel/libuuid devel/nss net/zeromq www/curl www/libmicrohttpd archivers/lz4 devel/nss net/zeromq www/curl www/libmicrohttpd

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64czmq-4.2.1nb2.tgz
NetBSD 10.0aarch64czmq-4.2.1.tgz
NetBSD 10.0aarch64ebczmq-4.2.1.tgz
NetBSD 10.0aarch64ebczmq-4.2.1nb2.tgz
NetBSD 10.0alphaczmq-4.2.1nb2.tgz
NetBSD 10.0earmv6hfczmq-4.2.1nb2.tgz
NetBSD 10.0earmv6hfczmq-4.2.1.tgz
NetBSD 10.0earmv7hfczmq-4.2.1nb2.tgz
NetBSD 10.0earmv7hfczmq-4.2.1.tgz
NetBSD 10.0i386czmq-4.2.1nb2.tgz
NetBSD 10.0i386czmq-4.2.1.tgz
NetBSD 10.0powerpcczmq-4.2.1.tgz
NetBSD 10.0x86_64czmq-4.2.1nb2.tgz
NetBSD 10.0_BETAx86_64czmq-4.2.1.tgz
NetBSD 8.0powerpcczmq-4.2.1nb2.tgz
NetBSD 8.0powerpcczmq-4.2.1.tgz
NetBSD 8.0x86_64czmq-4.2.1.tgz
NetBSD 8.0x86_64czmq-4.2.1nb2.tgz
NetBSD 9.0aarch64czmq-4.2.1nb2.tgz
NetBSD 9.0aarch64czmq-4.2.1.tgz
NetBSD 9.0alphaczmq-4.2.1nb2.tgz
NetBSD 9.0earmv6hfczmq-4.2.1nb2.tgz
NetBSD 9.0earmv6hfczmq-4.2.1.tgz
NetBSD 9.0earmv7hfczmq-4.2.1nb2.tgz
NetBSD 9.0earmv7hfczmq-4.2.1.tgz
NetBSD 9.0i386czmq-4.2.1.tgz
NetBSD 9.0i386czmq-4.2.1nb2.tgz
NetBSD 9.0powerpcczmq-4.2.1.tgz
NetBSD 9.0powerpcczmq-4.2.1nb2.tgz
NetBSD 9.0x86_64czmq-4.2.1nb2.tgz
NetBSD 9.0x86_64czmq-4.2.1.tgz
NetBSD 9.3x86_64czmq-4.2.1nb2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.