Daemon Power

The NetBSD Packages Collection: multimedia/lightspark

Brief description of the package:
Open source Flash player

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://lightspark.github.io/.

Please note that this package has a gnu-lgpl-v3 license.

The package is located in the "multimedia/lightspark" directory. The current source version of the package is "lightspark-0.8.1nb1". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for multimedia/lightspark :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: SDL2_mixer>=2.0.0 flac>=1.1.0nb1 libogg>=1.1 cwrappers>=20150314 libogg>=1.1.2nb1 libmodplug>=0.7 libvorbis>=1.0.1 mpg123>=1.0.0 opusfile>=0.5 libopus>=1.1 SDL2>=2.0 MesaLib>=3.4.2 libxcb>=1.6 libXdmcp>=0.99 xorgproto>=2016.1 libXau>=1.0 xcb-proto>=1.13 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 xcb-proto>=1.4 py27-mako-[0-9]* py37-setuptools>=0.8 py37-expat-[0-9]* python37>=3.7 libffi>=1.20 libuuid>=2.18 libffi>=3.0.11 readline>=2.2 readline>=6.0 python37>=3.7.0 python37>=3.7.4 x11-links>=1.22 osabi-NetBSD-8.0_STABLE python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 python27>=2.7.1nb2 libXScrnSaver>=1.1.2 xcursor>=1.0 Xfixes>=2.0.0 fixesproto>=3.0.0<5 Xrender>=0.8 Xrender>=0.2 Xrender>=0.8.2 Xfixes>=2.0.1nb2 Xrender>=0.9.0nb1 xcursor>=1.1.1 Xrandr>=0.99 Xrandr>=1.0.1 libusb-compat>=0.1.6rc2 libusb1>=1.0.9 MesaLib>=7.11.2 xcursor>=1.1.2nb1 Xrandr>=1.0.2nb3 flac>=1.1.3nb1 libmodplug>=0.8.8.1 libvorbis>=1.1.0nb1 opusfile>=0.7 SDL2>=2.0.3nb8 boost-libs-1.70.* icu>=3.4 icu>=64.1 boost-jam-1.70.* glibmm>=2.24.2 perl>=5.0 glib2>=2.60.0 pcre>=3.4nb1 pcre>=8.30nb1 py37-meson-[0-9]* ninja-build-[0-9]* re2c>=0.11.3 glib2>=2.4.0 libsigc++>=2.9.1 mm-common>=0.9.10 mm-common>=0.9.6 libsigc++>=2.0.3 glib2>=2.34.0 libsigc++>=2.0.17nb1 pango>=1.6.0 Xft2>=2.1.7nb3 fontconfig>=2.2 freetype2>=2.8.1 freetype2>=2.4.5 freetype2>=2.1.3 freetype2>=2.4.11 fontconfig>=2.10.93 fontconfig>=2.1nb2 Xrender>=0.9.0nb2 fontconfig>=2.13.0 Xft2>=2.1 Xft2>=2.1nb2 fontconfig>=2.11.91 fribidi>=0.19.7 fribidi>=0.19.1 glib2>=2.33.12 harfbuzz>=0.9.9 graphite2>=1.2 harfbuzz>=2.1.1 cairo>=1.12.10 lzo>=2.01 fontconfig>=2.2.95 freetype2>=2.1.9 png>=1.2.4 pixman>=0.30.0 pixman>=0.25.2 png>=1.6.0nb1 cairo>=1.0.0nb2 cairo-gobject>=1.10.2 cairo>=1.16.0 glib2>=2.14.0 Xft2>=2.1.7nb7 cairo-gobject>=1.16.0 help2man-[0-9]* p5-gettext>=1.01 perl>=5.28.0 perl<5.30.0 gobject-introspection>=0.6.14nb1 py37-cElementTree-[0-9]* glib2>=2.58.0 libffi>=3.0.0 gobject-introspection>=1.34.0 glew>=1.3.4 hicolor-icon-theme>=0.4 libLLVM34>=3.4.2nb1 ffmpeg4>=4.0 libass>=0.9.12 fribidi>=0.19.0 enca>=1.9 libaom>=1.0.0nb1 nasm>=2.13 asciidoc-[0-9]* docbook-xsl-[0-9]* docbook-xml>=4.2 getopt-[0-9]* libxslt>=1.1.8 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libxml2>=2.6.27 libgcrypt>=1.6.0 docbook-xml-[0-9]* libxslt>=1.1.28nb2 xmlto-[0-9]* docbook-xsl>=1.67.0nb1 libaom>=1.0.0 libtheora>=1.0alpha3 lame>=3.93.1nb2 xvidcore>=1.0.0 x264-devel>=20111207 nasm>=2.13.0 x264-devel>=20180224 libvdpau>=0.3 libva>=2.3.0 libdrm>=2.4.15 libvpx>=1.6.0 yasm-[0-9]* libbluray>=0.8.1 libass>=0.14.0nb2 libtheora>=1.0alpha3nb1 lame>=3.98.2nb1 lame>=3.96.1nb4 xvidcore>=1.1.0nb1 libvpx>=1.6.1 rtmpdump>=2.3 gnutls>=3.3.0 mozilla-rootcerts-[0-9]* gmp>=5.0 gmp>=4.2.1 gmp>=6.0 libcfg+>=0.6.2nb1 libtasn1>=4.9 libtasn1>=0.2.7 nettle>=3.4.1 gmp>=5.0.1 nettle>=2.4 p11-kit>=0.23.1 libtasn1>=0.3.0 p11-kit>=0.10 p11-kit>=0.23 libunistring>=0.9.3 libcfg+>=0.6.2nb3 nettle>=3.5.1 libunistring>=0.9.4 gnutls>=3.6.8nb1 curl>=7.12.3 libidn2>=2.0.0 jpeg>=8nb1 SDL2_mixer>=2.0.0nb2 boost-libs>=1.70.0 glibmm>=2.32.1nb1 pango>=1.42.4nb2 glew>=2.1.0 hicolor-icon-theme>=0.9nb1 ffmpeg4>=4.1nb2 rtmpdump>=2.4.0.0.fa8646daeb19dfd12c181f7d19de708d623704c0nb1 curl>=7.65.3nb1 jpeg>=9 boost-headers-1.70.* .

This package requires the following package(s) to run: SDL2_mixer>=2.0.0 flac>=1.1.0nb1 libogg>=1.1 libogg>=1.1.2nb1 libmodplug>=0.7 libvorbis>=1.0.1 mpg123>=1.0.0 opusfile>=0.5 libopus>=1.1 SDL2>=2.0 MesaLib>=3.4.2 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 libXScrnSaver>=1.1.2 xcursor>=1.0 Xfixes>=2.0.0 Xrender>=0.8 Xrender>=0.2 Xrender>=0.8.2 Xfixes>=2.0.1nb2 Xrender>=0.9.0nb1 xcursor>=1.1.1 Xrandr>=0.99 Xrandr>=1.0.1 libusb-compat>=0.1.6rc2 libusb1>=1.0.9 MesaLib>=7.11.2 xcursor>=1.1.2nb1 Xrandr>=1.0.2nb3 flac>=1.1.3nb1 libmodplug>=0.8.8.1 libvorbis>=1.1.0nb1 opusfile>=0.7 SDL2>=2.0.3nb8 boost-libs-1.70.* icu>=3.4 python37>=3.7 libffi>=1.20 libuuid>=2.18 libffi>=3.0.11 python37>=3.7.0 icu>=64.1 glibmm>=2.24.2 perl>=5.0 glib2>=2.60.0 pcre>=3.4nb1 pcre>=8.30nb1 glib2>=2.4.0 libsigc++>=2.9.1 libsigc++>=2.0.3 glib2>=2.34.0 libsigc++>=2.0.17nb1 pango>=1.6.0 Xft2>=2.1.7nb3 fontconfig>=2.2 freetype2>=2.8.1 freetype2>=2.4.5 freetype2>=2.1.3 freetype2>=2.4.11 fontconfig>=2.10.93 fontconfig>=2.1nb2 Xrender>=0.9.0nb2 fontconfig>=2.13.0 Xft2>=2.1 Xft2>=2.1nb2 fontconfig>=2.11.91 fribidi>=0.19.7 fribidi>=0.19.1 glib2>=2.33.12 harfbuzz>=0.9.9 graphite2>=1.2 harfbuzz>=2.1.1 cairo>=1.12.10 lzo>=2.01 fontconfig>=2.2.95 freetype2>=2.1.9 png>=1.2.4 pixman>=0.30.0 pixman>=0.25.2 png>=1.6.0nb1 cairo>=1.0.0nb2 cairo-gobject>=1.10.2 cairo>=1.16.0 glib2>=2.14.0 Xft2>=2.1.7nb7 cairo-gobject>=1.16.0 glew>=1.3.4 hicolor-icon-theme>=0.4 libLLVM34>=3.4.2nb1 ffmpeg4>=4.0 libass>=0.9.12 fribidi>=0.19.0 enca>=1.9 libaom>=1.0.0nb1 libaom>=1.0.0 libtheora>=1.0alpha3 lame>=3.93.1nb2 xvidcore>=1.0.0 x264-devel>=20111207 x264-devel>=20180224 libvdpau>=0.3 libva>=2.3.0 libdrm>=2.4.15 libvpx>=1.6.0 libbluray>=0.8.1 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 libass>=0.14.0nb2 libtheora>=1.0alpha3nb1 lame>=3.98.2nb1 lame>=3.96.1nb4 xvidcore>=1.1.0nb1 libvpx>=1.6.1 rtmpdump>=2.3 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 gnutls>=3.3.0 mozilla-rootcerts-[0-9]* gmp>=5.0 gmp>=4.2.1 gmp>=6.0 libcfg+>=0.6.2nb1 libtasn1>=4.9 libtasn1>=0.2.7 nettle>=3.4.1 gmp>=5.0.1 nettle>=2.4 p11-kit>=0.23.1 mozilla-rootcerts>=1.0.20150804nb1 libtasn1>=0.3.0 p11-kit>=0.10 p11-kit>=0.23 libunistring>=0.9.3 libcfg+>=0.6.2nb3 nettle>=3.5.1 libunistring>=0.9.4 libgcrypt>=1.6.0 gnutls>=3.6.8nb1 curl>=7.12.3 libidn2>=2.0.0 jpeg>=8nb1 SDL2_mixer>=2.0.0nb2 boost-libs>=1.70.0 glibmm>=2.32.1nb1 pango>=1.42.4nb2 glew>=2.1.0 hicolor-icon-theme>=0.9nb1 ffmpeg4>=4.1nb2 rtmpdump>=2.4.0.0.fa8646daeb19dfd12c181f7d19de708d623704c0nb1 curl>=7.65.3nb1 jpeg>=9 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
none

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]