Daemon Power

The NetBSD Packages Collection: meta-pkgs/netbsd-www

Brief description of the package:
Packages required to build the NetBSD.org web site

Please read the file "DESCR" for a longer description, or browse the package's history.

The package is located in the "meta-pkgs/netbsd-www" directory. The current source version of the package is "netbsd-www-1.8nb3". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for meta-pkgs/netbsd-www :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: ImageMagick>=5.5.7.11nb1 jasper>=1.701.0 jpeg>=8nb1 jpeg>=9 jasper>=1.600.0 libltdl>=2.4.2 fontconfig>=2.10.93 freetype2>=2.4.5 freetype2>=2.1.3 freetype2>=2.4.11 fontconfig>=2.1nb2 lcms2>=2.2 tiff>=3.6.1 jbigkit>=2.0 tiff>=4.0.3nb5 openexr>=1.6.1 ilmbase>=1.0.2nb1 ilmbase>=1.0.1 ilmbase>=2.2.0nb1 libwebp>=0.2.0 png>=1.2.4 png>=1.6.0nb1 fftw>=3.0 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 jasper>=1.900.1nb7 libltdl>=2.2.6 fontconfig>=2.10.93nb2 openexr>=2.2.0nb3 fftw>=3.1nb1 libxml2>=2.8.0nb2 x11-links>=0.91 osabi-NetBSD-6.1_STABLE docbook-website>=2.6.0nb1 docbook-simple-[0-9]* docbook-xsl>=1.58 docbook-xml>=4.2 perl>=5.0 docbook-xsl>=1.68.1 dvipsk-[0-9]* tex-dvips>=2013 kpathsea>=3.5.7 kpathsea>=6.0.0 tex-texconfig-[0-9]* kpathsea-[0-9]* libxslt>=1.0.20 libgcrypt>=1.2.0 libgpg-error>=0.6 libgpg-error>=1.10nb1 libxml2>=2.6.27 libgcrypt>=1.6.0 netbsd-doc-print>=1.3 kpathsea>=6.0.0nb2 netbsd-doc>=1.2 opensp>=1.4 xmlto-[0-9]* getopt-[0-9]* docbook-xsl>=1.67.0nb1 bash-[0-9]* libxslt>=1.1.8 libxslt>=1.1.28nb2 openjade-[0-9]* opensp>=1.5.1 opensp>=1.5.2nb1 docbook>=4.0 iso8879>=1986 iso12083>=1993 dsssl-docbook-modular>=1.54 html>=4.0 tidy>=20031002 libxslt>=1.1.0 doxygen>=1.8.7 makeindexk-[0-9]* tex-a4wide>=2010nb1 tex-ntgclass-[0-9]* tex-latex-[0-9]* tex-latexconfig>=2011 tex-latex-fonts-[0-9]* tex-luatex-[0-9]* luatex>=0.60.1 kpathsea>=6.0.1 zziplib>=0.10.82 cairo>=1.0.0nb2 MesaLib>=3.4.2 libXdamage>=1.0.3 Xfixes>=2.0.0 fixesproto>=3.0.0<5 xextproto>=7.0 inputproto>=1.4 xproto>=7.0.9 Xfixes>=2.0.1nb2 damageproto>=1.1.0 libdrm>=2.4.24 libdrm>=2.4.15 glproto>=1.4.11 glproto>=1.4.6 python27>=2.7 libffi>=1.20 libffi>=3.0.11 readline>=2.2 readline>=6.0 dri2proto>=2.1 dri2proto>=2.0 xf86driproto>=2.0.4 xf86driproto>=2.0.3 xf86vidmodeproto>=2.3 python27>=2.7.1nb2 Xrender>=0.2 renderproto>=0.9.3nb1 renderproto>=0.9 Xrender>=0.8.2 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 xcb-proto>=1.11 xcb-proto>=1.4 lzo>=2.01 fontconfig>=2.2.95 freetype2>=2.1.9 pixman>=0.22.0 pixman>=0.25.2 MesaLib>=7.11.2 Xrender>=0.9.0nb1 poppler>=0.5.1 zziplib>=0.13.56 cairo>=1.12.16nb2 poppler>=0.26.0 poppler-includes>=0.22.2 poppler-includes>=0.26.0 tex-etex-[0-9]* tex-plain-[0-9]* tex-amsfonts-[0-9]* tex-tetex>=3.0.25424 dialog>=1.0 tex-kpathsea>=2012nb1 tex-texconfig>=2013 tex-texlive.infra-[0-9]* tex-cm-[0-9]* tex-hyphen-base-[0-9]* tex-misc-[0-9]* tex-pdftex-[0-9]* tex-dvips-[0-9]* tex-kpathsea-[0-9]* web2c-[0-9]* kpathsea>=6.1.1 ptexenc>=1.3.1 ptexenc>=1.1.1 tex-tetex>=3.0.27774 tex-plain>=3.14159265.12854 tex-latex-bin-[0-9]* tex-latex>=2012 tex-cm-super-[0-9]* tex-ec-[0-9]* tex-epstopdf-[0-9]* ghostscript>=6.01 ghostscript-gpl-[0-9]* ghostscript-fonts>=6.0 libpaper>=1.1.22 tex-rsfs-[0-9]* tex-colortbl-[0-9]* tex-graphics-[0-9]* tex-pdftex-def-[0-9]* tex-tools-[0-9]* tex-graphics>=1.0onb1 tex-fancyhdr-[0-9]* tex-float-[0-9]* tex-geometry-[0-9]* tex-oberdiek-[0-9]* tex-amsmath-[0-9]* tex-etex-pkg-[0-9]* tex-ifluatex-[0-9]* tex-ifxetex-[0-9]* tex-hyperref-[0-9]* tex-ifxetex>=0.6 tex-latex-bin>=2009nb1 tex-oberdiek>=2009nb1 tex-url>=3.2 tex-listings-[0-9]* tex-algorithms-[0-9]* tex-fancyvrb-[0-9]* tex-multirow-[0-9]* tex-natbib-[0-9]* tex-psnfss>=9.2anb2 tex-avantgar-[0-9]* tex-bookman-[0-9]* tex-charter-[0-9]* tex-courier-[0-9]* tex-fpl-[0-9]* tex-helvetic-[0-9]* tex-mathpazo-[0-9]* tex-ncntrsbk-[0-9]* tex-palatino-[0-9]* tex-symbol-[0-9]* tex-times-[0-9]* tex-zapfchan-[0-9]* tex-zapfding-[0-9]* tex-pspicture-[0-9]* tex-sectsty-[0-9]* tex-tocloft-[0-9]* tex-wasysym-[0-9]* tex-wasy-[0-9]* tex-xcolor-[0-9]* tex-xtab-[0-9]* graphviz>=2.12nb1 pango>=1.6.0 Xft2>=2.1.7nb3 fontconfig>=2.2 Xrender>=0.9.0nb2 Xft2>=2.1 Xft2>=2.1nb2 fontconfig>=2.10.91 Xrender>=0.8 glib2>=2.32.1 libelf>=0.8.5 pcre>=8.31 pcre>=3.4nb1 pcre>=8.30nb1 glib2>=2.4.0 harfbuzz>=0.9.9 icu>=3.4 icu>=53.1 glib2>=2.34.0 harfbuzz>=0.9.4 cairo>=1.12.10 cairo-gobject>=1.10.2 Xft2>=2.1.7nb6 harfbuzz>=0.9.17nb2 cairo-gobject>=1.12.16nb1 help2man-[0-9]* p5-gettext>=1.01 perl>=5.20.0 perl<5.22.0 gobject-introspection>=0.6.14nb1 py27-cElementTree-[0-9]* glib2>=2.36.0 libffi>=3.0.0 gobject-introspection>=1.34.0 gtk2+>=2.4.0 py27-expat-[0-9]* shared-mime-info>=0.15 atk>=1.30.0 glib2>=2.31.2 atk>=1.11.4 glib2>=2.28.0 gdk-pixbuf2>=2.22.0 glib2>=2.37.2 xcursor>=1.0 xcursor>=1.1.1 Xft2>=2.1.2nb2 libXi>=1.3.0 inputproto>=2.3 xextproto>=7.0.3 xproto>=7.0.13 libXi>=1.0.0 Xrandr>=0.99 randrproto>=1.2.0 randrproto>=1.0 Xrandr>=1.0.1 libXcomposite>=0.3.1 compositeproto>=0.4 compositeproto>=0.3.1 pango>=1.20.0 cairo>=1.6.0 shared-mime-info>=1.0nb1 atk>=2.6.0 gdk-pixbuf2>=2.26.5nb2 xcursor>=1.1.2nb1 Xrandr>=1.0.2nb3 pango>=1.36.3nb1 gobject-introspection>=0.9.3 gd>=2.0.15nb1 libvpx>=0.9.2 yasm-[0-9]* libvpx>=1.0.0 lua52>=5.2.0<5.3 tk>=8.5.7 tcl>=8.5.7 tcl>=8.6.1nb1 gtk2+>=2.24.22nb3 gd>=2.1.0 tk>=8.6.1 swig>=1.3.24<2.0 swig>=1.3.31<2.0 graphviz>=2.26.3 graphviz>=2.26.3nb26 tex-epsf-[0-9]* tex-babel-[0-9]* tex-carlisle>=2010 tex-latex>=2009 tex-cyrillic-[0-9]* tex-german-[0-9]* tex-hyphen-german-[0-9]* tex-hyph-utf8-[0-9]* tex-hyphen-base>=2010nb1 tex-tetex>=3.0.27774nb1 tex-hyphen-russian-[0-9]* tex-ruhyphen>=1.6 tex-jadetex>=2.20nb1 tex-lambda-[0-9]* tex-marvosym-[0-9]* tex-passivetex>=1.25nb2 tex-psnfss-[0-9]* tex-rotating-[0-9]* tex-tipa-[0-9]* tex-xmltex-[0-9]* tex-latexconfig-[0-9]* tex-ulem-[0-9]* tex-lh-[0-9]* tex-ec>=1.0 tex-metafont-[0-9]* tex-picinpar-[0-9]* tex-pslatex-[0-9]* tex-ly1-[0-9]* opensp>=1.1 psutils>=1.17 w3m>=0.4 boehm-gc>=7.2 libatomic_ops>=7.4.0<2000 boehm-gc>=7.4 xplanet>=1.2.0nb3 giflib>=5.1.0 netpbm>=10.11.6 netpbm>=10.35.80nb6 .

This package requires the following package(s) to run: ImageMagick>=5.5.7.11nb1 jasper>=1.701.0 jpeg>=8nb1 jpeg>=9 jasper>=1.600.0 libltdl>=2.4.2 fontconfig>=2.10.93 freetype2>=2.4.5 freetype2>=2.1.3 freetype2>=2.4.11 fontconfig>=2.1nb2 lcms2>=2.2 tiff>=3.6.1 jbigkit>=2.0 tiff>=4.0.3nb5 openexr>=1.6.1 ilmbase>=1.0.2nb1 ilmbase>=1.0.1 ilmbase>=2.2.0nb1 libwebp>=0.2.0 png>=1.2.4 png>=1.6.0nb1 fftw>=3.0 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 jasper>=1.900.1nb7 libltdl>=2.2.6 fontconfig>=2.10.93nb2 openexr>=2.2.0nb3 fftw>=3.1nb1 libxml2>=2.8.0nb2 docbook-website>=2.6.0nb1 docbook-simple-[0-9]* docbook-xsl>=1.58 docbook-xml>=4.2 perl>=5.0 docbook-xsl>=1.68.1 dvipsk-[0-9]* tex-dvips>=2013 kpathsea>=3.5.7 kpathsea>=6.0.0 libxslt>=1.0.20 libgcrypt>=1.2.0 libgpg-error>=0.6 libgpg-error>=1.10nb1 libxml2>=2.6.27 libgcrypt>=1.6.0 netbsd-doc-print>=1.3 kpathsea>=6.0.0nb2 netbsd-doc>=1.2 opensp>=1.4 openjade-[0-9]* opensp>=1.5.1 opensp>=1.5.2nb1 docbook>=4.0 iso8879>=1986 iso12083>=1993 dsssl-docbook-modular>=1.54 html>=4.0 tidy>=20031002 tex-babel-[0-9]* tex-carlisle>=2010 tex-latex-bin-[0-9]* tex-latex>=2012 tex-latexconfig>=2011 tex-latex-fonts-[0-9]* tex-luatex-[0-9]* luatex>=0.60.1 kpathsea>=6.0.1 zziplib>=0.10.82 cairo>=1.0.0nb2 MesaLib>=3.4.2 libXdamage>=1.0.3 Xfixes>=2.0.0 Xfixes>=2.0.1nb2 libdrm>=2.4.24 libdrm>=2.4.15 Xrender>=0.2 Xrender>=0.8.2 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 lzo>=2.01 fontconfig>=2.2.95 freetype2>=2.1.9 pixman>=0.22.0 pixman>=0.25.2 MesaLib>=7.11.2 Xrender>=0.9.0nb1 poppler>=0.5.1 zziplib>=0.13.56 cairo>=1.12.16nb2 poppler>=0.26.0 tex-etex-[0-9]* tex-plain-[0-9]* tex-amsfonts-[0-9]* tex-tetex>=3.0.25424 dialog>=1.0 kpathsea-[0-9]* tex-kpathsea>=2012nb1 tex-texconfig>=2013 tex-texlive.infra-[0-9]* tex-cm-[0-9]* tex-hyphen-base-[0-9]* tex-misc-[0-9]* tex-pdftex-[0-9]* tex-dvips-[0-9]* tex-kpathsea-[0-9]* web2c-[0-9]* kpathsea>=6.1.1 ptexenc>=1.3.1 ptexenc>=1.1.1 tex-tetex>=3.0.27774 tex-plain>=3.14159265.12854 tex-graphics-[0-9]* tex-pdftex-def-[0-9]* tex-latex-[0-9]* tex-tools-[0-9]* tex-graphics>=1.0onb1 tex-latex>=2009 tex-latex-bin>=2009nb1 tex-cyrillic-[0-9]* tex-epsf-[0-9]* tex-german-[0-9]* tex-hyphen-german-[0-9]* tex-hyph-utf8-[0-9]* tex-hyphen-base>=2010nb1 tex-tetex>=3.0.27774nb1 tex-hyphen-russian-[0-9]* tex-ruhyphen>=1.6 tex-jadetex>=2.20nb1 tex-colortbl-[0-9]* tex-ec-[0-9]* tex-fancyhdr-[0-9]* tex-hyperref-[0-9]* tex-ifxetex>=0.6 tex-oberdiek>=2009nb1 tex-amsmath-[0-9]* tex-etex-pkg-[0-9]* tex-ifluatex-[0-9]* tex-ifxetex-[0-9]* tex-url>=3.2 tex-lambda-[0-9]* tex-marvosym-[0-9]* tex-passivetex>=1.25nb2 tex-psnfss-[0-9]* tex-avantgar-[0-9]* tex-bookman-[0-9]* tex-charter-[0-9]* tex-courier-[0-9]* tex-fpl-[0-9]* tex-helvetic-[0-9]* tex-mathpazo-[0-9]* tex-ncntrsbk-[0-9]* tex-palatino-[0-9]* tex-symbol-[0-9]* tex-times-[0-9]* tex-zapfchan-[0-9]* tex-zapfding-[0-9]* tex-rotating-[0-9]* tex-tipa-[0-9]* tex-xmltex-[0-9]* tex-latexconfig-[0-9]* tex-ulem-[0-9]* tex-lh-[0-9]* tex-ec>=1.0 tex-metafont-[0-9]* tex-picinpar-[0-9]* tex-pslatex-[0-9]* tex-ly1-[0-9]* ghostscript>=6.01 ghostscript-gpl-[0-9]* ghostscript-fonts>=6.0 libpaper>=1.1.22 opensp>=1.1 psutils>=1.17 w3m>=0.4 boehm-gc>=7.2 libatomic_ops>=7.4.0<2000 boehm-gc>=7.4 xplanet>=1.2.0nb3 pango>=1.6.0 Xft2>=2.1.7nb3 fontconfig>=2.2 Xrender>=0.9.0nb2 Xft2>=2.1 Xft2>=2.1nb2 fontconfig>=2.10.91 Xrender>=0.8 glib2>=2.32.1 libelf>=0.8.5 pcre>=8.31 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.0.11 glib2>=2.4.0 harfbuzz>=0.9.9 icu>=3.4 icu>=53.1 glib2>=2.34.0 harfbuzz>=0.9.4 cairo>=1.12.10 cairo-gobject>=1.10.2 Xft2>=2.1.7nb6 harfbuzz>=0.9.17nb2 cairo-gobject>=1.12.16nb1 giflib>=5.1.0 netpbm>=10.11.6 pango>=1.36.3nb1 netpbm>=10.35.80nb6 .

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
alpha:netbsd-www-1.5.tgz(NetBSD 5.1)
arm:netbsd-www-1.7nb1.tgz(NetBSD 6.0)
i386:netbsd-www-1.8nb2.tgz(NetBSD 5.1)
i386:netbsd-www-1.8nb1.tgz(NetBSD 5.1.2)
i386:netbsd-www-1.8nb3.tgz(NetBSD 6.0)
i386:netbsd-www-1.8nb2.tgz(NetBSD 6.0)
i386:netbsd-www-1.8nb2.tgz(NetBSD 6.0)
i386:netbsd-www-1.8nb2.tgz(NetBSD 6.0)
i386:netbsd-www-1.8nb2.tgz(NetBSD 6.0)
powerpc:netbsd-www-1.7.tgz(NetBSD 5.1)
powerpc:netbsd-www-1.7.tgz(NetBSD 5.1)
powerpc:netbsd-www-1.7nb1.tgz(NetBSD 5.2)
sparc64:netbsd-www-1.8nb2.tgz(NetBSD 6.1_STABLE)
x86_64:netbsd-www-1.8.tgz(NetBSD 5.1)
x86_64:netbsd-www-1.8nb2.tgz(NetBSD 5.1)
x86_64:netbsd-www-1.8.tgz(NetBSD 6.0)
x86_64:netbsd-www-1.8nb2.tgz(NetBSD 6.0)
x86_64:netbsd-www-1.8nb2.tgz(NetBSD 6.0)
x86_64:netbsd-www-1.8nb2.tgz(NetBSD 6.0)
x86_64:netbsd-www-1.8nb2.tgz(NetBSD 6.0)
x86_64:netbsd-www-1.8nb3.tgz(NetBSD 6.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]