Daemon Power

The NetBSD Packages Collection: math/py-scikit-image

Brief description of the package:
Image processing routines for SciPy

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://scikit-image.org/.

Please note that this package has a modified-bsd license.

The package is located in the "math/py-scikit-image" directory. The current source version of the package is "py37-scikit-image-0.15.0". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for math/py-scikit-image :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: py37-Pillow>=4.3.0 py37-olefile-[0-9]* py37-setuptools>=0.8 py37-expat-[0-9]* python37>=3.7 libffi>=1.20 cwrappers>=20150314 libuuid>=2.18 openssl>=1.1.1 libffi>=3.3nb1 openssl>=1.1.1dnb2 readline>=2.2 readline>=6.0 python37>=3.7.0 python37>=3.7.7 freetype2>=2.8.1 freetype2>=2.1.3 lcms2>=2.2 jpeg>=8nb1 tiff>=3.6.1 jbigkit>=2.0 jpeg>=9 tiff>=4.0.3nb5 libimagequant>=2.8.2 libwebp>=0.2.0 giflib>=5.2.1 png>=1.2.4 png>=1.6.0nb1 openjpeg>=2.1.0 libwebp>=0.6.0 py37-test-runner-[0-9]* py37-setuptools_scm-[0-9]* py37-toml-[0-9]* py37-test>=2.8 py37-atomicwrites>=1.0 py37-attrs>=17.4.0 py37-packaging-[0-9]* py37-pyparsing>=2.0.2 py37-six-[0-9]* py37-pluggy>=0.12 py37-importlib-metadata>=0.12 py37-zipp-[0-9]* py37-setuptools_scm>=1.15.0 py37-py>=1.5.0 py37-six>=1.10.0 py37-wcwidth-[0-9]* py37-more-itertools-[0-9]* py37-imageio>=2.0.1 py37-Pillow-[0-9]* py37-numpy-[0-9]* gcc5>=3.0 gsed>=3.0.2 py37-cython>=0.29.2 py37-cython>=0.12.1 blas>=1.0nb2 gcc5>=5.1 lapack>=3.1.1 blas>=1.0nb3 py37-pywavelets>=0.5.2 py37-numpy>=1.0 py37-networkx>=2.0 py37-decorator>=4.3.0 py37-six>=1.9.0 .

This package requires the following package(s) to run: py37-Pillow>=4.3.0 py37-olefile-[0-9]* py37-setuptools>=0.8 py37-expat-[0-9]* python37>=3.7 libffi>=1.20 libuuid>=2.18 openssl>=1.1.1 libffi>=3.3nb1 openssl>=1.1.1dnb2 python37>=3.7.0 python37>=3.7.7 freetype2>=2.8.1 freetype2>=2.1.3 lcms2>=2.2 jpeg>=8nb1 tiff>=3.6.1 jbigkit>=2.0 jpeg>=9 tiff>=4.0.3nb5 libimagequant>=2.8.2 libwebp>=0.2.0 giflib>=5.2.1 png>=1.2.4 png>=1.6.0nb1 openjpeg>=2.1.0 libwebp>=0.6.0 py37-imageio>=2.0.1 py37-Pillow-[0-9]* py37-numpy-[0-9]* gcc5>=3.0 gsed>=3.0.2 py37-cython>=0.29.2 py37-cython>=0.12.1 blas>=1.0nb2 gcc5>=5.1 lapack>=3.1.1 blas>=1.0nb3 py37-pywavelets>=0.5.2 py37-numpy>=1.0 py37-networkx>=2.0 py37-decorator>=4.3.0 py37-six>=1.9.0 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
i386:py27-scikit-image-0.14.1.tgz(NetBSD 7.0)
i386:py34-scikit-image-0.14.1.tgz(NetBSD 7.0)
i386:py36-scikit-image-0.14.1.tgz(NetBSD 7.0)
i386:py37-scikit-image-0.14.1.tgz(NetBSD 7.0)
i386:py27-scikit-image-0.14.1.tgz(NetBSD 7.1)
i386:py34-scikit-image-0.14.1.tgz(NetBSD 7.1)
i386:py36-scikit-image-0.14.1.tgz(NetBSD 7.1)
i386:py37-scikit-image-0.14.1.tgz(NetBSD 7.1)
i386:py27-scikit-image-0.14.1.tgz(NetBSD 8.0)
i386:py34-scikit-image-0.14.1.tgz(NetBSD 8.0)
i386:py35-scikit-image-0.14.1.tgz(NetBSD 8.0)
i386:py36-scikit-image-0.14.1.tgz(NetBSD 8.0)
i386:py37-scikit-image-0.14.1.tgz(NetBSD 8.0)
i386:py36-scikit-image-0.15.0.tgz(NetBSD 8.0)
i386:py37-scikit-image-0.15.0.tgz(NetBSD 8.0)
i386:py36-scikit-image-0.15.0.tgz(NetBSD 8.0)
i386:py37-scikit-image-0.15.0.tgz(NetBSD 8.0)
i386:py38-scikit-image-0.15.0.tgz(NetBSD 8.0)
powerpc:py36-scikit-image-0.15.0.tgz(NetBSD 8.0)
powerpc:py37-scikit-image-0.15.0.tgz(NetBSD 8.0)
powerpc:py36-scikit-image-0.15.0.tgz(NetBSD 9.0)
powerpc:py37-scikit-image-0.15.0.tgz(NetBSD 9.0)
sparc64:py36-scikit-image-0.15.0.tgz(NetBSD 8.0)
sparc64:py37-scikit-image-0.15.0.tgz(NetBSD 8.0)
x86_64:py36-scikit-image-0.15.0.tgz(NetBSD 9.0)
x86_64:py37-scikit-image-0.15.0.tgz(NetBSD 9.0)
x86_64:py38-scikit-image-0.15.0.tgz(NetBSD 9.0)
x86_64:py27-scikit-image-0.14.1.tgz(NetBSD 7.0)
x86_64:py34-scikit-image-0.14.1.tgz(NetBSD 7.0)
x86_64:py36-scikit-image-0.14.1.tgz(NetBSD 7.0)
x86_64:py37-scikit-image-0.14.1.tgz(NetBSD 7.0)
x86_64:py27-scikit-image-0.14.1.tgz(NetBSD 7.1)
x86_64:py34-scikit-image-0.14.1.tgz(NetBSD 7.1)
x86_64:py36-scikit-image-0.14.1.tgz(NetBSD 7.1)
x86_64:py37-scikit-image-0.14.1.tgz(NetBSD 7.1)
x86_64:py36-scikit-image-0.15.0.tgz(NetBSD 8.0)
x86_64:py37-scikit-image-0.15.0.tgz(NetBSD 8.0)
x86_64:py38-scikit-image-0.15.0.tgz(NetBSD 8.0)
x86_64:py27-scikit-image-0.14.1.tgz(NetBSD 8.0)
x86_64:py34-scikit-image-0.14.1.tgz(NetBSD 8.0)
x86_64:py35-scikit-image-0.14.1.tgz(NetBSD 8.0)
x86_64:py36-scikit-image-0.14.1.tgz(NetBSD 8.0)
x86_64:py37-scikit-image-0.14.1.tgz(NetBSD 8.0)
x86_64:py36-scikit-image-0.15.0.tgz(NetBSD 8.0)
x86_64:py37-scikit-image-0.15.0.tgz(NetBSD 8.0)
x86_64:py36-scikit-image-0.15.0.tgz(NetBSD 9.0)
x86_64:py37-scikit-image-0.15.0.tgz(NetBSD 9.0)
x86_64:py38-scikit-image-0.15.0.tgz(NetBSD 9.0)
x86_64:py36-scikit-image-0.15.0.tgz(NetBSD 9.0)
x86_64:py37-scikit-image-0.15.0.tgz(NetBSD 9.0)
x86_64:py38-scikit-image-0.15.0.tgz(NetBSD 9.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]