math/R-nimble - The NetBSD Packages Collection

MCMC, Particle Filtering, and Programmable Hierarchical Modeling

A system for writing hierarchical statistical models largely
compatible with 'BUGS' and 'JAGS', writing nimbleFunctions to operate
models and do basic R-style math, and compiling both models and
nimbleFunctions via custom- generated C++. 'NIMBLE' includes default
methods for MCMC, particle filtering, Monte Carlo Expectation
Maximization, and some other tools. The nimbleFunction system makes it
easy to do things like implement new MCMC samplers from R, customize
the assignment of samplers to different parts of a model from R, and
compile the new samplers automatically via C++ alongside the samplers
'NIMBLE' provides. 'NIMBLE' extends the 'BUGS'/'JAGS' language by
making it extensible: New distributions and functions can be added,
including as calls to external compiled code. Although most people
think of MCMC as the main goal of the 'BUGS'/'JAGS' language for
writing models, one can use 'NIMBLE' for writing arbitrary other kinds
of model-generic algorithms as well. A full User Manual is available
at .

Build dependencies

pkgtools/cwrappers

Runtime dependencies

devel/R-R6 math/R-coda math/R-igraph math/R lang/gcc7 math/R lang/gcc7

Binary packages

OSArchitectureVersion
NetBSD 8.0i386R-nimble-0.9.0.tgz
NetBSD 8.0i386R-nimble-0.9.0.tgz
NetBSD 8.0i386R-nimble-0.9.0.tgz
NetBSD 8.0x86_64R-nimble-0.9.0.tgz
NetBSD 8.0x86_64R-nimble-0.9.0.tgz
NetBSD 9.0aarch64R-nimble-0.9.0.tgz
NetBSD 9.0aarch64R-nimble-0.9.0.tgz
NetBSD 9.0aarch64R-nimble-0.9.0.tgz
NetBSD 9.0alphaR-nimble-0.9.0.tgz
NetBSD 9.0alphaR-nimble-0.9.0.tgz
NetBSD 9.0alphaR-nimble-0.9.0.tgz
NetBSD 9.0x86_64R-nimble-0.9.0.tgz
NetBSD 9.0x86_64R-nimble-0.9.0.tgz
NetBSD 9.0x86_64R-nimble-0.9.0.tgz
NetBSD 9.0x86_64R-nimble-0.9.0.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.