Daemon Power

The NetBSD Packages Collection: mail/notmuch

Brief description of the package:
Mail indexer

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://notmuchmail.org/.

Please note that this package has a gnu-gpl-v3 license.

The package is located in the "mail/notmuch" directory. The current source version of the package is "notmuch-0.29.2". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for mail/notmuch :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: gnupg2>=2.2.0 pinentry-[0-9]* libassuan>=2.1.0 libgpg-error>=0.6 cwrappers>=20150314 libgpg-error>=1.17 libgpg-error>=1.10nb1 libassuan>=2.4.2 libgpg-error>=1.16 libksba>=0.9.7 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=1.2 libgcrypt>=1.6.0 libksba>=1.3.0nb1 gnutls>=3.3.0 mozilla-rootcerts-[0-9]* lzo>=2.01 gmp>=5.0 gmp>=4.2.1 gmp>=6.0 libcfg+>=0.6.2nb1 libtasn1>=4.9 libtasn1>=0.2.7 nettle>=3.4.1 gmp>=5.0.1 nettle>=2.4 p11-kit>=0.23.1 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 libtasn1>=0.3.0 p11-kit>=0.10 p11-kit>=0.23 libunistring>=0.9.3 libcfg+>=0.6.2nb3 nettle>=3.5.1 libunistring>=0.9.4 libusb1>=1.0.9 npth>=1.2 npth>=1.1 readline>=2.2 libgcrypt>=1.7 libgpg-error>=1.28 libassuan>=2.5.1 libksba>=1.3.4 gnutls>=3.6.8nb1 readline>=6.0 desktop-file-utils>=0.8 glib2>=2.4.0 pcre>=3.4nb1 pcre>=8.30nb1 meson-[0-9]* ninja-build-[0-9]* python37>=3.7 libuuid>=2.18 python37>=3.7.0 re2c>=0.11.3 py37-setuptools>=0.8 py37-expat-[0-9]* python37>=3.7.5 glib2>=2.34.0 gmime3>=3.0.3 gpgme>=0.9.0 libassuan>=2.0.2 gpgme>=1.8.0nb1 gmime3>=3.0 xapian>=1.4 xapian>=1.0.7 talloc>=2.1.0 libxslt-[0-9]* libxml2>=2.6.27 xmlcatmgr>=2.0beta1 libxml2>=2.6.2 libxml2>=2.8.0nb2 docbook-xml-[0-9]* docbook-xsl-[0-9]* docbook-xml>=4.2 perl>=5.0 desktop-file-utils>=0.10nb1 xapian>=1.4.1 py37-sphinx-[0-9]* py37-alabaster>=0.7 py37-pygments>=0.8 py37-babel>=1.3 py37-pytz>=2015.7 py37-docutils>=0.12 py37-expat>=0 py37-roman>=1.4 py37-imagesize-[0-9]* py37-jinja2>=2.3 py37-babel>=0.8 py37-markupsafe>=0.23 py37-packaging-[0-9]* py37-pyparsing>=2.0.2 py37-six-[0-9]* py37-pygments>=2.0 py37-pytz-[0-9]* py37-requests>=2.5.0 py37-OpenSSL>=0.14 py37-cryptography>=2.3 py37-asn1crypto>=0.21.0 py37-cffi>=1.11.4 py37-cparser-[0-9]* py37-cparser>=2.10 py37-idna>=2.1 py37-six>=1.4.1 py37-six>=1.5.2 py37-certifi>=2017.4.17 py37-chardet>=3.0.2 py37-cryptography>=1.3.4 py37-idna>=2.5 py37-urllib3>=1.12.1 py37-Socks>=1.6.0 py37-certifi-[0-9]* py37-idna>=2.0.0 py37-setuptools-[0-9]* py37-snowballstemmer>=1.1 py37-sphinxcontrib-applehelp-[0-9]* py37-sphinxcontrib-devhelp-[0-9]* py37-sphinxcontrib-jsmath-[0-9]* py37-sphinxcontrib-htmlhelp-[0-9]* py37-sphinxcontrib-serializinghtml-[0-9]* py37-sphinxcontrib-qthelp-[0-9]* py37-six>=1.5 .

This package requires the following package(s) to run: gnupg2>=2.2.0 pinentry-[0-9]* libassuan>=2.1.0 libgpg-error>=0.6 libgpg-error>=1.17 libgpg-error>=1.10nb1 libassuan>=2.4.2 libgpg-error>=1.16 libksba>=0.9.7 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=1.2 libgcrypt>=1.6.0 libksba>=1.3.0nb1 gnutls>=3.3.0 mozilla-rootcerts-[0-9]* lzo>=2.01 gmp>=5.0 gmp>=4.2.1 gmp>=6.0 libcfg+>=0.6.2nb1 libtasn1>=4.9 libtasn1>=0.2.7 nettle>=3.4.1 gmp>=5.0.1 nettle>=2.4 p11-kit>=0.23.1 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 libtasn1>=0.3.0 p11-kit>=0.10 p11-kit>=0.23 libunistring>=0.9.3 libcfg+>=0.6.2nb3 nettle>=3.5.1 libunistring>=0.9.4 libusb1>=1.0.9 npth>=1.2 npth>=1.1 readline>=2.2 libgcrypt>=1.7 libgpg-error>=1.28 libassuan>=2.5.1 libksba>=1.3.4 gnutls>=3.6.8nb1 readline>=6.0 desktop-file-utils>=0.8 glib2>=2.4.0 pcre>=3.4nb1 pcre>=8.30nb1 glib2>=2.34.0 python37>=3.7 libuuid>=2.18 python37>=3.7.0 gmime3>=3.0.3 gpgme>=0.9.0 libassuan>=2.0.2 gpgme>=1.8.0nb1 gmime3>=3.0 xapian>=1.4 xapian>=1.0.7 talloc>=2.1.0 desktop-file-utils>=0.10nb1 xapian>=1.4.1 .

This package supports the following build-time options:

doc
Include the documentation.
notmuch-emacs
Install emacs support files for notmuch.

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
alpha:notmuch-0.28.3.tgz(NetBSD 8.0)
alpha:notmuch-0.28.tgz(NetBSD 8.0)
alpha:notmuch-0.29.1.tgz(NetBSD 8.0)
alpha:notmuch-0.29.1.tgz(NetBSD 8.0)
earm:notmuch-0.28.tgz(NetBSD 8.0)
earmv7hf:notmuch-0.21.tgz(NetBSD 7.0)
i386:notmuch-0.27.tgz(NetBSD 7.0)
i386:notmuch-0.27.tgz(NetBSD 7.0)
i386:notmuch-0.28.tgz(NetBSD 7.0)
i386:notmuch-0.28.3.tgz(NetBSD 7.0)
i386:notmuch-0.27.tgz(NetBSD 7.1)
i386:notmuch-0.27.tgz(NetBSD 7.1)
i386:notmuch-0.28.tgz(NetBSD 7.1)
i386:notmuch-0.28.3.tgz(NetBSD 7.1)
i386:notmuch-0.27.tgz(NetBSD 8.0)
i386:notmuch-0.27.tgz(NetBSD 8.0)
i386:notmuch-0.28.tgz(NetBSD 8.0)
i386:notmuch-0.28.3.tgz(NetBSD 8.0)
sparc64:notmuch-0.27.tgz(NetBSD 7.1)
x86_64:notmuch-0.27.tgz(NetBSD 7.0)
x86_64:notmuch-0.27.tgz(NetBSD 7.0)
x86_64:notmuch-0.28.tgz(NetBSD 7.0)
x86_64:notmuch-0.28.3.tgz(NetBSD 7.0)
x86_64:notmuch-0.27.tgz(NetBSD 7.1)
x86_64:notmuch-0.27.tgz(NetBSD 7.1)
x86_64:notmuch-0.28.tgz(NetBSD 7.1)
x86_64:notmuch-0.28.3.tgz(NetBSD 7.1)
x86_64:notmuch-0.27.tgz(NetBSD 8.0)
x86_64:notmuch-0.27.tgz(NetBSD 8.0)
x86_64:notmuch-0.28.tgz(NetBSD 8.0)
x86_64:notmuch-0.28.3.tgz(NetBSD 8.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]