lang/vslisp - The NetBSD Packages Collection

Embeddable Lisp library and standalone interpreter

VSLisp is an embedded Lisp library and standalone interpreter. It's
very small, and runs on many platforms. It was developed as a graphics
scripting language for VMS, but now its development goes under Unix,
and old Graph library is not supported now.

VSLisp is not Scheme or Common Lisp compatible. Surely, you can
customize it to look like one of them, but by default VSLisp is a yet
another Lisp dialect, and to work with it you'll need to understand
the difference.

VSLisp is distributed under the terms of the GNU General Public License
version 2.

Build dependencies

devel/libtool-base pkgtools/mktools pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64vslisp-4.0.1nb3.tgz
NetBSD 10.0aarch64vslisp-4.0.1nb3.tgz
NetBSD 10.0earmv6hfvslisp-4.0.1nb3.tgz
NetBSD 10.0earmv6hfvslisp-4.0.1nb3.tgz
NetBSD 10.0earmv7hfvslisp-4.0.1nb3.tgz
NetBSD 10.0earmv7hfvslisp-4.0.1nb3.tgz
NetBSD 10.0i386vslisp-4.0.1nb3.tgz
NetBSD 10.0powerpcvslisp-4.0.1nb3.tgz
NetBSD 10.0powerpcvslisp-4.0.1nb3.tgz
NetBSD 10.0x86_64vslisp-4.0.1nb3.tgz
NetBSD 10.0x86_64vslisp-4.0.1nb3.tgz
NetBSD 8.0earmv7hfvslisp-4.0.1nb3.tgz
NetBSD 8.0i386vslisp-4.0.1nb3.tgz
NetBSD 8.0i386vslisp-4.0.1nb3.tgz
NetBSD 8.0powerpcvslisp-4.0.1nb3.tgz
NetBSD 8.0powerpcvslisp-4.0.1nb3.tgz
NetBSD 8.0powerpcvslisp-4.0.1nb3.tgz
NetBSD 8.0x86_64vslisp-4.0.1nb3.tgz
NetBSD 8.0x86_64vslisp-4.0.1nb3.tgz
NetBSD 9.0aarch64vslisp-4.0.1nb3.tgz
NetBSD 9.0aarch64vslisp-4.0.1nb3.tgz
NetBSD 9.0aarch64vslisp-4.0.1nb3.tgz
NetBSD 9.0alphavslisp-4.0.1nb3.tgz
NetBSD 9.0alphavslisp-4.0.1nb3.tgz
NetBSD 9.0alphavslisp-4.0.1nb3.tgz
NetBSD 9.0alphavslisp-4.0.1nb3.tgz
NetBSD 9.0alphavslisp-4.0.1nb3.tgz
NetBSD 9.0earmvslisp-4.0.1nb3.tgz
NetBSD 9.0earmv6hfvslisp-4.0.1nb3.tgz
NetBSD 9.0earmv6hfvslisp-4.0.1nb3.tgz
NetBSD 9.0earmv6hfvslisp-4.0.1nb3.tgz
NetBSD 9.0earmv7hfvslisp-4.0.1nb3.tgz
NetBSD 9.0earmv7hfvslisp-4.0.1nb3.tgz
NetBSD 9.0earmv7hfvslisp-4.0.1nb3.tgz
NetBSD 9.0i386vslisp-4.0.1nb3.tgz
NetBSD 9.0i386vslisp-4.0.1nb3.tgz
NetBSD 9.0i386vslisp-4.0.1nb3.tgz
NetBSD 9.0m68kvslisp-4.0.1nb3.tgz
NetBSD 9.0m68kvslisp-4.0.1nb3.tgz
NetBSD 9.0m68kvslisp-4.0.1nb3.tgz
NetBSD 9.0m68kvslisp-4.0.1nb3.tgz
NetBSD 9.0mips64ebvslisp-4.0.1nb3.tgz
NetBSD 9.0mips64ebvslisp-4.0.1nb3.tgz
NetBSD 9.0mips64ebvslisp-4.0.1nb3.tgz
NetBSD 9.0mips64ebvslisp-4.0.1nb3.tgz
NetBSD 9.0mips64ebvslisp-4.0.1nb3.tgz
NetBSD 9.0powerpcvslisp-4.0.1nb3.tgz
NetBSD 9.0powerpcvslisp-4.0.1nb3.tgz
NetBSD 9.0powerpcvslisp-4.0.1nb3.tgz
NetBSD 9.0vaxvslisp-4.0.1nb3.tgz
NetBSD 9.0x86_64vslisp-4.0.1nb3.tgz
NetBSD 9.0x86_64vslisp-4.0.1nb3.tgz
NetBSD 9.0x86_64vslisp-4.0.1nb3.tgz
NetBSD 9.0x86_64vslisp-4.0.1nb3.tgz
NetBSD 9.0x86_64vslisp-4.0.1nb3.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.