lang/ucblogo - The NetBSD Packages Collection

UCB (Berkeley) Logo interpreter

[This package is GPL'd - please see README in sources for license information]

This version of Logo is designed for a machine with adequate memory.  It is
not likely to be usable as the basis for a 64K microcomputer implementation.

The interpreter was written primarily by Daniel Van Blerkom, Brian Harvey,
Michael Katz, and Douglas Orleans.  Thanks to Fred Gilham for the X11 code.
Send comments by e-mail to bh@cs.berkeley.edu.

Build dependencies

pkgtools/x11-links x11/xorgproto x11/xcb-proto devel/glib2-tools pkgtools/mktools devel/gmake pkgtools/cwrappers

Runtime dependencies

graphics/hicolor-icon-theme x11/wxGTK30 graphics/hicolor-icon-theme x11/wxGTK30

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64ucblogo-6.2.1nb2.tgz
NetBSD 10.0earmv6hfucblogo-6.2.1nb2.tgz
NetBSD 10.0earmv7hfucblogo-6.2.1nb2.tgz
NetBSD 10.0i386ucblogo-6.2.1nb2.tgz
NetBSD 10.0powerpcucblogo-6.2.1nb2.tgz
NetBSD 10.0powerpcucblogo-6.2.1nb2.tgz
NetBSD 10.0x86_64ucblogo-6.2.1nb2.tgz
NetBSD 10.0x86_64ucblogo-6.2.1nb2.tgz
NetBSD 8.0earmv7hfucblogo-6.2.1.tgz
NetBSD 8.0i386ucblogo-6.2.1nb1.tgz
NetBSD 8.0i386ucblogo-6.2.1nb2.tgz
NetBSD 8.0powerpcucblogo-6.2.1nb1.tgz
NetBSD 8.0powerpcucblogo-6.2.1nb2.tgz
NetBSD 8.0powerpcucblogo-6.2.1nb2.tgz
NetBSD 8.0x86_64ucblogo-6.2.1nb1.tgz
NetBSD 8.0x86_64ucblogo-6.2.1nb2.tgz
NetBSD 9.0aarch64ucblogo-6.2.1nb2.tgz
NetBSD 9.0aarch64ucblogo-6.2.1nb1.tgz
NetBSD 9.0alphaucblogo-6.2.1nb1.tgz
NetBSD 9.0alphaucblogo-6.2.1nb1.tgz
NetBSD 9.0alphaucblogo-6.2.1nb1.tgz
NetBSD 9.0alphaucblogo-6.2.1nb2.tgz
NetBSD 9.0alphaucblogo-6.2.1nb2.tgz
NetBSD 9.0earmv6hfucblogo-6.2.1nb1.tgz
NetBSD 9.0earmv6hfucblogo-6.2.1nb2.tgz
NetBSD 9.0earmv7hfucblogo-6.2.1nb2.tgz
NetBSD 9.0earmv7hfucblogo-6.2.1nb1.tgz
NetBSD 9.0i386ucblogo-6.2.1nb1.tgz
NetBSD 9.0i386ucblogo-6.2.1nb1.tgz
NetBSD 9.0i386ucblogo-6.2.1nb2.tgz
NetBSD 9.0mips64ebucblogo-6.2.1nb1.tgz
NetBSD 9.0mips64ebucblogo-6.2.1nb1.tgz
NetBSD 9.0mips64ebucblogo-6.2.1nb1.tgz
NetBSD 9.0powerpcucblogo-6.2.1nb2.tgz
NetBSD 9.0powerpcucblogo-6.2.1nb1.tgz
NetBSD 9.0powerpcucblogo-6.2.1nb2.tgz
NetBSD 9.0sparc64ucblogo-6.2.1nb1.tgz
NetBSD 9.0sparc64ucblogo-6.2.1nb1.tgz
NetBSD 9.0sparc64ucblogo-6.2.1nb1.tgz
NetBSD 9.0sparc64ucblogo-6.2.1nb2.tgz
NetBSD 9.0sparc64ucblogo-6.2.1nb2.tgz
NetBSD 9.0x86_64ucblogo-6.2.1nb1.tgz
NetBSD 9.0x86_64ucblogo-6.2.1nb1.tgz
NetBSD 9.0x86_64ucblogo-6.2.1nb1.tgz
NetBSD 9.0x86_64ucblogo-6.2.1nb2.tgz
NetBSD 9.0x86_64ucblogo-6.2.1nb2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.