lang/ruby27-base - The NetBSD Packages Collection

Ruby 2.7.4 release minimum base package

Ruby is the interpreted scripting language for quick and
easy object-oriented programming.  It has many features to
process text files and to do system management tasks (as in
Perl).  It is simple, straight-forward, and extensible.

Features of Ruby are shown below.

  + Simple Syntax
  + *Normal* Object-Oriented features (ex. class, method calls)
  + *Advanced* Object-Oriented features (ex. Mix-in, Singleton-method)
  + Operator Overloading
  + Exception Handling
  + Iterators and Closures
  + Garbage Collection
  + Dynamic Loading of Object files (on some architecture)
  + Highly Portable (works on many UNIX machines, and on DOS, Windows,
    Mac, etc.)

Ruby 2.7 introduces a number of new features and performance
improvements, most notably:

  * Pattern Matching (Experimental)
  * REPL improvement
  * Compaction GC
  * Separation of positional and keyword arguments

This package is Ruby 2.7 release minimum base package.

Build dependencies

pkgtools/cwrappers devel/pkgconf

Runtime dependencies

textproc/libyaml textproc/libyaml

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfruby27-base-2.7.2.tgz
NetBSD 8.0earmv7hfruby27-base-2.7.1nb2.tgz
NetBSD 8.0earmv7hfruby27-base-2.7.3.tgz
NetBSD 8.0earmv7hfruby27-base-2.7.4.tgz
NetBSD 8.0i386ruby27-base-2.7.2.tgz
NetBSD 8.0i386ruby27-base-2.7.2.tgz
NetBSD 8.0i386ruby27-base-2.7.3.tgz
NetBSD 8.0i386ruby27-base-2.7.4.tgz
NetBSD 8.0powerpcruby27-base-2.7.1nb2.tgz
NetBSD 8.0powerpcruby27-base-2.7.2.tgz
NetBSD 8.0powerpcruby27-base-2.7.2.tgz
NetBSD 8.0powerpcruby27-base-2.7.3.tgz
NetBSD 8.0powerpcruby27-base-2.7.4.tgz
NetBSD 8.0powerpcruby27-base-2.7.3.tgz
NetBSD 8.0powerpcruby27-base-2.7.4.tgz
NetBSD 8.0x86_64ruby27-base-2.7.3.tgz
NetBSD 8.0x86_64ruby27-base-2.7.2.tgz
NetBSD 8.0x86_64ruby27-base-2.7.2.tgz
NetBSD 8.0x86_64ruby27-base-2.7.4.tgz
NetBSD 9.0aarch64ruby27-base-2.7.4.tgz
NetBSD 9.0aarch64ruby27-base-2.7.2.tgz
NetBSD 9.0aarch64ruby27-base-2.7.2.tgz
NetBSD 9.0aarch64ruby27-base-2.7.3.tgz
NetBSD 9.0alpharuby27-base-2.7.3.tgz
NetBSD 9.0alpharuby27-base-2.7.4.tgz
NetBSD 9.0alpharuby27-base-2.7.2.tgz
NetBSD 9.0alpharuby27-base-2.7.3.tgz
NetBSD 9.0earmruby27-base-2.7.2.tgz
NetBSD 9.0earmruby27-base-2.7.3.tgz
NetBSD 9.0earmv6hfruby27-base-2.7.4.tgz
NetBSD 9.0earmv6hfruby27-base-2.7.1nb2.tgz
NetBSD 9.0earmv6hfruby27-base-2.7.2.tgz
NetBSD 9.0earmv6hfruby27-base-2.7.2.tgz
NetBSD 9.0earmv6hfruby27-base-2.7.2.tgz
NetBSD 9.0earmv6hfruby27-base-2.7.3.tgz
NetBSD 9.0earmv7hfruby27-base-2.7.4.tgz
NetBSD 9.0earmv7hfruby27-base-2.7.1nb2.tgz
NetBSD 9.0earmv7hfruby27-base-2.7.2.tgz
NetBSD 9.0earmv7hfruby27-base-2.7.2.tgz
NetBSD 9.0earmv7hfruby27-base-2.7.3.tgz
NetBSD 9.0earmv7hfruby27-base-2.7.3.tgz
NetBSD 9.0earmv7hfruby27-base-2.7.4.tgz
NetBSD 9.0i386ruby27-base-2.7.2.tgz
NetBSD 9.0i386ruby27-base-2.7.2.tgz
NetBSD 9.0i386ruby27-base-2.7.3.tgz
NetBSD 9.0i386ruby27-base-2.7.4.tgz
NetBSD 9.0m68kruby27-base-2.7.4.tgz
NetBSD 9.0mips64ebruby27-base-2.7.3.tgz
NetBSD 9.0mips64ebruby27-base-2.7.4.tgz
NetBSD 9.0mips64ebruby27-base-2.7.1nb2.tgz
NetBSD 9.0mips64ebruby27-base-2.7.2.tgz
NetBSD 9.0mips64ebruby27-base-2.7.2.tgz
NetBSD 9.0mips64ebruby27-base-2.7.3.tgz
NetBSD 9.0mipselruby27-base-2.7.3.tgz
NetBSD 9.0mipselruby27-base-2.7.2.tgz
NetBSD 9.0mipselruby27-base-2.7.2.tgz
NetBSD 9.0powerpcruby27-base-2.7.3.tgz
NetBSD 9.0powerpcruby27-base-2.7.1nb2.tgz
NetBSD 9.0powerpcruby27-base-2.7.2.tgz
NetBSD 9.0powerpcruby27-base-2.7.2.tgz
NetBSD 9.0powerpcruby27-base-2.7.3.tgz
NetBSD 9.0powerpcruby27-base-2.7.3.tgz
NetBSD 9.0sparc64ruby27-base-2.7.3.tgz
NetBSD 9.0sparc64ruby27-base-2.7.4.tgz
NetBSD 9.0sparc64ruby27-base-2.7.2.tgz
NetBSD 9.0sparc64ruby27-base-2.7.3.tgz
NetBSD 9.0sparcruby27-base-2.7.3.tgz
NetBSD 9.0sparcruby27-base-2.7.4.tgz
NetBSD 9.0sparcruby27-base-2.7.1nb2.tgz
NetBSD 9.0sparcruby27-base-2.7.2.tgz
NetBSD 9.0sparcruby27-base-2.7.2.tgz
NetBSD 9.0sparcruby27-base-2.7.2.tgz
NetBSD 9.0sparcruby27-base-2.7.3.tgz
NetBSD 9.0vaxruby27-base-2.7.2.tgz
NetBSD 9.0vaxruby27-base-2.7.2.tgz
NetBSD 9.0vaxruby27-base-2.7.3.tgz
NetBSD 9.0x86_64ruby27-base-2.7.2.tgz
NetBSD 9.0x86_64ruby27-base-2.7.3.tgz
NetBSD 9.0x86_64ruby27-base-2.7.2.tgz
NetBSD 9.0x86_64ruby27-base-2.7.3.tgz
NetBSD 9.0x86_64ruby27-base-2.7.4.tgz
NetBSD 9.0x86_64ruby27-base-2.7.2.tgz
NetBSD 9.0x86_64ruby27-base-2.7.2.tgz
NetBSD 9.0x86_64ruby27-base-2.7.3.tgz
NetBSD 9.0x86_64ruby27-base-2.7.4.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

ruby-build-ri-db
Build and install database for Ruby's ri utility.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.