Daemon Power

The NetBSD Packages Collection: lang/ruby-coffee-script

Brief description of the package:
Ruby CoffeeScript Compiler

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://github.com/josh/ruby-coffee-script/.

Please note that this package has a mit license.

The package is located in the "lang/ruby-coffee-script" directory. The current source version of the package is "ruby26-coffee-script-2.4.1". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for lang/ruby-coffee-script :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: ruby26-coffee-script-source>=0 ruby26-base>=2.6.5 openssl>=1.1.1 cwrappers>=20150314 libyaml>=0.1.1 openssl>=1.1.1dnb2 libyaml>=0.1.4 ruby26-execjs>=0 nodejs>=4 libuv>=1.23 libuv>=1.6 libcares>=1.3.0nb1 icu>=3.4 nghttp2>=1.0.0 python37>=3.7 libffi>=1.20 libuuid>=2.18 libffi>=3.0.11 readline>=2.2 readline>=6.0 python37>=3.7.0 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 libcares>=1.6.0 icu>=64.1 nghttp2>=1.40.0nb2 lockf-[0-9]* python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 openssl>=0.9.6 python27>=2.7.1nb2 .

This package requires the following package(s) to run: ruby26-coffee-script-source>=0 ruby26-base>=2.6.5 openssl>=1.1.1 libyaml>=0.1.1 openssl>=1.1.1dnb2 libyaml>=0.1.4 ruby26-execjs>=0 nodejs>=4 libuv>=1.23 libuv>=1.6 libcares>=1.3.0nb1 icu>=3.4 nghttp2>=1.0.0 python37>=3.7 libffi>=1.20 libuuid>=2.18 libffi>=3.0.11 python37>=3.7.0 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 libcares>=1.6.0 icu>=64.1 nghttp2>=1.40.0nb2 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
earmv6hf:ruby24-coffee-script-2.4.1.tgz(NetBSD 8.0)
earmv6hf:ruby25-coffee-script-2.4.1.tgz(NetBSD 8.0)
earmv6hf:ruby26-coffee-script-2.4.1.tgz(NetBSD 8.0)
earmv7hf:ruby24-coffee-script-2.4.1.tgz(NetBSD 8.0)
earmv7hf:ruby25-coffee-script-2.4.1.tgz(NetBSD 8.0)
earmv7hf:ruby26-coffee-script-2.4.1.tgz(NetBSD 8.0)
i386:ruby18-coffee-script-2.2.0.tgz(MirBSD 10)
i386:ruby193-coffee-script-2.2.0.tgz(MirBSD 10)
i386:ruby200-coffee-script-2.2.0.tgz(MirBSD 10)
i386:ruby211-coffee-script-2.2.0.tgz(MirBSD 10)
i386:ruby23-coffee-script-2.4.1.tgz(NetBSD 7.0)
i386:ruby24-coffee-script-2.4.1.tgz(NetBSD 7.0)
i386:ruby25-coffee-script-2.4.1.tgz(NetBSD 7.0)
i386:ruby24-coffee-script-2.4.1.tgz(NetBSD 7.0)
i386:ruby25-coffee-script-2.4.1.tgz(NetBSD 7.0)
i386:ruby24-coffee-script-2.4.1.tgz(NetBSD 7.0)
i386:ruby25-coffee-script-2.4.1.tgz(NetBSD 7.0)
i386:ruby23-coffee-script-2.4.1.tgz(NetBSD 7.1)
i386:ruby24-coffee-script-2.4.1.tgz(NetBSD 7.1)
i386:ruby25-coffee-script-2.4.1.tgz(NetBSD 7.1)
i386:ruby24-coffee-script-2.4.1.tgz(NetBSD 7.1)
i386:ruby25-coffee-script-2.4.1.tgz(NetBSD 7.1)
i386:ruby24-coffee-script-2.4.1.tgz(NetBSD 7.1)
i386:ruby25-coffee-script-2.4.1.tgz(NetBSD 7.1)
i386:ruby23-coffee-script-2.4.1.tgz(NetBSD 8.0)
i386:ruby24-coffee-script-2.4.1.tgz(NetBSD 8.0)
i386:ruby25-coffee-script-2.4.1.tgz(NetBSD 8.0)
i386:ruby26-coffee-script-2.4.1.tgz(NetBSD 8.0)
i386:ruby24-coffee-script-2.4.1.tgz(NetBSD 8.0)
i386:ruby25-coffee-script-2.4.1.tgz(NetBSD 8.0)
i386:ruby26-coffee-script-2.4.1.tgz(NetBSD 8.0)
i386:ruby24-coffee-script-2.4.1.tgz(NetBSD 8.0)
i386:ruby25-coffee-script-2.4.1.tgz(NetBSD 8.0)
i386:ruby26-coffee-script-2.4.1.tgz(NetBSD 8.0)
i386:ruby24-coffee-script-2.4.1.tgz(NetBSD 8.0)
i386:ruby25-coffee-script-2.4.1.tgz(NetBSD 8.0)
i386:ruby26-coffee-script-2.4.1.tgz(NetBSD 8.0)
x86_64:ruby23-coffee-script-2.4.1.tgz(NetBSD 7.0)
x86_64:ruby24-coffee-script-2.4.1.tgz(NetBSD 7.0)
x86_64:ruby25-coffee-script-2.4.1.tgz(NetBSD 7.0)
x86_64:ruby24-coffee-script-2.4.1.tgz(NetBSD 7.0)
x86_64:ruby25-coffee-script-2.4.1.tgz(NetBSD 7.0)
x86_64:ruby24-coffee-script-2.4.1.tgz(NetBSD 7.0)
x86_64:ruby25-coffee-script-2.4.1.tgz(NetBSD 7.0)
x86_64:ruby23-coffee-script-2.4.1.tgz(NetBSD 7.1)
x86_64:ruby24-coffee-script-2.4.1.tgz(NetBSD 7.1)
x86_64:ruby25-coffee-script-2.4.1.tgz(NetBSD 7.1)
x86_64:ruby24-coffee-script-2.4.1.tgz(NetBSD 7.1)
x86_64:ruby25-coffee-script-2.4.1.tgz(NetBSD 7.1)
x86_64:ruby24-coffee-script-2.4.1.tgz(NetBSD 7.1)
x86_64:ruby25-coffee-script-2.4.1.tgz(NetBSD 7.1)
x86_64:ruby24-coffee-script-2.4.1.tgz(NetBSD 8.0)
x86_64:ruby25-coffee-script-2.4.1.tgz(NetBSD 8.0)
x86_64:ruby26-coffee-script-2.4.1.tgz(NetBSD 8.0)
x86_64:ruby23-coffee-script-2.4.1.tgz(NetBSD 8.0)
x86_64:ruby24-coffee-script-2.4.1.tgz(NetBSD 8.0)
x86_64:ruby25-coffee-script-2.4.1.tgz(NetBSD 8.0)
x86_64:ruby26-coffee-script-2.4.1.tgz(NetBSD 8.0)
x86_64:ruby24-coffee-script-2.4.1.tgz(NetBSD 8.0)
x86_64:ruby25-coffee-script-2.4.1.tgz(NetBSD 8.0)
x86_64:ruby26-coffee-script-2.4.1.tgz(NetBSD 8.0)
x86_64:ruby24-coffee-script-2.4.1.tgz(NetBSD 8.0)
x86_64:ruby25-coffee-script-2.4.1.tgz(NetBSD 8.0)
x86_64:ruby26-coffee-script-2.4.1.tgz(NetBSD 8.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]