lang/nuitka - The NetBSD Packages Collection

Python to C++ compiler

Right now Nuitka is a good replacement for the Python interpreter and
compiles every construct that CPython 2.6, 2.7, 3.2 and 3.3 offer.  It
translates the Python into a C++ program that then uses "libpython" to
execute in the same way as CPython does, in a very compatible way.

It is somewhat faster than CPython already, but currently it doesn't
make all the optimizations possible, but a 258% factor on pystone is a
good start (number is from version 0.3.11).

Build dependencies

devel/py-setuptools44 pkgtools/mktools pkgtools/cwrappers

Runtime dependencies

lang/python27 lang/python27

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64nuitka-0.5.0.1nb5.tgz
NetBSD 10.0aarch64nuitka-0.5.0.1nb5.tgz
NetBSD 10.0earmv6hfnuitka-0.5.0.1nb5.tgz
NetBSD 10.0earmv6hfnuitka-0.5.0.1nb5.tgz
NetBSD 10.0earmv7hfnuitka-0.5.0.1nb5.tgz
NetBSD 10.0earmv7hfnuitka-0.5.0.1nb5.tgz
NetBSD 10.0i386nuitka-0.5.0.1nb5.tgz
NetBSD 10.0powerpcnuitka-0.5.0.1nb5.tgz
NetBSD 10.0powerpcnuitka-0.5.0.1nb5.tgz
NetBSD 10.0x86_64nuitka-0.5.0.1nb5.tgz
NetBSD 10.0x86_64nuitka-0.5.0.1nb5.tgz
NetBSD 8.0earmv7hfnuitka-0.5.0.1nb3.tgz
NetBSD 8.0i386nuitka-0.5.0.1nb4.tgz
NetBSD 8.0i386nuitka-0.5.0.1nb5.tgz
NetBSD 8.0powerpcnuitka-0.5.0.1nb3.tgz
NetBSD 8.0powerpcnuitka-0.5.0.1nb5.tgz
NetBSD 8.0powerpcnuitka-0.5.0.1nb5.tgz
NetBSD 8.0x86_64nuitka-0.5.0.1nb4.tgz
NetBSD 8.0x86_64nuitka-0.5.0.1nb5.tgz
NetBSD 9.0aarch64nuitka-0.5.0.1nb5.tgz
NetBSD 9.0aarch64nuitka-0.5.0.1nb4.tgz
NetBSD 9.0aarch64nuitka-0.5.0.1nb5.tgz
NetBSD 9.0alphanuitka-0.5.0.1nb3.tgz
NetBSD 9.0alphanuitka-0.5.0.1nb4.tgz
NetBSD 9.0alphanuitka-0.5.0.1nb4.tgz
NetBSD 9.0alphanuitka-0.5.0.1nb5.tgz
NetBSD 9.0alphanuitka-0.5.0.1nb5.tgz
NetBSD 9.0earmv6hfnuitka-0.5.0.1nb4.tgz
NetBSD 9.0earmv6hfnuitka-0.5.0.1nb5.tgz
NetBSD 9.0earmv6hfnuitka-0.5.0.1nb5.tgz
NetBSD 9.0earmv7hfnuitka-0.5.0.1nb5.tgz
NetBSD 9.0earmv7hfnuitka-0.5.0.1nb5.tgz
NetBSD 9.0earmv7hfnuitka-0.5.0.1nb4.tgz
NetBSD 9.0i386nuitka-0.5.0.1nb4.tgz
NetBSD 9.0i386nuitka-0.5.0.1nb4.tgz
NetBSD 9.0i386nuitka-0.5.0.1nb5.tgz
NetBSD 9.0m68knuitka-0.5.0.1nb4.tgz
NetBSD 9.0m68knuitka-0.5.0.1nb4.tgz
NetBSD 9.0mips64ebnuitka-0.5.0.1nb3.tgz
NetBSD 9.0mips64ebnuitka-0.5.0.1nb4.tgz
NetBSD 9.0mips64ebnuitka-0.5.0.1nb4.tgz
NetBSD 9.0powerpcnuitka-0.5.0.1nb5.tgz
NetBSD 9.0powerpcnuitka-0.5.0.1nb4.tgz
NetBSD 9.0powerpcnuitka-0.5.0.1nb5.tgz
NetBSD 9.0sparc64nuitka-0.5.0.1nb3.tgz
NetBSD 9.0sparc64nuitka-0.5.0.1nb4.tgz
NetBSD 9.0sparc64nuitka-0.5.0.1nb4.tgz
NetBSD 9.0sparc64nuitka-0.5.0.1nb5.tgz
NetBSD 9.0sparc64nuitka-0.5.0.1nb5.tgz
NetBSD 9.0sparcnuitka-0.5.0.1nb3.tgz
NetBSD 9.0sparcnuitka-0.5.0.1nb3.tgz
NetBSD 9.0x86_64nuitka-0.5.0.1nb5.tgz
NetBSD 9.0x86_64nuitka-0.5.0.1nb4.tgz
NetBSD 9.0x86_64nuitka-0.5.0.1nb4.tgz
NetBSD 9.0x86_64nuitka-0.5.0.1nb5.tgz
NetBSD 9.0x86_64nuitka-0.5.0.1nb5.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.