lang/njs - The NetBSD Packages Collection

NGINX JavaScript command line utility

njs scripting language, or just njs, is a subset of the JavaScript language
that allows extending nginx functionality.  njs is created in compliance
with ECMAScript 5.1 (strict mode) with some ECMAScript 6 and later
extensions.  The compliance is still evolving.

Build dependencies

pkgtools/mktools pkgtools/cwrappers

Runtime dependencies

devel/pcre devel/pcre

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64njs-0.7.7.tgz
NetBSD 10.0aarch64njs-0.7.9.tgz
NetBSD 10.0earmv6hfnjs-0.7.7.tgz
NetBSD 10.0earmv6hfnjs-0.7.9.tgz
NetBSD 10.0earmv7hfnjs-0.7.7.tgz
NetBSD 10.0earmv7hfnjs-0.7.9.tgz
NetBSD 10.0i386njs-0.7.7.tgz
NetBSD 10.0powerpcnjs-0.7.7.tgz
NetBSD 10.0powerpcnjs-0.7.7.tgz
NetBSD 10.0x86_64njs-0.7.9.tgz
NetBSD 10.0x86_64njs-0.7.7.tgz
NetBSD 8.0i386njs-0.7.3.tgz
NetBSD 8.0i386njs-0.7.7.tgz
NetBSD 8.0powerpcnjs-0.7.9.tgz
NetBSD 8.0powerpcnjs-0.7.9.tgz
NetBSD 8.0x86_64njs-0.7.3.tgz
NetBSD 8.0x86_64njs-0.7.7.tgz
NetBSD 9.0aarch64njs-0.7.7.tgz
NetBSD 9.0aarch64njs-0.7.3.tgz
NetBSD 9.0aarch64njs-0.7.9.tgz
NetBSD 9.0alphanjs-0.7.2.tgz
NetBSD 9.0alphanjs-0.7.3.tgz
NetBSD 9.0alphanjs-0.7.7.tgz
NetBSD 9.0alphanjs-0.7.9.tgz
NetBSD 9.0earmv6hfnjs-0.7.3.tgz
NetBSD 9.0earmv6hfnjs-0.7.7.tgz
NetBSD 9.0earmv6hfnjs-0.7.9.tgz
NetBSD 9.0earmv7hfnjs-0.7.7.tgz
NetBSD 9.0earmv7hfnjs-0.7.9.tgz
NetBSD 9.0earmv7hfnjs-0.7.3.tgz
NetBSD 9.0i386njs-0.7.3.tgz
NetBSD 9.0i386njs-0.7.3.tgz
NetBSD 9.0i386njs-0.7.7.tgz
NetBSD 9.0mips64ebnjs-0.7.2.tgz
NetBSD 9.0powerpcnjs-0.7.7.tgz
NetBSD 9.0powerpcnjs-0.7.3.tgz
NetBSD 9.0powerpcnjs-0.7.7.tgz
NetBSD 9.0sparc64njs-0.7.2.tgz
NetBSD 9.0sparc64njs-0.7.3.tgz
NetBSD 9.0sparc64njs-0.7.7.tgz
NetBSD 9.0sparc64njs-0.7.9.tgz
NetBSD 9.0x86_64njs-0.7.5nb1.tgz
NetBSD 9.0x86_64njs-0.7.3.tgz
NetBSD 9.0x86_64njs-0.7.3.tgz
NetBSD 9.0x86_64njs-0.7.7.tgz
NetBSD 9.0x86_64njs-0.7.6.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

ssl
Enable SSL support.
pcre
Enable Perl-compatible regular expressions.
pcre2
Use Perl Compatible Regular Expressions, API version 2.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.