lang/mujs - The NetBSD Packages Collection

Lightweight embedded JavaScript interpreter

MuJS is a lightweight Javascript interpreter designed for embedding in other
software to extend them with scripting capabilities.

MuJS was designed with a focus on small size, correctness, and simplicity.

It is written in portable C and implements ECMAScript as specified by
ECMA-262. The interface for binding with native code is designed to be as
simple as possible to use, and is very similar to Lua.

Build dependencies

devel/libtool-base pkgtools/mktools devel/gmake pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64mujs-1.2.0.tgz
NetBSD 10.0earmv6hfmujs-1.2.0.tgz
NetBSD 10.0earmv7hfmujs-1.2.0.tgz
NetBSD 10.0i386mujs-1.2.0.tgz
NetBSD 10.0powerpcmujs-1.2.0.tgz
NetBSD 10.0powerpcmujs-1.2.0.tgz
NetBSD 10.0x86_64mujs-1.3.0.tgz
NetBSD 10.0x86_64mujs-1.2.0.tgz
NetBSD 8.0i386mujs-1.2.0.tgz
NetBSD 8.0powerpcmujs-1.3.0.tgz
NetBSD 8.0powerpcmujs-1.3.0.tgz
NetBSD 8.0x86_64mujs-1.2.0.tgz
NetBSD 9.0aarch64mujs-1.2.0.tgz
NetBSD 9.0alphamujs-1.2.0.tgz
NetBSD 9.0alphamujs-1.3.0.tgz
NetBSD 9.0earmmujs-1.2.0.tgz
NetBSD 9.0earmv6hfmujs-1.2.0.tgz
NetBSD 9.0earmv7hfmujs-1.2.0.tgz
NetBSD 9.0i386mujs-1.2.0.tgz
NetBSD 9.0m68kmujs-1.2.0.tgz
NetBSD 9.0m68kmujs-1.3.0.tgz
NetBSD 9.0mips64ebmujs-1.2.0.tgz
NetBSD 9.0powerpcmujs-1.2.0.tgz
NetBSD 9.0powerpcmujs-1.2.0.tgz
NetBSD 9.0sparc64mujs-1.2.0.tgz
NetBSD 9.0sparc64mujs-1.3.0.tgz
NetBSD 9.0sparcmujs-1.2.0.tgz
NetBSD 9.0sparcmujs-1.3.0.tgz
NetBSD 9.0x86_64mujs-1.2.0.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.