lang/forth-retro - The NetBSD Packages Collection

Clean, elegant, and pragmatic dialect of Forth

RETRO is a clean, elegant, and pragmatic dialect of Forth. It provides
a simple alternative for those willing to make a break from legacy
systems.

The language draws influences from many sources including traditional
Forth systems, cmForth, colorForth, Factor, and Parable. It was
designed to be easy to grasp and adapt to specific uses.

The basic language is very portable. It runs on a tiny virtual
machine (Nga), which is written in C. There are multiple interface
options, the main one (rre) is buildable with just the standard C
compiler and libraries on most systems.

Build dependencies

pkgtools/mktools pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64forth-retro-12.0.2019.7.tgz
NetBSD 10.0earmv6hfforth-retro-12.0.2019.7.tgz
NetBSD 10.0earmv7hfforth-retro-12.0.2019.7.tgz
NetBSD 10.0i386forth-retro-12.0.2019.7.tgz
NetBSD 10.0powerpcforth-retro-12.0.2019.7.tgz
NetBSD 10.0powerpcforth-retro-12.0.2019.7.tgz
NetBSD 10.0x86_64forth-retro-12.0.2019.7.tgz
NetBSD 10.0x86_64forth-retro-12.0.2019.7.tgz
NetBSD 8.0earmv7hfforth-retro-12.0.2019.7.tgz
NetBSD 8.0i386forth-retro-12.0.2019.7.tgz
NetBSD 8.0i386forth-retro-12.0.2019.7.tgz
NetBSD 8.0powerpcforth-retro-12.0.2019.7.tgz
NetBSD 8.0powerpcforth-retro-12.0.2019.7.tgz
NetBSD 8.0powerpcforth-retro-12.0.2019.7.tgz
NetBSD 8.0x86_64forth-retro-12.0.2019.7.tgz
NetBSD 8.0x86_64forth-retro-12.0.2019.7.tgz
NetBSD 9.0aarch64forth-retro-12.0.2019.7.tgz
NetBSD 9.0aarch64forth-retro-12.0.2019.7.tgz
NetBSD 9.0alphaforth-retro-12.0.2019.7.tgz
NetBSD 9.0alphaforth-retro-12.0.2019.7.tgz
NetBSD 9.0alphaforth-retro-12.0.2019.7.tgz
NetBSD 9.0alphaforth-retro-12.0.2019.7.tgz
NetBSD 9.0alphaforth-retro-12.0.2019.7.tgz
NetBSD 9.0earmforth-retro-12.0.2019.7.tgz
NetBSD 9.0earmv6hfforth-retro-12.0.2019.7.tgz
NetBSD 9.0earmv6hfforth-retro-12.0.2019.7.tgz
NetBSD 9.0earmv7hfforth-retro-12.0.2019.7.tgz
NetBSD 9.0earmv7hfforth-retro-12.0.2019.7.tgz
NetBSD 9.0i386forth-retro-12.0.2019.7.tgz
NetBSD 9.0i386forth-retro-12.0.2019.7.tgz
NetBSD 9.0i386forth-retro-12.0.2019.7.tgz
NetBSD 9.0mips64ebforth-retro-12.0.2019.7.tgz
NetBSD 9.0mips64ebforth-retro-12.0.2019.7.tgz
NetBSD 9.0mips64ebforth-retro-12.0.2019.7.tgz
NetBSD 9.0mips64ebforth-retro-12.0.2019.7.tgz
NetBSD 9.0mips64ebforth-retro-12.0.2019.7.tgz
NetBSD 9.0powerpcforth-retro-12.0.2019.7.tgz
NetBSD 9.0powerpcforth-retro-12.0.2019.7.tgz
NetBSD 9.0powerpcforth-retro-12.0.2019.7.tgz
NetBSD 9.0sparc64forth-retro-12.0.2019.7.tgz
NetBSD 9.0sparc64forth-retro-12.0.2019.7.tgz
NetBSD 9.0sparc64forth-retro-12.0.2019.7.tgz
NetBSD 9.0sparc64forth-retro-12.0.2019.7.tgz
NetBSD 9.0sparc64forth-retro-12.0.2019.7.tgz
NetBSD 9.0sparcforth-retro-12.0.2019.7.tgz
NetBSD 9.0sparcforth-retro-12.0.2019.7.tgz
NetBSD 9.0x86_64forth-retro-12.0.2019.7.tgz
NetBSD 9.0x86_64forth-retro-12.0.2019.7.tgz
NetBSD 9.0x86_64forth-retro-12.0.2019.7.tgz
NetBSD 9.0x86_64forth-retro-12.0.2019.7.tgz
NetBSD 9.0x86_64forth-retro-12.0.2019.7.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.