lang/elisp-manual - The NetBSD Packages Collection

The Emacs Lisp Reference Manual for GNU Emacs Version 21.2

Herein is found the programming manual for elisp (Emacs Lisp), the
dialect of Lisp used to extend (and write applications inside) GNU
Emacs.

Because Emacs Lisp is designed for use in an editor, it has special
features for scanning and parsing text as well as features for
handling files, buffers, displays, subprocesses, and so on. All Emacs
editing commands are available.

This manual attempts to be a full description of Emacs Lisp.  For a
beginner's introduction to Emacs Lisp, see ``An Introduction to Emacs
Lisp Programming,'' by Bob Chassell. Also see ``The GNU Emacs Manual''.

This package contains the manual corresponding to Emacs 21.x. For
Emacs 22 and up, the Lisp manual is included in the main Emacs
distribution and consequently in the main Emacs package.

Build dependencies

pkgtools/mktools pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64elisp-manual-21.2.8.tgz
NetBSD 10.0aarch64elisp-manual-21.2.8.tgz
NetBSD 10.0earmv6hfelisp-manual-21.2.8.tgz
NetBSD 10.0earmv6hfelisp-manual-21.2.8.tgz
NetBSD 10.0earmv7hfelisp-manual-21.2.8.tgz
NetBSD 10.0earmv7hfelisp-manual-21.2.8.tgz
NetBSD 10.0i386elisp-manual-21.2.8.tgz
NetBSD 10.0powerpcelisp-manual-21.2.8.tgz
NetBSD 10.0powerpcelisp-manual-21.2.8.tgz
NetBSD 10.0x86_64elisp-manual-21.2.8.tgz
NetBSD 10.0x86_64elisp-manual-21.2.8.tgz
NetBSD 8.0earmv7hfelisp-manual-21.2.8.tgz
NetBSD 8.0i386elisp-manual-21.2.8.tgz
NetBSD 8.0i386elisp-manual-21.2.8.tgz
NetBSD 8.0powerpcelisp-manual-21.2.8.tgz
NetBSD 8.0powerpcelisp-manual-21.2.8.tgz
NetBSD 8.0powerpcelisp-manual-21.2.8.tgz
NetBSD 8.0x86_64elisp-manual-21.2.8.tgz
NetBSD 8.0x86_64elisp-manual-21.2.8.tgz
NetBSD 9.0aarch64elisp-manual-21.2.8.tgz
NetBSD 9.0aarch64elisp-manual-21.2.8.tgz
NetBSD 9.0aarch64elisp-manual-21.2.8.tgz
NetBSD 9.0alphaelisp-manual-21.2.8.tgz
NetBSD 9.0alphaelisp-manual-21.2.8.tgz
NetBSD 9.0alphaelisp-manual-21.2.8.tgz
NetBSD 9.0alphaelisp-manual-21.2.8.tgz
NetBSD 9.0alphaelisp-manual-21.2.8.tgz
NetBSD 9.0earmelisp-manual-21.2.8.tgz
NetBSD 9.0earmv6hfelisp-manual-21.2.8.tgz
NetBSD 9.0earmv6hfelisp-manual-21.2.8.tgz
NetBSD 9.0earmv6hfelisp-manual-21.2.8.tgz
NetBSD 9.0earmv7hfelisp-manual-21.2.8.tgz
NetBSD 9.0earmv7hfelisp-manual-21.2.8.tgz
NetBSD 9.0earmv7hfelisp-manual-21.2.8.tgz
NetBSD 9.0i386elisp-manual-21.2.8.tgz
NetBSD 9.0i386elisp-manual-21.2.8.tgz
NetBSD 9.0i386elisp-manual-21.2.8.tgz
NetBSD 9.0mips64ebelisp-manual-21.2.8.tgz
NetBSD 9.0mips64ebelisp-manual-21.2.8.tgz
NetBSD 9.0mips64ebelisp-manual-21.2.8.tgz
NetBSD 9.0mips64ebelisp-manual-21.2.8.tgz
NetBSD 9.0mips64ebelisp-manual-21.2.8.tgz
NetBSD 9.0powerpcelisp-manual-21.2.8.tgz
NetBSD 9.0powerpcelisp-manual-21.2.8.tgz
NetBSD 9.0powerpcelisp-manual-21.2.8.tgz
NetBSD 9.0sparc64elisp-manual-21.2.8.tgz
NetBSD 9.0sparc64elisp-manual-21.2.8.tgz
NetBSD 9.0sparc64elisp-manual-21.2.8.tgz
NetBSD 9.0sparc64elisp-manual-21.2.8.tgz
NetBSD 9.0sparc64elisp-manual-21.2.8.tgz
NetBSD 9.0sparcelisp-manual-21.2.8.tgz
NetBSD 9.0sparcelisp-manual-21.2.8.tgz
NetBSD 9.0x86_64elisp-manual-21.2.8.tgz
NetBSD 9.0x86_64elisp-manual-21.2.8.tgz
NetBSD 9.0x86_64elisp-manual-21.2.8.tgz
NetBSD 9.0x86_64elisp-manual-21.2.8.tgz
NetBSD 9.0x86_64elisp-manual-21.2.8.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.