lang/camlp4 - The NetBSD Packages Collection

Preprocessor and pretty printer for OCaml

Camlp4 is a software system for writing extensible parsers for programming
languages. It provides a set of OCaml libraries that are used to define
grammars as well as loadable syntax extensions of such grammars. Camlp4 stands
for Caml Preprocessor and Pretty-Printer and one of its most important
applications is the definition of domain-specific extensions of the syntax of
OCaml.

This package is obsolete and no longer supported by OCaml 4.09 and over.
Users should switch to the new PPX infrastructure or use Camlp5.

Build dependencies

devel/ocamlbuild pkgtools/cwrappers devel/ocamlbuild

Runtime dependencies

lang/ocaml

Binary packages

OSArchitectureVersion
(none)

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.